VirtualBox

Ticket #5351 (closed defect: wontfix)

Opened 4 years ago

Last modified 4 years ago

Missing dependencies in RPMs

Reported by: ToddAndMargo Owned by:
Priority: major Component: installer
Version: VirtualBox 3.0.8 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Hi All,

Files involved:

VirtualBox-3.0.8_53138_rhel5-1.i386.rpm VirtualBox-3.0.8_53138_rhel5-1.x86_64.rpm

You are missing the following dependencies in your RPM:

gcc kernel-headers

Placing these dependencies in your spec file would eliminate some pretty nonsensical error messages, like the following:

# /etc/init.d/vboxdrv setup Stopping VirtualBox kernel module [ OK ] Recompiling VirtualBox kernel module [FAILED]

(Look at /var/log/vbox-install.log to find out what went wrong)

# cat /var/log/vbox-install.log Makefile:147: * Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again. Stop

As gcc and kernel-headers are absolutely necessary to operate Virtual Box, they need to be set as dependencies in the spec file.

Workaround: yum install gcc kernel-headers

Many thanks, -T

Change History

comment:1 Changed 4 years ago by ToddAndMargo

VirtualBox-3.1-3.1.0_55467_rhel5-1.x86_64.rpm still has this problem.

comment:2 Changed 4 years ago by frank

I don't want to add a strong dependency to the kernel headers. In Debian, there is a weak dependency which is appropriate but a strong dependency isn't in my opinion. The reason is that even kernel-headers could be wrong if the user uses another kernel than the default kernel. And it might be a use case to edit VM configurations on a machine without the intension to start a VM.

comment:3 Changed 4 years ago by ToddAndMargo

Hi Frank,

.deb and .rpm are apples and oranges. If you do not install the dependencies in the RPM format, these are the misleading errors the user is going to get. The errors I am showing here are with a fresh install of Cent OS 5.4x64 on a blank hard drive. This has happened to me twice. Note that these bogus error messages have absolutely nothing to do with the missing dependencies.

Please impalement this as a kindness to your users. Had I not a long experience with Virtual Box, I would have never figured out the misleading (bogus) error messages.

Many thanks, -T

bogus error messages

# rpm -ivh VirtualBox-3.1-3.1.0_55467_rhel5-1.x86_64.rpm ... Compilation of the kernel module FAILED! VirtualBox will not start until this problem is fixed. Please consult /var/log/vbox-install.log to find out why the kernel module does not compile. Most probably the kernel sources are not found. Install them and execute

/etc/init.d/vboxdrv setup

as root.

And

# /etc/init.d/vboxdrv setup Stopping VirtualBox kernel module [ OK ] Recompiling VirtualBox kernel module [FAILED]

(Look at /var/log/vbox-install.log to find out what went wrong)

# cat /var/log/vbox-install.log Makefile:147: * Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again. Stop

comment:4 Changed 4 years ago by frank

No need to post the output here, I know the error message. What I was saying is that adding this dependency would only improve this situation for some users, not for the general user. And by pointing to the weak dependency of .deb packages I gave an example how to make this better. IMHO weak dependencies are one important feature which .rpm package is missing by design. But that's another discussion I don't want to start here.

comment:5 Changed 4 years ago by Technologov

OK, in such a case it would be wise to CLOSE this bug as "WONTFIX".

-Technologov

comment:6 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use