VirtualBox

Ticket #53 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

Red Hat Linux 7 as guest crashes VirtualBox

Reported by: Technologov Owned by:
Priority: minor Component: other
Version: VirtualBox 1.3.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Red Hat Linux 7 (2.2 kernel) crashes VirtualBox. It happens on kernel boot, right after boot loader.

This crash doesn't look like a normal crash (no error messages), it just closes the VM window immediately.

Software: openSUSE 10.2 Linux, VirtualBox 1.3.4 Full.

-Alexey Eremenko

Change History

comment:1 Changed 7 years ago by Technologov

To maker life easier for you, I have decided to put a ISO for download.

Red Hat Linux 7 ISO link:

 http://www.yousendit.com/transfer.php?action=check_download&ufid=5E593B076DC3ABB6&key=19137d077e823eb1ca84093007dddbe819bbbfaa

Steps to reproduce:

  1. download this image
  1. start a virtual Box 1.3.4 with this ISO inside
  1. press enter to start installing RHL 7
  1. VirtualBox will crash

NOTE: due to many conversions this file got, ISO's checksum will not be original, but the rpm's that are inside are 100% original. Original or not, it should NOT crash VirtualBox.

Additional info: Red Hat Linux 7 is an ancient Linux Operating system, released in 2000, running on kernel 2.2. It has KDE 1 and GNOME 1.

-Alexey Eremenko

comment:2 Changed 7 years ago by achimha

Thanks for the testcase. We will look into it. You are correct: it should not crash VirtualBox. Most likely it causes a guru meditation (a release assertion to aid debugging).

comment:3 Changed 7 years ago by achimha

  • Priority changed from critical to minor

I can reproduce the problem. It triggers a situation we have not implemented support for yet. We will probably look into it but it has a low priority

comment:4 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Doesn't crash here. I get up to the textmode selection box for language. Could be the same thing as the syllable bug you reported before.

comment:5 Changed 7 years ago by Technologov

Fix verified. This doesn't crash on boot now.

Tested on: Windows Vista, VBox 1.4.0.

RHL 7 still crashes in the mid of install stage however.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use