VirtualBox

Ticket #5286 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Cannot start VM after Windows Update

Reported by: yrro Owned by:
Priority: critical Component: network
Version: VirtualBox 3.0.8 Keywords: dataloss
Cc: Guest type: Linux
Host type: Windows

Description

While my virtual machine was running, Windows Update upgraded the driver for my ethernet interface.

I then suspended the VM and shut the machine down.

Now that I have booted back up, I am unable to start the VM, and because the VM is suspended, I am unable to access its settings! My only option is to throw away my work by discarding!

Failed to start the virtual machine wintermute.

VM cannot start because the host interface 'Realtek RTL8186C(P)/8111(P) Family PCI-E GBE NIC' does not exist.

Details

Result Code: VBOX_E_HOST_ERROR (0x80BB0008) Component: Console Interface: IConsole {0a51994b-cbc6-4686-94eb-d4e4023280e2}

Change History

comment:1 Changed 4 years ago by gimel

Confirmed and it's a pain in ... :-(

One solution would be if VB could use the interface name not its type.

comment:2 Changed 4 years ago by gimel

"name" means, the name you can change in Windows. Doing this, one could rename the interface and fix the situation.

comment:3 Changed 3 years ago by yrro

It would be better if it disabled the virtual network adapter instead of refusing to start the VM at all.

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This issue should be fixed in VBox 4.0.4. In case the network interface does not exist anymore, the user is still able to resume the VM and can change the network attachment.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use