VirtualBox

Ticket #5283 (closed defect: obsolete)

Opened 4 years ago

Last modified 3 months ago

CentOS 5.0 Final installer will not start on Windows 7 i386 Host

Reported by: surlypatron Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords: CentOS 5, Windows 7
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

I am unable to boot from the CentOS 5.0 Final i386 installation DVD, the ISO file for which I have mounted in VirtualBox.

Whenever I boot from the DVD, the installation screen appears, and I issue the command linux text and press ENTER. There is some output to the console, but the VM freezes at

NET: Registered protocol family 2

The SHA1 checksum of the installation disc, CentOS-5.0-i386-bin-DVD.iso, is:

d4aa041570417eeecee9021e6f8bcc845e65145a

The VirtualBox log file is attached.

Attachments

VBox-5283.log Download (29.8 KB) - added by surlypatron 4 years ago.
VBox.log Download (65.2 KB) - added by tortilla 4 years ago.
Log with IO-APIC disabled
CentOS 5.xml Download (6.4 KB) - added by tortilla 4 years ago.
Config with IO-APIC disabled
VBox.2.log Download (66.8 KB) - added by tortilla 4 years ago.
Log with IO-APIC enabled
CentOS 5.2.xml Download (6.4 KB) - added by tortilla 4 years ago.
Config with IO-APIC enabled
CentOS_1-2011-03-15-18-41-57.log Download (64.9 KB) - added by tortilla 3 years ago.
VBox.3.log Download (66.6 KB) - added by tortilla 3 years ago.
SVM on

Change History

Changed 4 years ago by surlypatron

comment:1 Changed 4 years ago by surlypatron

This issue has existed for over three years (since VirtualBox 1.3.8). See:

 http://www.virtualbox.org/ticket/370

Editing grub.conf to include "noacpi nolapic" is not an acceptable solution; this is a problem with VirtualBox, not with CentOS (or any other OS).

comment:2 Changed 4 years ago by frank

Ticket #370 is not related to your problem as you are using an AMD CPU. Any reason why you didn't enable AMD-V for that VM? Enabling this setting could make that VM work.

comment:3 Changed 4 years ago by surlypatron

I guess you're the programmer, so I'll concede that my problem is not related, even though the boot process halts at the exact same place ("NET: Registered protocol family 2") and is resolved with the exact same steps (boot the kernel with the "nolapic" option), as described in #370.

I did enable AMD-V, initially, but switched it back off in an effort to troubleshoot. I am able to turn on all of the "bells and whistles" (i.e., AMD-V, Nested Paging, ACPI, IO APIC, PAE/NX, etc.) and the OS boots without issue, provided that I pass the "nolapic" argument to the kernel.

User "Technologov" commented in #370 that it's not practical to test my configuration because my hardware is exceedingly rare. Really? A company of Sun's financial fortitude can't spring for the few hundred bucks required to build a comparable system and fix this problem? One would think that a company with Sun's resources would already have "one of everything" laying around for testing purposes. I suppose that I've overestimated the scope of the VirtualBox project.

comment:4 Changed 4 years ago by tortilla

I have a same issue with VirtualBox 3.2.6, CentOS 5.5 i386, and Windows 7 x86_64 on AMD Athlon2 x4. But with IO APIC enabled in VM's properties installation process doesn't freezes.

comment:5 Changed 4 years ago by frank

Current versions of VirtualBox enable the I/O-APIC for 64-bit guests but not for 32-bit guests. Currently I'm not sure how CentOS 5 guests behave with a disabled I/O-APIC, will check that.

comment:6 Changed 4 years ago by tortilla

I'm sure I have 32-bit guest. Here are logs with disabled I/O-APIC and with enabled.

Changed 4 years ago by tortilla

Log with IO-APIC disabled

Changed 4 years ago by tortilla

Config with IO-APIC disabled

Changed 4 years ago by tortilla

Log with IO-APIC enabled

Changed 4 years ago by tortilla

Config with IO-APIC enabled

comment:7 Changed 4 years ago by frank

CentOS 5 / 32-bit boots without problems here. To make the guest behave better, add 'divider=10' to the guest grub command line. Adding this parameter will force the guest to use a 100 Hz timer instead of a 1000 Hz timer. Note that it can take some time until the guest boots, especially if you don't have added the divider parameter yet. You should wait up to 2 minutes if the guest will actually boot or not.

comment:8 Changed 4 years ago by tortilla

It definitly doesn't boot with IO-APIC disabled with or without 'divide=10'. I have waiting over 30 minutes. With IO-APIC enabled everything is ok, system boots and run fine.

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

comment:10 Changed 3 years ago by tortilla

  • Status changed from closed to reopened
  • Resolution fixed deleted

Still in VBox 4.0.4

comment:11 Changed 3 years ago by frank

  • Version changed from VirtualBox 3.0.8 to VirtualBox 4.0.4

Could you attach a VBox.log file for such a 4.0.4 VM session? Because we cannot reproduce this issue ...

Changed 3 years ago by tortilla

comment:12 Changed 3 years ago by frank

Any idea why SVM is disabled on your host? Could you check the BIOS if there is some option to enable "virtualization support"?

comment:13 Changed 3 years ago by tortilla

Yes There is an option "Secure Virtual Machine Mode" in CMOS Setup. But CentOS still can't be loaded with this option enabled.

Changed 3 years ago by tortilla

SVM on

comment:14 Changed 3 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use