VirtualBox

Ticket #5201 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

VB wasn't rebuilt following kernel upgrade; DKMS is installed.

Reported by: dimitris Owned by:
Priority: minor Component: other
Version: VirtualBox 3.0.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I installed 3.0.8 on an Ubuntu Karmic host a few days ago. At that time the host was running kernel 2.6.31-11 or -12, not sure which.

The host has since been upgraded to 2.6.31-13. When I tried to start a VM, I got the "no driver present" error message along with the suggestion to install DKMS.

This machine has DKMS installed and had it when the kernel was upgraded.

Any ideas?

Change History

comment:1 Changed 5 years ago by dimitris

Forgot to mention, sudo /etc/init.d/vboxdrv setup reinstalled without any problems, and I'm happily running my guest now.

comment:2 Changed 5 years ago by dimitris

This might have been a dkms issue on Karmic. After a kernel upgrade, albeit only a change within the 2.6.31-13-generic current on Karmic, DKMS did pick up VB's dependency and rebuilt on reboot.

comment:3 Changed 5 years ago by michael

I saw this once a while ago on Jaunty. The dkms maintainer suggested that if that really did happen then it was a dkms bug, but since I was never able to reproduce it we dropped the issue.

comment:4 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

comment:5 Changed 5 years ago by sandervl73

Let's assume it's a DKMS bug then. If it works one time and fails the other, then it's rather unlikely to be a VirtualBox problem.

comment:6 Changed 5 years ago by michael

Just checked again (it was a while back), and what I saw was actually something different - the modules *were* rebuilt by dkms, but at the next reboot, not at the time the kernel headers were upgraded (which is what should have happened).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use