VirtualBox

Ticket #5152 (new defect)

Opened 5 years ago

USB Mouse stops working

Reported by: kwchristensen Owned by:
Priority: minor Component: USB
Version: VirtualBox 3.0.8 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I have a laptop running a Windows 7 host and have Windows XP and Ubuntu 9.04 guest OSes under VBox 3.0.6. I need to exclusively use XP for some work so it is often running at least in the background. I also often need move from desk to desk around the office, but i really despise the touchpad so I carry a wireless mouse with me. Since I need XP for work I have a USB filter to automatically redirect ALL usb devices (ie usb flash drives) to the guest (XP) and bypass the host (USB filter set to "YES"). Guest additions are installed.

This issue I am having is when I need to move more than just a few feet. In this case I unplug my mouse so the computer fill fit in the briefcase - the USB receiver sticks out too far to leave it plugged in. Regardless of if I suspend my computer or leave it running, when I plug the mouse back in the mouse does not behave correctly. When I plug it in the cursor can only be moved by the touchpad, which still works seemlessly between the guest and host. However, the USB mouse only works in the guest OS and it is a second INVISIBLE CURSOR. I can tell the mouse still works because i can left and right click and the appropriate actions occur when the cursor should be. However, the visible cursor only moves when you use use touchpad yet both will interact with the guest simultaneously. I also tried in addition to a USB filter for all devices to add a second filter as an exception for the mouse. When I set the filter for the mouse "No" seemed the logical choice; my understanding is that setting should give control to the host always and everything would work as expected in theory. However when I set this filter it disabled the mouse completely in the guest AND in the host (although the touchpad still worked). I changed the settings to "Any" and "Yes" just to see what would happen and the mouse was completely disabled under those settings as well. As soon as the guest was closed the mouse started working again.

So, I tried setting changing the USB filter to "ANY" but it acts exactly the same. I changed it to "NO" but it also behaves the same way - but setting it to "NO" defeats my purpose of rerouting the USB devices so I changed it back to "YES". If I disable the filter then it behaves as it should and both the mouse and touchpad will control the cursor when I remove and reattach the mouse.

I do not know if this would be a bug since it obviously is a USB mouse and I have USB devices directed to the guest. Regardless, it seems that a mouse should be a special case since it works as it should with the filter enabled as long as I either shutdown or save and close the guest. The only time I have any issues with the mouse, even with the filter enabled, is when I unplug it and reattach it with the guest running.

Generally I use an XP Guest and that is where I discovered this issue, however it is repeatable with Ubuntu Guest as well so it is not a Windows issue. Any advice or suggestions would be appreciated.

*Update: I upgraded to 3.0.8 and saw that a USB bug had been fixed, however it did not quite fix this issue although it did change it slightly. When I plug in the USB mouse Windows (host) now detects the mouse and does the PnP installing thing. Once that finished though the mouse still does not work in the host or the guest until I shut down the guest. The second "invisible cursor" effect no longer happens, its as though the guest now does not recognize the device at all. Lastly, now the host will not utilize the mouse until I unplug it and reattach it after the guest is closed - before once the guest was closed the mouse started working but this is no longer the case.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use