VirtualBox

Ticket #5095 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Incoherent network connection causes Virtualbox to freeze

Reported by: MoC Owned by:
Priority: critical Component: network/NAT
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Hi,

I use VirtualBox on Windows XP SP3 to run Fedora 11 (I'm pretty sure though, that this problem does not depend on the type of the guest system, it also occured on e. g. Ubuntu 9.04.) and use a NAT to connect the virtual machine to my internet connection. I'm in a network with a traffic shaper, which causes the transfer rate to "jump around". Whenever the speed is near or equal 0, VirtualBox will freeze consuming all available CPU resources and is almost completely inresponsive. Now, I know that tickets like #2888 but since I don't know wether they are in a similiar network I thought I'd better open a seperate ticket. Frankly I cannot provide a log file since VirtualBox seems to write the logs to disk only if it exits dignifiedly (Why is that so?), but I made a screenshot showing the network load ("Netzwerk" tab in the task manager, above connection) and a snapshot of the CPU usage ("CPU-Auslastung" in the status bar of the task manager). This really is a blocker and I'd be really thankful if you could fix it as soon as possible.

Attachments

VirtualBox-IceCold.png Download (187.5 KB) - added by MoC 5 years ago.
VirtualBox freezing.
VBox.log Download (63.8 KB) - added by MoC 5 years ago.
VBox.2.log Download (50.2 KB) - added by MoC 5 years ago.
Log created during a "problematic" session.

Change History

Changed 5 years ago by MoC

VirtualBox freezing.

comment:1 Changed 5 years ago by Hachiman

Could you please look at your home directory, find .VirtualBox\Machine\<your-machine-name>\Logs\VBox.log and attach it to the ticket?

comment:2 Changed 5 years ago by Hachiman

  • Component changed from network to network/NAT

Changed 5 years ago by MoC

comment:3 follow-up: ↓ 4 Changed 5 years ago by MoC

Like I said, it did not create a log (and I assume it's because I killed the process, though that's not good practice - if my assumption is true). The VBox.log is from a later session where I did not use the internet connection. But in case it still can help, I attached it.

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 5 years ago by Hachiman

Replying to MoC:

Like I said, it did not create a log (and I assume it's because I killed the process, though that's not good practice - if my assumption is true).

Hm ... sounds strange ...

The VBox.log is from a later session where I did not use the internet connection. But in case it still can help, I attached it.

Yes, please.

Changed 5 years ago by MoC

Log created during a "problematic" session.

comment:5 in reply to: ↑ 4 Changed 5 years ago by MoC

Replying to Hachiman:

Hm ... sounds strange ...

Ok, I do have to correct myself, it might very well be that it created a log file, I missleadingly assumed that even if you kill a process, Windows would update the mtime. Sorry for that. I reproduced above situation and attached the correct log.

comment:6 Changed 5 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate #2845

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use