VirtualBox

Ticket #5092 (new defect)

Opened 5 years ago

Last modified 4 years ago

USB storage devices can't be mounted

Reported by: spaaarky21 Owned by:
Priority: major Component: USB
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

When I connect a USB storage device (flash drive or external hard drive) to my Mac host, Virtual Box captures it but the Windows guest reports that it is malfunctioning, saying "USB device not recognized - one of the USB devices attached to this computer has malfunctions, and Windows does not recognize it." This errors started occurring only after I upgraded from Virtual Box 2.x to 3.0.x. Other users have had similar experiences -  http://forums.virtualbox.org/viewtopic.php?f=8&t=22186

Please let me know if there is any additional information I can provide.

Attachments

VBox.log Download (41.9 KB) - added by spaaarky21 5 years ago.
VBox.2.log Download (74.1 KB) - added by ukchucktown 4 years ago.

Change History

Changed 5 years ago by spaaarky21

comment:1 Changed 5 years ago by edderrd

This also affects me on Ubuntu 9.04 host machine.

comment:2 Changed 5 years ago by fudgefactor

I have a 64-bit Snow Leopard Host running Windows XP guest with USB 2.0 enabled. My machine is a 2009 MacBook Pro with 4GB of RAM. Any USB device I connect to the Virtual Machine shows up as an unknown device under windows. I have tried a Kingston Data Traveler flash drive and a Safenet Sentinel Security Key. In both cases, windows complains it is an unknown device. Under the device properties, I notice that windows doesn't know the vendor ID or the product ID for the USB device. This is the Device Instance ID reported by Windows Device Manager when I plug in my Data Traveler flash drive:
USB\VID_0000&PID_0000\5&1ED81D73&0&1

I obtained the vendor and product ID for the flash drive:
Device VendorID/ProductID: 0x0951/0x1605 (Kingston Technology Company)

This is what is reported by the VirtualBox log when the devices are attached:
00:07:37.736 VUSB: attached '0000000118ec0220[proxy 04b9:8000]' to port 1
00:07:37.740 OHCI: USB Operational
00:08:13.687 OHCI: USB Suspended
00:08:14.590 OHCI: USB Operational
00:08:15.222 OHCI: USB Suspended
00:08:22.546 VUSB: attached '000000013d757150[proxy 04b9:8000]' to port 1
00:08:22.551 OHCI: USB Operational
00:08:49.952 OHCI: USB Suspended

comment:3 Changed 5 years ago by fudgefactor

An additional note: I have noticed this problem is still there in version 3.0.8.

comment:4 Changed 5 years ago by fudgefactor

The vendor and product ID for the security key that I used for the test outlined above is:
Device VendorID/ProductID: 0x04B9/0x8000 (Rainbow Technologies, Inc.)

comment:5 Changed 5 years ago by spaaarky21

As information, I am having the problem with 3.0.8 as well and I use a USB filter in VirtualBox with the vendor and product ID's empty, to capture all devices that are connected.

comment:6 Changed 4 years ago by ukchucktown

I also have the problem with 3.08 and OS X 10.6.1. I'm using Linux guests and none of them can access a USB external drive on an OS X host. If I run fdisk -l from the Linux guest nothing shows up. I have tried USB filters and the eject trick without success. It appears as though VirtualBox captures the port but still no luck.

comment:7 Changed 4 years ago by benlau

I also have problem with VirtualBox 3.08 on OS X 10.6.1 with a Linux guest (Ubuntu 9.04). However, the behaviour is different than the one reported by ukchucktown. Not every USB thumb drive fail with this configuration. I have two 2GB/8GB usb thumb drives made by Toshiba are able to be mounted on the guest. But another 8GB thumb drive made by Toshiba is failed.

comment:8 Changed 4 years ago by doggkruse

I see this problem with a Mac OS 10.6.1 Host and Windows XP Guest. Any USB device assigned to the Guest will be reported as Malfunctioning. In the Guest, the Vendor and Product ID's are 0000. This seems to be directly related to having more than one processor assigned to the guest. If the guest is limited to one processor, all USB devices work as expected.

comment:9 Changed 4 years ago by fudgefactor

doggkruse, thanks for the workaround. I had originally set my virtual machine to use 2 processors. Switching to one processor works as advertised. Thanks a lot. This has been driving me crazy.

comment:10 Changed 4 years ago by spaaarky21

Changing the VM's processor count back to one worked for me too. What an odd cause for the problem.

comment:11 Changed 4 years ago by spaaarky21

On a possibly related note, when I upgraded to 3.0.6 and started having trouble with USB devices not mounting, I also noticed that VirtualBox no longer seems to release devices when unchecked from the "USB devices" menu. Previously, unchecking a USB drive would release it to the host, allowing it to mount it. However, returning the VM to one processor doesn't seem to fix this problem.

comment:12 Changed 4 years ago by ukchucktown

This is also a problem with Linux guests under OS X and the number of processors makes no difference. I'm able to work with a Sandisk Cruzer USB flash drive without any problems from a Kubuntu 9.10 guest. My USB hard drive (Western Digital) in a Rocketfish enclosure does not work from the VM. I have tried myriad combinations of USB filters, plugging in at different times (before and after VM startup) and the results are always the same. The drive is captured by VirtualBox briefly then unavailable. Once it disappears no USB devices are listed in the Devices menu (it's empty instead of listing the devices disabled). I also have VM shutdown problems if I keep the USB hard drive powered on during the shutdown.

Changed 4 years ago by ukchucktown

comment:13 Changed 4 years ago by pasi

I confirm ukchucktown observation. I have two hosts OS X and XP running Ubuntu 9.10 guest with one processor. In OS X My LaCie USB hard drive (FAT32) is/stays "gray" while in XP I can access it.

VirtualBox 3.0.12. Mac OS 10.5.6.

In XP the virtualbox unmounts LaCie from the host and mounts it to guest Linux automatically. Unmount+mount takes 20-30 seconds, but it works. When using OS X, LaCie is never unmounted from the host, and I believe therefore LaCie stays grayed in virtualbox. I desperately tried manual unmount, but it did not help.

When I tried this for the first time on XP, I experienced somewhat similar misbehaviour. This was, perhaps, due to the fact that I did not have virtual box USB driver installed on XP-host. After the second trial Windows informed me about new the virtual box USB driver and, it worked. My guessing for the bug is that either: a) virtual box USB driver in OS X is missing or buggy, and/or b) driver and OS X version of virtual box do not communicate properly.

comment:14 Changed 4 years ago by spaaarky21

Out of curiosity, when did everyone here create their trouble VM? I was having a problem where, even with 2 CPU's setup for the guest, the VM process wasn't using more than 50% of the host's CPU time. That turned out to be a problem where my Windows installation was using a non-SMP kernel since it was installed when I was only running on one CPU. To fix that, I reinstalled Windows and my USB problem seems to be solved (although now I have other performance problems.)

comment:15 Changed 4 years ago by berlichman

For what it's worth - had same problem - greyed out USB flash drives in XP with 3 different flash drives (4 and 8 GB) - host is Mac OS X ver 10.6.2 on a MacBook - latest version of VBox.

However, just bought a 64GB flash drive (Kingston DataTraveler 150 from China for $23 incl shipping on Ebay) and, lo and behold, XP recognizes it!! Go figure! New drive is "USB 2.0 compliant and 1.1 compatible".

Bruce

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use