VirtualBox

Ticket #505 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

Log viewer opens arbitrary files, not only Log files

Reported by: padde Owned by:
Priority: major Component: other
Version: VirtualBox 1.4.0 Keywords:
Cc: Guest type: other
Host type: other

Description

VirtualBox 1.4.0 (closed source) on Gentoo Linux opens all files in my ~ directory (/home/patrick) when I trigger the "Show Log..." option from "Machine" menu in the VirtualBox GUI. This only happens after a virtual machine has been started and stopped.

Change History

comment:1 Changed 7 years ago by sandervl73

We are unable to reproduce this. Can you describe step by step how this happens for you?

comment:2 Changed 7 years ago by padde

Ok, this is what I do:

Power up the host, load the vboxdrv kernel module. Start up the VirtualBox GUI which has exactly one VM registered. If I press CTRL-L there, I get four log files in the viewer, namely VBox.log, VBox.log.1, VBox.log.2 and VBox.log.3. Now I press the "Start" button and do stuff in the VM. I shut it down, it shows "Powered Off" in the GUI. I press CTRL-L, get quite some disk activity, and after a couple of seconds the Log viewer opens with files from my ~ directory in the tabs. Screenshot:  http://p173.de/s/1185188534.png. This log file, which resides in my ~ dir, seems to be a couple of days old, and it's the only one of its kind - why it's there, I don't know. I guess my VirtualBox installation is somehow screwed, due to having installed the open source version first, then uninstalled it and installed the closed source version.

comment:3 Changed 7 years ago by padde

All this is somehow related to a file called 2007-07-16-16-06-08.089-VirtualBox-14904.log which resides in my home directory. If it resides there, the problem occurs. If not, it does not. The content of this file is available here:  http://rafb.net/p/b1VzNs75.html

Hope this helps with debugging...

comment:4 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if it still happens. We have never been able to reproduce this.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use