VirtualBox

Ticket #5002 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

kCGErrorFailure on Mac OS X 10.6.x Host with VBoxManage -> fixed in SVN/3.0.8

Reported by: mcptron Owned by:
Priority: major Component: VM control
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

When calling VBoxManage (e.g. startvm) the following error message appears if there is no graphical session for the current user on the host system. this makes it impossible to start a headless vm from a hosts system startup script.

VBoxManage[744] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.

Change History

comment:1 Changed 5 years ago by mcptron

See also this forum thread which discusses pretty the same issue:

 http://forums.virtualbox.org/viewtopic.php?f=8&t=21888

thx & rg. michael

comment:2 Changed 5 years ago by poetzsch

  • Summary changed from kCGErrorFailure on Mac OS X 10.6.x Host with VBoxManage to kCGErrorFailure on Mac OS X 10.6.x Host with VBoxManage -> fixed in SVN

The problem is fixed in SVN & the fix will be included in the next minor release.

comment:3 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from kCGErrorFailure on Mac OS X 10.6.x Host with VBoxManage -> fixed in SVN to kCGErrorFailure on Mac OS X 10.6.x Host with VBoxManage -> fixed in SVN/3.0.8
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use