VirtualBox

Ticket #4978 (closed defect: fixed)

Opened 5 years ago

Last modified 2 years ago

Can't uninstall old VirtualBox version 2.2.0

Reported by: tps800 Owned by:
Priority: critical Component: installer
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Trying to remove VirtualBox via Software -> Remove leads to a starting Installer looking for data, then, after some work being done to a rollback because of some fatal error.

I have tried some of the tips given to remove VirtualBox anyway, but without success. Now I am stuck with the old Version 2.2.0 without being able to install the new version 3.0.6 just because this installer first calls the uninstaller for the installed version which fails!

Attachments

MSId37f8.zip Download (28.2 KB) - added by tps800 5 years ago.

Change History

Changed 5 years ago by tps800

comment:1 Changed 5 years ago by loomy

I have the same problem

comment:2 Changed 5 years ago by tps800

I could at least remove the old version by doing the following:

  1. Remove all devices associated with virtual box, mainly the TAP interface
  2. Go into the registry and search for all Keys holding VirtualBox or the install path. Be sure only to delete what you know what ist associated with VirtuaBox!
  3. Reboot
  4. Remove the directory VirtualBox was installed in.
  5. Install the new version.

Clear: since I do not know what VirtualBox installed into %SystemRoot% and down, I am sure I do not catch all installed files this way. But it enabled me to install the new version at least.

I dug into why the installer failed then rolling back: looks a lot like it failed removing the TAP drivers and related files. This because OpenVPN installes TAP devices too and VirtualBox doesn't find the related files installed by OpenVPN assuming them installed by itself --- bad assumtion!

Since driver remove did not help out I had a closer look at related files. These where those blocking uninstalling VirtualBox.

I tried to uninstall VirtualBox 3.0.6 after installing it successfully. This worked. But since there wasn't any upgrade to OpenVPN since maybe it will break again afterwards :-( )-:

comment:3 Changed 4 years ago by pentagonik

Still relevant for VBox 3.1?

comment:4 Changed 4 years ago by tps800

Yes --- If you upgrade from 2.2.0. Upgrades from versions after 2.2.0 have no problems at all!

For me this was the last upgrade to an actual version from 2.2.0 --- It was the last time I could Test it. All hardware under my control is now at least at version 3.0.1!

comment:5 Changed 4 years ago by Technologov

The bug is in the UnInstaller of VBox 2.2.0. I am not sure if VBox 3.1.x installer can workaround old uninstaller bugs.

-Technologov

comment:6 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use