VirtualBox

Ticket #4901 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Host Only network does not work if there is no real network connection

Reported by: faz Owned by:
Priority: major Component: network
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

I am trying to have a virtual network between Host (OS X 10.5.8) and a windows VM (Win XP Pro SP3). I am out of office and I have not any network available and no modem connection. So I have tried to use configure the VM to use Host Only network, but it seems not possibile to have it work.

If you try to set such option in the VM, you need to select the interface from the list below, but there is no option to choose.

If you go to Virtual Box preferences about network, again, there is no virtual network adapter listed. You can create one but when you leave preferences the virtual adapter is gone too. If you try add it again, the virtual adapter count is increased by one unit but again it is lost from the list. Anyway if you go to the VM settings, there is no virtual adapter listed when you select the Host Only.

So it seems not possible to create a network between host and client vm.

If I connect the computer to a network or make a modem connection, then network interfaces are listed and I can configure host only network. The problem is that as soon as you disconnect from real network, all interfaces are lost and the VM reports an error message about "inexistend network interface". So you have do change it to something else to start it again.

Change History

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use