VirtualBox

Ticket #4900 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Host Only network does not work if there is no real network connection

Reported by: faz Owned by:
Priority: major Component: network
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

I am trying to have a virtual network between Host (OS X 10.5.8) and a windows VM (Win XP Pro SP3). I am out of office and I have not any network available and no modem connection. So I have tried to use configure the VM to use Host Only network, but it seems not possibile to have it work.

If you try to set such option in the VM, you need to select the interface from the list below, but there is no option to choose.

If you go to Virtual Box preferences about network, again, there is no virtual network adapter listed. You can create one but when you leave preferences the virtual adapter is gone too. If you try add it again, the virtual adapter count is increased by one unit but again it is lost from the list. Anyway if you go to the VM settings, there is no virtual adapter listed when you select the Host Only.

So it seems not possible to create a network between host and client vm.

If I connect the computer to a network or make a modem connection, then network interfaces are listed and I can configure host only network. The problem is that as soon as you disconnect from real network, all interfaces are lost and the VM reports an error message about "inexistend network interface". So you have do change it to something else to start it again.

Attachments

VBox.log Download (49.2 KB) - added by faz 5 years ago.

Change History

Changed 5 years ago by faz

comment:1 Changed 5 years ago by lRem

I experience the same problem on more or less the same setup. I have a bunch of guests all with host-only networking. If I pull out the ethernet plug while they are down, the guests fail to start at all. If I do it once a guest is running the connection does not break, but the other guests still refuse to start.

comment:2 Changed 5 years ago by webjunk

Experiencing the same problem on Snow Leopard host with Ubuntu guest machines. Host only works fine when a host network connection is present. Without one I can't start up machines. Only network interface option when host is disconnected from networks is "None Selected."

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in VBox 3.0.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use