VirtualBox

Ticket #4820 (closed defect: fixed)

Opened 5 years ago

Last modified 2 years ago

Unable to boot OpenSolaris build 118 on VirtualBox 3.0.4 (Ubuntu host)

Reported by: adamretter Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Solaris
Host type: Linux

Description (last modified by frank) (diff)

VirtualBox 3.0.4 on Host Ubuntu 9.04 x64.

Booting fails with OpenSolaris build 118 guest, either live dvd from Genunix or an existing 2009.06 install that has been updated to build 118 from the dev pkg repository.

In VirtualBox I have tried both switching on and off - Enable ACPI, Enable IO APIC, Enable PAE/NX and choosing 1 or 2 CPU's.

When booting build 118 from the live dvd, shortly after the Grub boot menu, I get this error -

unexpected trap instruction pointer 0x28 error code, optional 0x7 code segment 0x82 flags register 0xfffffffffbc4edf0 return %rsp 0x8 return %ss 0x2 Attempting stack backtrace: Stack traceback:

0x28) 0x4c000000b8ec8148

unexpected trap in early boot Press any key to reboot.

When booting the upgraded 2009.06 to build 118, shortly after the grub menu I only see the loading status screen, but pressing any button results in a reboot, so I would guess the problem is the same.

Attachments

VBox.log Download (44.4 KB) - added by torindel 5 years ago.
3.0.8 logs

Change History

comment:1 Changed 5 years ago by torindel

adamretter what cpu?

I got same problem on my x86_64 gentoo with Phenom 9850 cpu with 8GB ram and gf 9800gtx, march=barcelona while my friend whose pc differences only with Athlon X2 cpu, lesser ram amount and gf 8800, march=k8 have not (same versions of glibc, gcc, xorg etc, tested his kernel/modules too).

Tested on virtual box ose/bin 3.0.4/3.0.6/trunk with all option combinations, screenshoot depending on options:  http://img38.imageshack.us/img38/6900/122zw.png ,  http://img24.imageshack.us/img24/8651/1222s.png[[BR]]

Last opensolaris that boots is 2009/06, checked b117-b122.

comment:3 Changed 5 years ago by frank

Please attach VBox.log files and re-check with VBox 3.0.8.

Changed 5 years ago by torindel

3.0.8 logs

comment:4 Changed 5 years ago by torindel

looks the same on 3.0.8, attached logs with stock solaris/opensolaris 64 settings on ose

comment:5 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.1.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use