VirtualBox

Ticket #4797 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

VBox refuses to start VM's reports VM driver not accessible

Reported by: marsh Owned by:
Priority: major Component: installer
Version: VirtualBox 2.0.10 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

Upgraded to VirtualBox 2.0.10-50334 from 2.0.8-44071. After upgrade Vbox immediately began reporting VM inaccessible errors (See error report below).

Recompiled kernel modules using /etc/vboxdrv setup command with same result.

Downgraded back to 2.0.8 VBox is back to working.

VBox does not appear be logging to the VBox.log file so I have extracted all the vbox messages I could find in other log files. Admittedly it is not much to go on but it is all that I have available.

Distro: Ubuntu (Dapper 6.06LTS)
Platform: AMD64
Kernel 2.6.15-54

Error Reports from VBox:

VERR_VM_DRIVER_NOT_ACCESSIBLE (rc=-1909)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Re-setup the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. Users of Ubuntu or Fedora should install the DKMS package at first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

Attachments

vbox.log Download (20.0 KB) - added by marsh 5 years ago.
extracts of various linux log files
vbox-2.0.10.zip Download (53.5 KB) - added by ingo2 5 years ago.
VBox 2.0.10 fails to start VM after upgrade. File /home/ingo/log (strace)

Change History

Changed 5 years ago by marsh

extracts of various linux log files

comment:1 Changed 5 years ago by frank

  • Version changed from VirtualBox 2.0.0 to VirtualBox 2.0.10
  • Component changed from other to installer
  • Description modified (diff)

Well, I'm not aware of any change of the Linux installer between 2.0.8 and 2.0.10. I assume you installed the Dapper (.deb) package from our website, correct?

When you install VBox 2.0.10, what are the permissions of /dev/vboxdrv (/bin/ls -l /dev/vboxdrv)?

comment:2 Changed 5 years ago by ingo2

I can confirm the very same in Ubuntu-Hardy-amd64.

Upgrade from 2.0.8 -> 2.0.10 itself works fine. I can start the VBox-gui without any problems, but as soon as I want to start an existing VM I get following 2 error pop-ups:

They appear one after another with 2 sec. inbetween (bottom row from left to right).

[IMG] http://i28.tinypic.com/16jqbe9.jpg[/IMG]

I also tried to recompile the kernel module -> runs through but problem persists. I checked permissions for /dev/vboxdrv (module gets loaded automatically):

it is:

$ ls -l /dev/vboxdrv
crw------- 1 root vboxusers 10, 63 2009-09-03 15:46 /dev/vboxdrv

This applies to both versions 2.0.8 AND 2.0.10.

I tried to change permissions to 660 and even 666 -> it does not change anything.

I tried to start VBox as root and create a new VM -> the same.

comment:3 Changed 5 years ago by frank

The correct permissions of /dev/vboxdrv are 0660. Are you sure that the current user is member of the vboxusers group?

Doing

sudo chmod u+s /usr/bin/strace
strace -s128 -f -o ~/log /usr/lib/virtualbox/VirtualBox -startvm VM_NAME

and attaching the compressed log file to this ticket could help revealing the problem as well.

comment:4 Changed 5 years ago by ingo2

attaching the compressed log file to this ticket

I have done according to your request and attached the logfile /home/ingo/log zipped to vbox-2.0.10.zip

Hope this is the file you would like to obtain?

BTW: before that tests I issued

chmod 0660 /dev/vboxdrv

and of course I do belong to group vboxusers since version 1.x.x of VBox ;-)

ingo@pp:~$ groups
ingo adm cdrom floppy audio dip video plugdev users fuse lpadmin admin vboxusers uml-net dialout

Changed 5 years ago by ingo2

VBox 2.0.10 fails to start VM after upgrade. File /home/ingo/log (strace)

comment:5 Changed 5 years ago by ingo2

comment:

in Ubuntu-Hardy there exists (by default) already a directory ~/log containing logfiles from 'enigmail'. Had to remove it before I could start the strace and restore it afterwards. Would be nice if VBox did respect that?

comment:6 Changed 4 years ago by Technologov

Still relevant for 3.2.0 ?

-Technologov

comment:7 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use