VirtualBox

Ticket #4788 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

SCSI does not work if ACPI is disabled

Reported by: Hawk Owned by:
Priority: minor Component: other
Version: VirtualBox 3.0.4 Keywords: scsi
Cc: Guest type: Linux
Host type: Linux

Description

I'm using VirtualBox to test my embedded system and I have strange problems with SCSI on Linux guest. Everything works fine on distro kernels, for example vanilla one with this config:

 http://cvs.pld-linux.org/cgi-bin/cvsweb/packages/kernel-vanilla/kernel-vanilla-x86.config?rev=1.1.2.21

And when using my own kernel which I prepared for my embedded system it doesn't work. Here is config which this kernel uses:

 http://cvs.pld-linux.org/cgi-bin/cvsweb/packages/kernel-CRI/kernel-CRI-x86.config?rev=1.1.2.16

When I configure BusLogic controller I got this in dmesg and attached virtual disks are not visible at all:

 http://pld.pastebin.com/f2cb2a

When configured as LSI Logic that appears in dmesg and modprobe hangs disallowing to load any other ide/sata/scsi module:

 http://pld.pastebin.com/f2553d876

When configured as SATA AHCI disks are visible, but terribly slow.

It may look at as a kernel misconfiguration but the very same kernel that fails under VirtualBox works just fine on various real hardware SCSI controllers and under VMware 5.x which I digged out from my archives. I'd be thankfull for any ideas how to get it working under VirtualBox too.

Change History

comment:1 Changed 5 years ago by Hawk

I nailed the problem. SCSI stops working in vbox after disabling ACPI and power management in kernel configuration.

comment:2 Changed 5 years ago by Hawk

Even better, it is sufficient to boot kernel with acpi=off to break scsi.

comment:3 Changed 5 years ago by frank

Problem confirmed. Has something to do with initializing the PCI devices in the guest BIOS. We are working on a solution.

comment:4 Changed 5 years ago by frank

  • Summary changed from Strange problems with SCSI on Linux guest to SCSI does not work if ACPI is disabled

comment:5 Changed 4 years ago by Technologov

VBox 3.1.0 solves (hides) the problem by not allowing disable ACPI via GUI.

-Technologov

comment:6 Changed 4 years ago by frank

Disabling ACPI is still available with VBoxManage modifyvm and this will not be changed in the near future.

comment:7 Changed 4 years ago by Hawk

Besides, even with ACPI enabled in VirtualBox SCSI will still not work if Linux kernel doesn't have ACPI support enabled.

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Most probably solved in VBox 3.1.6. Reopen if necessary.

comment:9 Changed 4 years ago by mostlybrian

  • Status changed from closed to reopened
  • Resolution fixed deleted

Tested VBox 3.1.6 & found issue still exists.

Tried my own kernel (without ACPI) on a newly created VM with buslogic scsi -> same issue as original defect.

A more generally reproducible test

I also repro'd booting Ubuntu (ubuntu-10.04-desktop-i386.iso)

<ESC> -> <F6> (Other Options) -> <Enter> (toggle acpi=off) -> <ESC> -> Try Ubuntu without installing

dmesg shows the "Device offlined - not ready after error recovery" messages at intervals.

If acpi is not disabled during boot, the disk works under Ubuntu.

comment:10 Changed 3 years ago by mostlybrian

Just tried the acpi=off Ubuntu 10.04 test I mentioned previously with VirtualBox 4.0.4-70112 & it appears to function correctly with both buslogic & lsilogic SCSI controllers. [No dmesg spam & when I started the install to disk it did see the disk attached to the SCSI controller.]

Therefore, it appears to me that the defect was fixed sometime between 3.1.6 & 4.0.4 & IMO the defect may now be (re)closed. Yay!

comment:11 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use