Ticket #4777 (closed defect: obsolete)

Opened 7 years ago

Last modified 2 months ago

VESA palette support broken

Reported by: axeld Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by michaln) (diff)

This is broken in several ways:

1) it reports a VBE info block capability of 1, which means, no VGA compatibility (which it is) 2) palette setting via interrupt 0x10, eax 0x4f09 does nothing 3) but also does not return an error

For reference, Qemu does report the correct capability, does not implement the VBE set palette function either, but correctly reports an error when trying to do so.

Change History

comment:1 Changed 2 months ago by michaln

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

This does not reflect the current status.

In the future, please do not report things like "eax 0x4f09 does nothing" but why it matters and how the problem can be reproduced with some existing software.

comment:2 Changed 2 months ago by axeld

The full sentence is "palette setting via interrupt 0x10, eax 0x4f09 does nothing" -- and there isn't really much more to say about this.

However, a test case would have been nice, indeed. I have tested with the "ParticlesII" demo running on Haiku using the VESA driver; the demo is available as part of Haiku's source code, and can be built using "jam ParticlesII".

From reading the VirtualBox source code, it looks like all is fine (both the VGA compatibility flag issue [1], as well as setting the palette (at least there is a function responsible for this no matter if it is actually working)), however, I just tried the demo again, and at least the colors don't change. If there is interest in getting to the bottom of this, I could look into it again and come up with more info, if needed.


comment:3 Changed 2 months ago by michaln

Exactly, the code is there.

It would be great if you could provide a testcase, perhaps in the form of an OVA appliance. There could be some more complex reason why the demo isn't working. Incidentally, is it known that the demo behaves as expected on real hardware?

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use