VirtualBox

Ticket #4679 (closed defect: invalid)

Opened 5 years ago

Last modified 3 years ago

Ubuntu Jaunty + vbox 3.0.4 - right ctrl key does not work when "Locate Pointer" is on -> works by design of X11

Reported by: hanasaki Owned by:
Priority: major Component: GUI
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: other
Host type: Linux

Description

in Gnome go into system/prefs/mouse and enable Locate Mouse when hitting control Start a Linux jaunty GUI as a VM after the VM boots click the mouse inside so the mouse is captured hit the control key to release the mouse

The host GUI will show the mouse location as it should however the mouse will remain captured.

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by davidsarah

I had this bug also in VirtualBox 4.0.4 with Ubuntu Maverick. A workaround is to press Shift-RightCtrl rather than RightCtrl alone. It's a serious bug because it prevents 'uncapturing' the mouse, so if you didn't know about the Shift-RightCtrl workaround, the only way to escape would be to do an unclean power-off of the physical machine.

This bug seems to apply for any host using GNOME/Metacity, and any guest OS. It appears that the host window manager is intercepting the RightCtrl before VirtualBox can see it. Presumably this also happens if the host key is LeftCtrl.

I don't know whether it is possible to disable 'Locate Pointer' only when the mouse is captured; if not, then the user should be warned to either switch it off manually or change the host key to something other than RightCtrl or LeftCtrl. (Note that you cannot change the host key while the mouse is captured.)

comment:2 in reply to: ↑ 1 Changed 3 years ago by davidsarah

Replying to davidsarah:

This bug seems to apply for any host using GNOME/Metacity, and any guest OS.

... so the 'Guest type' field is wrong, but I can't edit that.

comment:3 Changed 3 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid
  • Guest type changed from Linux to other
  • Summary changed from Ubuntu Jaunty + vbox 3.0.4 - right ctrl key does not work when "Locate Pointer" is on to Ubuntu Jaunty + vbox 3.0.4 - right ctrl key does not work when "Locate Pointer" is on -> works by design of X11

I'm not sure that there is a lot we can do here, other than suggest that you use a different host key if you need this GNOME feature. The way X11 works, two applications can't both grab one key, and if the application that doesn Locate Pointer was there first then we lose.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use