VirtualBox

Ticket #4660 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Registration dialog does not accept e-mail address

Reported by: pjiricka Owned by:
Priority: minor Component: other
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: other
Host type: Mac OS X

Description

I tried to register in the registration dialog. The dialog prompts me to enter e-mail address, but when I entered my e-mail + password, it said "Invalid user name and/or password". When I used the sun.com username (not e-mail) and password, it worked. However, I would expect it should work with the e-mail address as well.

I am a Sun employee.

Change History

comment:1 Changed 4 years ago by jglick

In my case I could not even enter the password corresponding to my @sun.com email address: the password field refuses to accept a space (U+0020).

comment:2 Changed 4 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to fixed

The initial problem should be solved for some time. I tried to change my password at sun.com so it contain a space. This was not possible. Only the following charakters are allowed:

A-Z a-z 0-9 [ ! # $ % = + | ~ ` : ; , { } < > / * ( ) ' ? " & ]

Maybe you have registered for some time and this has changed in the meantime. As spaces in general are problematic, especially when you try to handle them in html requests, we will not allow them, even for older passwords.

comment:3 Changed 4 years ago by jglick

I'm not sure what GUI you're going through, but my sun.com login is based on LDAP, and it certainly permits spaces in the password (as of the last time I changed it in netadmin, which you are required to do at least twice a year).

Spaces are not especially problematic in HTML forms. Certainly no more so than ampersands! There is a standard form encoding which every web-programming library since the mid-90s has supported. No special work is required to support every printing ASCII character in a password field.

comment:4 Changed 4 years ago by jglick

  • Status changed from closed to reopened
  • Resolution fixed deleted

Reopening for space issue; does not look like this tracker lets me change the summary.

comment:5 Changed 4 years ago by rbalada

I found that that it's not just space (U+0020), which is not accepted as password character.

I'm using Virtualbox 3.1.2 on Mac OS X 10.6 and have some special characters in my Sun-internal-LDAP password. I found that also following six characters are ignored: <{'"}> . In names it's left arrow (&lt;), left curly bracket, single quote, double quote, right curly bracket and right arrow (&gt;). I don't know if it's OS X specific.

comment:6 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Obsolete.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use