VirtualBox

Ticket #4656 (new defect)

Opened 5 years ago

Last modified 2 weeks ago

USB device is busy with a previous request

Reported by: Clodoaldo Owned by:
Priority: major Component: USB
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Windows XP host and Fedora 11 guest. After a crash while transferring a huge amount of files between the pen drive and the Fedora guest, the pen drive becomes unavailable. When clicking Devices -> USB Devices -> Device Name this message is shown:

"Failed to attach the USB device xxx to the virtual machine Fedora 11 USB device xxx with UUID yyy is busy with a previous request. Please try again later.

Details:

Result Code: E_INVALIDARG (0x80070057) Component: HostUSBDevice Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a} Callee: IConsole {0a51994b-cbc6-4686-94eb-d4e4023280e2} "

Forum discussion topic:

 http://forums.virtualbox.org/viewtopic.php?f=6&t=20744&start=0#p89540

Attachments

usb_error.PNG Download (16.5 KB) - added by Clodoaldo 5 years ago.
Error dialog box image

Change History

Changed 5 years ago by Clodoaldo

Error dialog box image

comment:1 Changed 5 years ago by abhay

As I posted in the forums, I was having this exact problem. Solved it by disabling USB 2.0 or EHCI support in BIOS and everything works now. May be USB 2.0 support is not perfect in Virtualbox?

comment:2 Changed 5 years ago by rolandoleo

disabiling USB 2.0 in the virtualbox or in the mainboard bios native???

comment:3 Changed 5 years ago by abhay

You have to disable USB 2.0 in the mainboard's BIOS.

comment:4 Changed 2 weeks ago by kmose

5 years later, this "USB device is busy with a previous request" is still a problem and happens to me constantly. The only way to resolve it involves rebooting (either or both) my guest and host machines. I see threads all over the internet about this problem with no resolution. In my case I am using Windows 7 x86 with VirtualBox 4.3.10.

Is this ever going to be fixed?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use