VirtualBox

Ticket #4655 (closed defect: worksforme)

Opened 5 years ago

Last modified 5 months ago

VRDP connection count bug? (wrong value of mcVRDPClients)

Reported by: pvgorp Owned by:
Priority: major Component: RDP
Version: VirtualBox 2.2.4 Keywords: VRDP
Cc: Guest type: other
Host type: Linux

Description (last modified by sunlover) (diff)

See  http://forums.virtualbox.org/viewtopic.php?f=1&t=20087&p=87279#p87279:

Hi all, we are using VRDP, often over a wireless connection. We have noticed several times that when a Linux rdesktop sessions is terminated due to wireless signal problems, it becomes impossible to connect again afterwards.

Our logs indicate that the error is not due to the external authentication module that we are using. Instead, it seems that the VirtualBox did not notice the disconnection from the client properly. More specifically, the mcVRDPclients variable shown on  http://www.virtualbox.de/changeset/12126 does not seem to be reset.

Here is the related fragment from our server log, starting from the moment where I want to reconnect after the rdesktop sessions from my Linux client has failed due to wireless signal problems:

16:23:52.692 VRDP: New connection: 16:23:52.729 VRDP: Flags 0x00000003 16:23:52.729 VRDP: Channel: [cliprdr] [1004]. Accepted. 16:23:52.836 VRDP: Client seems to be rdesktop. 16:23:52.836 VRDP: Logon: pvgorp (192.168.1.101) build 2600. User: [pieter@...com] Domain: [] Screen: 0 16:23:52.836 VRDPAUTH: User: [pieter@...com]. Domain: []. Authentication type: [External] 16:23:52.836 VRDPAUTH: external authentication module returned 'access granted' 16:23:52.836 VRDPAUTH: Access granted. 16:23:52.837 VRDPAUTH: Multiple connections are not enabled. Access denied. 16:23:52.837 VRDP: Connection closed: 16:23:52.837 VRDP: Logoff: pvgorp (192.168.1.101) build 2600. User: [pieter@...com] Domain: [] Reason 0x0001.

Is it possible to reset the internal counter for the number of supposedly connected clients via VBoxManage? Or are there other workarounds or permanent solutions?

Best regards, Pieter Van Gorp  http://is.ieis.tue.nl/staff/pvgorp/share/

Attachments

VBox.log Download (53.1 KB) - added by jonjbar 3 years ago.

Change History

comment:1 Changed 5 years ago by sunlover

Most likely the old connection was still active in VRDP server. Could you attach complete VBox.log with the problem?

comment:2 Changed 5 years ago by pvgorp

After some VirtualBox upgrades, people stopped complaining about this issue. It seems to be resolved and therefore can be closed. I will reopen it as soon as someone contacts me again about this issue.

Regards, Pieter  http://is.tm.tue.nl/staff/pvgorp/share/

comment:3 Changed 4 years ago by jtalarico

I'm running VB 3.0.8 on OS X Snow Leopard with a Win 7 guest OS. I see this exact behavior several times a day.

The remote connection drops and attempts to reconnect fail.

Logs read: VRDPAUTH: Multiple connections are not enabled. Access denied.

...but no connections are active.

comment:4 Changed 4 years ago by pvgorp

Sounds like this is OS dependent... I do not have complaints anymore since using Ubuntu 9 as a host OS.

comment:5 Changed 4 years ago by pvgorp

I am using VirtualBox myself again more frequently... and I notice that this bug in fact *does* still exist, also on Ubuntu hosts. After an interrupted connection, I cannot reconnect.

In the Machine log on the host machine, I read:

01:22:23.955 VRDPAUTH: Multiple connections are not enabled. Access denied

Most probably, the variable that I mentioned in my original post is still not managed correctly.

My host machine has the following OS:

Linux 2.6.28-16-generic #55-Ubuntu SMP x86_64 GNU/Linux

Changed 3 years ago by jonjbar

comment:6 Changed 3 years ago by jonjbar

Same problem here: Ubuntu Server 10.10 host and Windows 7 64-bit guest. VirtualBox version 3.2.12

But this does not happen over a wireless connection but a wired one: when the guest is downloading content, my VRDP connection is dropped and I can't reconnect. The log says VRDPAUTH: Multiple connections are not enabled. Access denied.

So I enabled the --vrdpmulticon option.

Now when I connect to the machine, I see a black screen.

To go back to normal, I have to pause the machine and restart it.

comment:7 Changed 10 months ago by brian.king

I'm using Solaris 10 as the Host and Windows XP as the guest and Virtualbox version 4.2.14r86644 and I have the vrdemulticon="on" set.

The client count is not correct. It seems to add 2 for every client that connects, and it never decrements. Some examples:

  • Freshly started VM
$ VBoxManage showvminfo WinXP --machinereadable | grep '^VRDEClients='
VRDEClients=0
  • After connecting with a single RDP client (client count goes to 2 -- should be 1)
$ VBoxManage showvminfo WinXP --machinereadable | grep VRDEClient
VRDEClients=2
VRDEClientName="ClientABC"
VRDEClientIP="XXX.YYY.71.196"
VRDEClientVersion=6001
  • After diconnecting with the RDP client (client name and IP disappear, but count stays at 2)
$ VBoxManage showvminfo WinXP-GNB --machinereadable | grep VRDEClient
VRDEClients=2
  • Reconnect with the same client (count is now 4 -- should be 1)
$ VBoxManage showvminfo WinXP --machinereadable | grep VRDEClient
VRDEClients=4
VRDEClientName="ClientABC"
VRDEClientIP="XXX.YYY.71.196"
VRDEClientVersion=6001
  • Connect from a second client at the same time (count goes to 6 when it should be 2)
$ VBoxManage showvminfo WinXP --machinereadable | grep VRDEClient
VRDEClients=6
VRDEClientName="CLIENTABC"
VRDEClientIP="XXX.YYY.2.15"
VRDEClientVersion=6001
  • The only way to reset the count is to either:
     a) restart the VM; or
     b) VBoxManage controlvm WinXP vrde off ; VBoxManage controlvm WinXP vrde on
    

comment:8 Changed 10 months ago by sunlover

  • Description modified (diff)

brian.king, this is the expected behavior. VRDEClients is the total number of clients connected so far to the VRDP server. Some clients, for example MSTSC, may open a connection then close it and open again, in this case both connections are counted.

comment:9 Changed 5 months ago by mVincent

still experiencing this bug on Virtualbox 4.3.2

VRDEClients does not reset to zero(0) after all RDP clients disconnect(MSTSC client). I understand MSTSC opens multiple connections(or two simultaneous connections), but after clients disconnect from VRDP Server, VRDEClients does not reset to 0.

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe showvminfo rakvm --machineread
able | findstr "VRDEClients"
VRDEClients=6
C:\Users\Mark>netstat -an | findstr 5050
  TCP    0.0.0.0:5050           0.0.0.0:0              LISTENING
  TCP    [::]:5050              [::]:0                 LISTENING

comment:10 Changed 5 months ago by sunlover

  • Status changed from new to closed
  • Resolution set to worksforme

mVincent, looks like you did not understood the comment 8. VRDEClients is not the number of currently connected clients.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use