VirtualBox

Ticket #4653 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Final frame of Compiz animation not updated to the screen (Mac OS X only) -> Fixed in SVN.

Reported by: TheMattrix Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.1.6 Keywords: compiz
Cc: Guest type: Linux
Host type: Mac OS X

Description

I have Ubuntu 9.04 installed under VirtualBox 3.0.2 running in Windows 7.

With Compiz enabled, all animations are performed smoothly and without flaw save for this one notable exception - the final frames of any animation are not updated to the screen. Only when the screen is again updated does the previous animation get drawn.

Unfortunately, this is not limited to fancy animations but applies to any screen update. When typing, a character does not appear after a key-press until the following key-press, so text boxes always appear to have a one-character lag.

However, if there is a continual on-screen animation (such as a progress bar), all screen updates seem to complete.

I've attached two screen-shots. The first is after closing a window, and the second is after clicking on a menu. The desktop would remain as shown in the screen-shots until something else was updated on the screen.

Attachments

Compiz01.jpg Download (304.8 KB) - added by TheMattrix 5 years ago.
closing a window
Compiz02.jpg Download (293.6 KB) - added by TheMattrix 5 years ago.
opening a menu
VBox.log Download (60.3 KB) - added by TheMattrix 5 years ago.
log of the session in which the screen-shots were taken
VBox-2009-11-30-16-03-47.log Download (85.6 KB) - added by cornelius 4 years ago.
log of a session where the bug still persists with VBox 3.1
Ubuntu Desktop-2009-12-01-10-23-38.log Download (46.3 KB) - added by markedwards 4 years ago.
Attaching a log report of with the bug present. OS X 10.6.2 with Virtualbox 3.1.0r55467 host, Ubuntu 9.10 32-bit Desktop guest. This is a fresh install from the .iso with this version of Virtualbox. I definitely have the proper guest additions installed. Incidentally, this session was a boot into windowed mode, and ended in a crash (machine aborted) when I tried to go to fullscreen mode, although this doesn't appear to be reflected in the log. I see this kind of instability regularly when trying to use 3D with Ubuntu. It's basically unusable with 3D at this point, in my configuration, although with 3D off it is quite stable. Thanks!
VBox-2009-12-01-13-20-04.log Download (103.0 KB) - added by cornelius 4 years ago.
log of a session where the bug still persists after reinstalling guest additions once more
VBox.log.3 Download (62.6 KB) - added by antonioe 4 years ago.
3.1.0 on OS X 10.6.2 Dec 9 2009
Ubuntu-2009-12-09-21-52-09.log Download (78.9 KB) - added by cornelius 4 years ago.
log of a session where the bug still persists with a fresh guest OS installation on a new VM
VBox.log.1 Download (62.1 KB) - added by jptech 4 years ago.
log from jptech 29-Dec-2009
Ubuntu-2010-04-06-19-51-02.log Download (66.4 KB) - added by BarryCent 4 years ago.

Change History

Changed 5 years ago by TheMattrix

closing a window

Changed 5 years ago by TheMattrix

opening a menu

Changed 5 years ago by TheMattrix

log of the session in which the screen-shots were taken

comment:1 follow-up: ↓ 2 Changed 5 years ago by michael

You might want to search for similar bug reports regarding Compiz, as I have seen this behaviour on physical hardware too, although only for some applications. If you do, feel free to add information and/or links to this ticket.

comment:2 in reply to: ↑ 1 Changed 5 years ago by TheMattrix

Replying to michael:

You might want to search for similar bug reports regarding Compiz, as I have seen this behaviour on physical hardware too, although only for some applications. If you do, feel free to add information and/or links to this ticket.

I had scoured the internet for about a week prior to filing this report. I could not find any mention of a similar problem on the VirtualBox forums, the Compiz forums, bug-trackers for either project, nor any other site for that matter.

Actually, the closest I found was  one locked topic on the VirtualBox forums which didn't mention a solution. As per the moderator's suggestion, I did search for other related threads...and found nothing.

comment:3 Changed 5 years ago by michael

These look similar (the second comment on the first ticket is mine. I saw similar issues to what you describe in the VirtualBox machine selector when I was using Compiz. Whether or not a VM was running was not relevant).

 https://bugs.launchpad.net/ubuntu/+source/meta-kde/+bug/335803  http://www.nvnews.net/vbulletin/showthread.php?t=132476  https://bugs.launchpad.net/ubuntu/intrepid/+source/compiz/+bug/269904

comment:4 Changed 5 years ago by moltendorf

I am having this same issue, except the host is Windows Vista Ultimate 64-bit with Service Pack 1 (not Windows 7), and on Ubuntu 9.04 64-bit on both VirtualBox 3.0.2, and 3.0.4. This does not occur under VirtualBox 2.2.x. I have tested this with a vanilla install of Ubuntu 9.04 64-bit with Guest Additions installed.

comment:5 Changed 5 years ago by SirNuke

I'm seeing this exact problem as well with Windows XP SP3 32-bit as the host, and Ubuntu 9.04 32-bit guest with Compiz enabled (VirtualBox 3.0.2). Compiz on the guest worked with the VirtualBox 2.2 releases.

comment:6 Changed 5 years ago by JonathanHarford

I'm having the same issue.
VirtualBox 3.0.4
Host: 64-bit Vista Home Premium SP1
Guest: Ubuntu 9.04 64-bit OR Ubuntu 9.04 32-bit

Here's a mention of (what seems to be) the same problem in the forum:
 http://forums.virtualbox.org/viewtopic.php?f=3&p=91835

comment:7 Changed 5 years ago by mouridis

Exactly the same issue here. The problem wasn't there on VirtualBox 2.2.x

I'm using VirtualBox 3.0.4 r50677 on Windows Vista Business SP2 32-bit with Ubuntu 9.04 32-bit as the guest OS.

Maybe it has something to do with the graphics driver on the host OS? I use an ATI HD2600XT video card with Catalyst 8.8.

comment:8 Changed 5 years ago by no1

Exact same problem here. In VBox 2.2.4 desktop effects in Ubuntu 9.04 were smooth and no ghosting issues at all.

After upgrading to Vbox 3.x I'm experiencing noticable lag and the same ghost windows that others are seeing.

Host: VBox 3.0.4 Windows 7 x64 RTM Intel E8500 @3.13 ATI Radeon HD 4800, Catalyst 9.8

Guest: Ubuntu 9.04 Latest Guest Additions installed

comment:9 Changed 5 years ago by markedwards

There are at least two forum posts complaining about this very issue, both noting that it was fine in 2.2.4:

 http://forums.virtualbox.org/viewtopic.php?f=3&t=20884

 http://forums.virtualbox.org/viewtopic.php?f=3&t=19352

comment:10 Changed 5 years ago by TheMattrix

The issue continues to persist in Virtualbox 3.0.6.

comment:11 Changed 5 years ago by mouridis

I can also verify the the issue is NOT fixed in 3.0.6

comment:12 Changed 5 years ago by rkroes

I can also confirm this is not fixed in 3.0.6. It was working brilliantly prior to version 3.

Please fix this soon :-)

comment:13 Changed 5 years ago by Exillis

Can this bug get a bump to higher priority?

This is a really annoying bug. It's so bad I've reverted back to 2.x. Compiz worked correctly (and had good performance) right up until 3.0.0 and has been broken ever since.

comment:14 Changed 5 years ago by mouridis

The issue persists also in VirtualBox 3.0.8

comment:15 Changed 5 years ago by leonid

We're aware of this issue and are looking for a solution. So far it's caused by xdamage notification not arriving before the last pixmap update.

comment:16 Changed 4 years ago by ugtar

Do you need any help resolving this issue (not that I'm an expert on anything X -- this issue just bugs me so much that I'd be willing to chip in if someone could point me in the right direction).

comment:17 Changed 4 years ago by cornelius

I posted a workaround here, until this gets fixed:
 http://forums.virtualbox.org/viewtopic.php?f=3&t=20884&p=105915#p105915

comment:18 follow-ups: ↓ 19 ↓ 20 Changed 4 years ago by Arno

Still the problem in VirtualBox 3.0.10 r54097

comment:19 in reply to: ↑ 18 Changed 4 years ago by Arno

Replying to Arno:

Still the problem in VirtualBox 3.0.10 r54097

Edit: Occur both with Ubuntu 9.04 and 9.10

comment:20 in reply to: ↑ 18 Changed 4 years ago by Exillis

Replying to Arno:

Still the problem in VirtualBox 3.0.10 r54097

Confirmed. This is not however a Linux guest specific issue since it occurs on OpenSolaris as well. It is definitely an issue with X and/or compiz.

comment:23 Changed 4 years ago by markedwards

No change in VirtualBox 3.0.12. Problem still exists, including redraw/screen update issues, and crashing.

comment:24 Changed 4 years ago by jptech

I'm glad to see a decent bug report for this issue. It's been annoying me for 6 months now.

comment:25 Changed 4 years ago by no1

Really hope this can be looked at as a priority for the next release. Even if the next release contained no fixes other than this one, I think people would be pretty happy.

comment:26 Changed 4 years ago by swaj

This issue has been happening for me too, since at least 3.0.2. I'm running Windows 7 Ultimate 64-bit with Ubuntu 9.04 and Linux Mint 7 guests and it happens no matter which guest I use. I would be really nice if this could become a priority.

comment:27 follow-up: ↓ 32 Changed 4 years ago by leonid

  • Summary changed from Final frame of Compiz animation not updated to the screen to Final frame of Compiz animation not updated to the screen -> Fixed in SVN.

comment:28 follow-up: ↓ 29 Changed 4 years ago by Arno

Could you please tell me what is SVN ?

comment:29 in reply to: ↑ 28 Changed 4 years ago by Arno

Replying to Arno:

Could you please tell me what is SVN ?

Ok, forget about that ... If I do not make a mistake SN should be for Sub Version ... !?
and the N for ???

comment:30 Changed 4 years ago by frank

Well, the N is for the final n in subversion. The subversion tool is actually called svn.

comment:31 in reply to: ↑ description Changed 4 years ago by adz

I have same issue with 3.0.12 running on Windows 7 64-bit host and Ubuntu 9.10 64-bit (Karmic) Desktop.

Tried 3.1 BETA but this breaks all Compiz 3D desktop effects.

comment:32 in reply to: ↑ 27 Changed 4 years ago by Exillis

Replying to leonid:

A huge thank you to leonid for this fix. The #1 reason for me to upgrade to 3.1.0!

comment:33 Changed 4 years ago by markedwards

Will this fix address both the crashing/instability and the frame updating issues? Are these the same bug?

comment:34 Changed 4 years ago by frank

Please check the Beta 2 which is available in some hours. It contains these fixes.

comment:35 Changed 4 years ago by swaj

I have installed Beta 2 of v3.1.0, and this problem still occurs.

comment:36 Changed 4 years ago by swaj

Please see the below screencast to watch the behavor in 3.1.0 BETA2. This is running on a Windows 7 64-bit host (Core I7). The guest is Linux Mint 7 32-bit with the latest VirtualBox Guest Additions installed. Hope this helps!

 http://geeksharp.net/video/vbox-3d-bug.mp4

comment:37 Changed 4 years ago by arknu

I can confirm this is still occuring using 3.1 BETA 2 and Ubuntu 9.10 (x86) as the guest running on Windows x64 host

comment:38 Changed 4 years ago by reydan

Also confirming this still occurs under 3.1 BETA 2, Gentoo x64 as the guest running on Windows 7 x64 host, even after installing and reinstalling Guest additions 3.1 beta 2.

comment:39 Changed 4 years ago by frank

  • Summary changed from Final frame of Compiz animation not updated to the screen -> Fixed in SVN. to Final frame of Compiz animation not updated to the screen

Unfortunately it turns out that this is not fixed yet.

comment:40 Changed 4 years ago by leonid

Proper fix didn't went to beta2, so you'd have to wait a bit more.

comment:41 Changed 4 years ago by sandervl73

Beta 3 is out now with hopefully the final fix.

comment:42 Changed 4 years ago by vanos

I can confirm that its now working (the last frame is shown properly) in Beta 3. I tried with win7 host and Linux Mint guest.

Good work!!

comment:43 Changed 4 years ago by arknu

Confirmed fixed as well with Windows x64 host and Ubuntu 9.10 x86 guest.

comment:44 Changed 4 years ago by leonid

  • Summary changed from Final frame of Compiz animation not updated to the screen to Final frame of Compiz animation not updated to the screen -> Fixed in SVN.

comment:45 Changed 4 years ago by Arno

Sorry but ... it does not work with my configuration

Vbox Beta 3.1.0_beta3r55271
Vista 64bits host and Ubuntu 9.10 64bits guest.

In fact now Ubuntu does not even want to activate visual effects at all.

comment:46 follow-up: ↓ 48 Changed 4 years ago by vanos

To Arno:

Have you reinstalled guest addons?

comment:47 Changed 4 years ago by leonid

There was a problem with 64bit linuxes which ain't related to this ticket but anyway it's fixed after beta3.

comment:48 in reply to: ↑ 46 Changed 4 years ago by Arno

Replying to vanos:

To Arno:

Have you reinstalled guest addons?

This is a clean installation of ubuntu 9.10 64bits with only R and Grass installed. Ubuntu is up to date and guest additions were re-installed after migration to beta3.

Is this bug specific to me ?

comment:49 Changed 4 years ago by reydan

Confirmed fixed as well with Windows 7 x64 host and Gentoo Linux x64 guest.

comment:50 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:51 Changed 4 years ago by cornelius

The bug doesn't seem to be fixed for me.

Vbox 3.1.0_r55467 Host: OSX 10.6.2 Guest: Ubuntu 9.10

(I installed the latest guest additions and rebooted).

comment:52 Changed 4 years ago by cornelius

I should add that my guest is 64-bit.

Changed 4 years ago by cornelius

log of a session where the bug still persists with VBox 3.1

comment:53 Changed 4 years ago by markedwards

  • Status changed from closed to reopened
  • Resolution fixed deleted

Also on OS X 10.6.2, and this issue persists, with both Ubuntu 9.10 32-bit and 9.10 64-bit. The 32-bit is a fresh install.

This appears to perhaps be fixed only for Windows hosts.

comment:54 Changed 4 years ago by frank

cornelius, according to your log file you didn't update the guest additions to 3.1.0. Please do and attach a new VBox.log file if the problem still exists!

markedwards, you didn't attach a VBox.log file!

comment:55 Changed 4 years ago by leonid

Exactly what Frank wrote abobe, "00:00:29.434 VM: Raising runtime error '3DSupportIncompatibleAdditions' (fFlags=0x4) 772 00:00:29.434 Console: VM runtime error: fatal=false, errorID=3DSupportIncompatibleAdditions message="An attempt by the virtual machine to use hardware 3D acceleration failed. The version of the Guest Additions installed in the virtual machine does not match the version of VirtualBox on the host. Please install appropriate Guest Additions to fix this issue"

Also, please stick to the topic. If Compiz doesn't work at all it's a different issue. This ticket is about lag with the last animation frame.

Changed 4 years ago by markedwards

Attaching a log report of with the bug present. OS X 10.6.2 with Virtualbox 3.1.0r55467 host, Ubuntu 9.10 32-bit Desktop guest. This is a fresh install from the .iso with this version of Virtualbox. I definitely have the proper guest additions installed. Incidentally, this session was a boot into windowed mode, and ended in a crash (machine aborted) when I tried to go to fullscreen mode, although this doesn't appear to be reflected in the log. I see this kind of instability regularly when trying to use 3D with Ubuntu. It's basically unusable with 3D at this point, in my configuration, although with 3D off it is quite stable. Thanks!

comment:56 Changed 4 years ago by cornelius

Frank, I don't know if there was a problem with the guest additions installation yesterday, but I just reinstalled the guest additions once more, rebooted the guest, and the problem is still there. I'm attaching the new log.

Changed 4 years ago by cornelius

log of a session where the bug still persists after reinstalling guest additions once more

comment:57 Changed 4 years ago by Arno

Finally !!! Well done ! It works with Vbox 3.1.0, Vista 64 host and ubuntu 9.10 64 !!

Changed 4 years ago by antonioe

3.1.0 on OS X 10.6.2 Dec 9 2009

comment:58 Changed 4 years ago by antonioe

Unfortunately I am having the same experience as markedwards. I have attached my VBox.log.3 dated Dec 9 2009. Thanks for your efforts.

comment:59 Changed 4 years ago by cornelius

On an OS X 10.6.2 host, I tried creating a new VM with VBox 3.1.0, installing a fresh 64-bit Ubuntu 9.10 as guest, then mounting the guest additions iso, installing guest additions, and rebooting the guest: The issue is still there.

comment:60 follow-up: ↓ 62 Changed 4 years ago by leonid

Once again...Please don't post here if your problem is NOT related to the compiz animation delays.

Antonioe: according to your log, you DO NOT have 3d acceleration enabled for VM. So I highly doubt you could run compiz on guest and get the animation issue.

Cornelius: Which issue is still there?

comment:61 Changed 4 years ago by cornelius

leonid: The issue is the same one shown in the video above:  http://geeksharp.net/video/vbox-3d-bug.mp4

That is, the last frame of any animation (or change) is not shown until something (like cursor blinking, system-monitor applet graph update, clock applet time update, etc.) forces a refresh. The issue includes window opening/closing animations, typing (where the last typed character(s) don't appear until the next blinking of the cursor), and menu item selection (the previously selected item is highlighted, but not the currently selected one, i.e., selection visual stays "behind in time" of the actual selection).

This issue happens only when compiz is running. With metacity, this issue is not seen. I'm attaching a VBox.log for the fresh installation I mentioned last time.

Thanks for following up on the issue even if it seems to be fixed for some people (only Windows hosts maybe?)

Changed 4 years ago by cornelius

log of a session where the bug still persists with a fresh guest OS installation on a new VM

comment:62 in reply to: ↑ 60 Changed 4 years ago by antonioe

Replying to leonid:

Antonioe: according to your log, you DO NOT have 3d acceleration enabled for VM. So I highly doubt you could run compiz on guest and get the animation issue.

Hmmm... with so many tries I may have posted a log from a "reset" try... just repeated the attempt, made SURE 3D Accel WAS enabled before firing up the VM, then System->Preferences->Appearances->Visual Effects DID allowed me to choose "Extra" and Voila! the "Missing last keystroke/Ghost last window animation frame" syndrome is still there (I'm sure there is a command line way of doing all that, but I'l an old COBOL programmer and only know how to do it by GUI). I have a log of that. Anybody interested in my posting it? Otherwise, and since I see I'm not the only one observing this trouble, I'll sit quietly until it's resolved. Ciao!

comment:63 Changed 4 years ago by markedwards

Issue is still present with VirtualBox 3.1.2 r56127, OSX 10.6.2 host, Ubuntu 9.10 guest, 32-bit and 64-bit.

comment:64 Changed 4 years ago by leonid

So looks like it's present only on OSX hosts. Got an idea why so should be fixed soon.

comment:65 Changed 4 years ago by jptech

I'm still having a problem with 3.0.12. I've always assumed this was the related bug. I'll attach a log file.

My host OS is Win7. I'm using 3.0.12 tools. I booted a new install of Ubuntu 9.10, opened and closed a single window, and shut down. When I close a window it will go half transparent. I have to perform another action to get it to disappear completely.

Please let me know if I can provide any additional info.

Changed 4 years ago by jptech

log from jptech 29-Dec-2009

comment:66 Changed 4 years ago by markedwards

jptech:

Read the thread before posting. The issue was addressed in VBox 3.1 for Windows hosts.

comment:67 Changed 4 years ago by jptech

Version 3.1.2 DOES work for me. Apparently I didn't drink enough coffee today and was thinking 3.0.12 was the latest version while reading the 3.1.2 patch notes. Incidentally, the in application 'Check for Updates' was telling me I had the most recent version when I was running 3.0.12.

Thanks for the reply Mark and thank you to whoever fixed the issue!

comment:68 Changed 4 years ago by wader

I can confirm this with VirtualBox 3.1.2 on Mac OS 10.6.2 as host and Ubuntu 9.10 amd64 as guest

comment:69 Changed 4 years ago by antonioe

Uhh.. what are you confirming: that the issue has been fixed on a Mac OS host or that it is still there?

comment:70 Changed 4 years ago by wader

sorry, that i still have the issue

comment:71 Changed 4 years ago by BarryCent

I can confirm also that I am experiencing the same issue on a Mac OS X 10.6 host and Ubuntu 9.10 64-bit guest running in VirtualBox 3.1.2. This is a fresh installation of Ubuntu too.

I have the same setup on another system which is a slower system with Windows XP as the host and it works fine on there.

comment:72 Changed 4 years ago by markedwards

Issue is still present in VBox 3.1.4, using Ubuntu 9.10 32-bit guest on OS X 10.6.2 host.

comment:73 Changed 4 years ago by BarryCent

I can also confirm that this issue is still present in VirtualBox 3.1.4, running an Ubuntu 9.10 64-bit guest under Mac OS 10.6.

I have performed a clean installation of both Ubuntu and VirtualBox, deleting all settings and re-creating the virtual machine from scratch.

Would it be possible for someone to look into this issue please?

comment:74 Changed 4 years ago by shrift

I am also still having this problem with 3.1.4. I am running a Lucid 64bit guest on a Mac OSX 10.6.2 host.

comment:75 Changed 4 years ago by BarryCent

Mac OS 10.6.3 host, VirtualBox 3.1.6 r59351, Ubuntu 9.04/9.10 x86 & x64 guests.

Problem is still here. This is ridiculous Oracle/Sun, whoever.

Why are we still having this issue 8 months after the issue was reported?? Why is the problem not being recognized?

Hell, the host type and assigned individual haven't even been updated on the ticket...

comment:76 Changed 4 years ago by sandervl73

Really useful to complain loudly and not even bother to attach the VBox.log of the session.

Changed 4 years ago by BarryCent

comment:78 Changed 4 years ago by BarryCent

I wasn't trying to complain 'loudly'. I apologize if it came across that way.

I have attached a log of my Ubuntu session. Again, I'm sorry I didn't know one was required for support.

Please let me know if you require any more files.

Thanks Mark, I feel a little less insignificant now :-)

comment:80 Changed 4 years ago by sandervl73

  • Host type changed from Windows to Mac OS X
  • Version changed from VirtualBox 3.0.2 to VirtualBox 3.1.6

comment:81 Changed 4 years ago by sandervl73

  • Summary changed from Final frame of Compiz animation not updated to the screen -> Fixed in SVN. to Final frame of Compiz animation not updated to the screen (Mac OS X only)

comment:82 Changed 4 years ago by frank

Some remarks from my side: You might have noticed that there are currently more than 2300 tickets open. Some of them are more relevant, some of them are less relevant or even bogus. We are trying hard to keep this database up to date, to remove irrelevant entries and, of course, to fix real bugs. More important bugs will be fixed first, and providing information by the reporters will at least sometimes provide the missing bits which is required to find the final bugfix. For instance, it seems like this particular problem is related to Mac OS X hosts -- so far this wasn't obvious.

But, as already mentioned, our support is for free of charge and we have only limited ressources. Therefore we decide which problem is more relevant, sorry! We appreciate the feedback that some feature still does not work as expected with a new VBox version. But words like ... this is ridiculous Oracle/Sun, whoever and ... hell, the host type and assigned individual haven't even been updated on the ticket... is IMHO impertinent and will only decrease our willingness to look into the problem.

comment:83 Changed 4 years ago by leonid

  • Summary changed from Final frame of Compiz animation not updated to the screen (Mac OS X only) to Final frame of Compiz animation not updated to the screen (Mac OS X only) -> Fixed in SVN.

comment:84 Changed 4 years ago by frank

Parts fixed in 3.1.8, should be fully fixed in 3.2.0

comment:85 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use