VirtualBox

Ticket #4650 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

SATA emulation seems to ignore the flush() request

Reported by: javaboyuk Owned by:
Priority: critical Component: virtual disk
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: other
Host type: other

Description

The SATA emulation seems to ignore the flush() request to the drives both RAW and file based.

This leads to DATA LOSS (and filesystem loss) this is espically dangerous for Filesystems that are transcationally based eg ZFS. This can lead to loss of the whole filesystems. It could also be the cause of a number of issues with journalled filesystems(NTFS ext3 etc).

When the guest calls the flush() call the emulation should call the hosts underlying flush() for the virtual or RAW disk.

For the discusion on ZFS you might look at this  http://www.opensolaris.org/jive/thread.jspa?threadID=108213&tstart=0 and this for the IDE discusion:  http://forums.virtualbox.org/viewtopic.php?f=8&t=13661&start=0

(the IDE emulation also does this but, I believe, can have it disbaled with:VBoxManage setextradata VMNAME "VBoxInternal/Devices/piix3ide/0/LUN#[x]/Config/IgnoreFlush" 0 )

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4949.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use