VirtualBox

Ticket #4620 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

xp multiprocessor is very, very slow

Reported by: ToddAndMargo Owned by:
Priority: major Component: guest smp
Version: VirtualBox 3.0.2 Keywords: SMP Multiprocessor XP slow
Cc: Guest type: Windows
Host type: Linux

Description

Hi All,

Please fix this for me.

Host: CentOS 5.3 Guest: XP-Pro SP3 OEM, upgraded from SP2 Vbox 3.0.2

I just created a new virtual machine to take advantage of 3.0.2's multiprocessor support. Problem, it runs much faster on a single processor than on dual processors.

The guest only has VBox 3.0.2 Guest Additions, Firefox 3.5, Ultra Explorer, and all M$'s current service packs installed, including SP3. No other software, including Anti Virus, is installed. It is meant to be my base system to recover from when I screw things up.

I also have a copy of this VM with only the base XP-SP2 install. It is also very, very slow under multiprocessors. One runs fine.

And since there is nothing on it, I can test away and not worry about hurting anything critical.

Many thanks, -T

Attachments

WinXP2.tar.gz2 Download (24.0 KB) - added by ToddAndMargo 5 years ago.
all 4 logs files
WinXP2.tar Download (270.0 KB) - added by ToddAndMargo 5 years ago.
4 log files in simple, uncompressed tar format

Change History

comment:1 Changed 5 years ago by ToddAndMargo

Additional info: my motherboard uses an Intel chipset and a Xeon 5130 processor

And, I have another XP-SP3 guest at a customer's site that I had to put back on 1 processor to get it to stop crawling.

And, and, W7RC and WS08 seem to have taken to multiprocessor like a duck to water on these same machines.

comment:2 Changed 5 years ago by sandervl73

Without a VBox.log I can't say anything meaningful.

Changed 5 years ago by ToddAndMargo

all 4 logs files

comment:3 Changed 5 years ago by frank

  • Component changed from other to guest smp

comment:4 follow-up: ↓ 5 Changed 5 years ago by sandervl73

Could you upload the file in a format for which I don't have to download additional software? If you disabled the IO-APIC in your 1 cpu guests, then it's an IO-APIC problem and a duplicate ticket.

comment:5 in reply to: ↑ 4 Changed 5 years ago by ToddAndMargo

Replying to sandervl73:

Could you upload the file in a format for which I don't have to download additional software?

"tar xjvf WinXP2.tar.gz2" should do the trick. Let me know if you have a problem with it.

If you disabled the IO-APIC in your 1 cpu guests, then it's an IO-APIC problem and a duplicate ticket.

IO-APIC is enabled on the 1 CPU guest and that it the fast VM. The slow 2 CPU VM also has both APIC and IO-APIC enabled. I have the same things on both VM's, except for the number of CPU's.

From my vantage point, it seems that whenever I do a XP VM with "XP-Pro-SP3 OEM" there is not a problem. Mine was an "XP-Pro-SP2 Retail Pack Upgrade" that I installed SP3 on. Maybe that has something to do with it? I was slow both before and after SP3.

-T

comment:6 Changed 5 years ago by sandervl73

I'm using Windows here, so that doesn't work. Tar is fine, gz is fine, gz2 isn't. Please use a more common compression format.

Changed 5 years ago by ToddAndMargo

4 log files in simple, uncompressed tar format

comment:7 follow-up: ↓ 8 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

It's a duplicate of the IO-APIC ticket. Your Xeon CPU doesn't have the optimization that's required to deal with the IO-APIC and 32 bits guests. I assume your 1 cpu guest was installed without the IO-APIC.

comment:8 in reply to: ↑ 7 Changed 4 years ago by ToddAndMargo

Replying to sandervl73:

I assume your 1 cpu guest was installed without the IO-APIC.

Yes. It is about 2 years old.

Your Xeon CPU doesn't have the optimization that's required to deal with the IO-APIC and 32 bits guests.

It is a Xeon 5130. "Supposedly" the 5130 has everything you need. Also, both my Vista Ultimate and W7 Pro VM's have everything turned on and they do not exhibit the problem. It is only XP that has such.

It's a duplicate of the IO-APIC ticket.

Are you certain? My Vista Ultimate and W7 Pro VM's do not have the problem.

Also, do you have the ticket number for the IO-APIC?

Many thanks, -T

comment:9 Changed 4 years ago by sandervl73

#4392.

Microsoft changed the way Vista & Windows 7 operate. This problem only applies to Windows NT/2000/XP/2003. As you installed XP without IO-APIC enabled it uses a different HAL.

Your Xeon CPU does not have this optimization. Perhaps this feature was implemented later on.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use