VirtualBox

Ticket #4610 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

libcurl dependency doesn't match code

Reported by: rvboxr Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.2 Keywords: libcurl
Cc: Guest type: other
Host type: Linux

Description

Trying to build VirtualBox 3.0.2 OSE on Centos 5.3. Fails with: VirtualBox-3.0.2_OSE/src/VBox/Runtime/common/misc/s3.cpp :248: error: 'CURLE_REMOTE_FILE_NOT_FOUND' was not declared in this scope

However, the output from configure was successful: Checking for libcurl: found version 7.15.5, OK.

And the machine has the 7.15 version installed: $ rpm -qa | grep curl curl-devel-7.15.5-2.1.el5_3.4 curl-7.15.5-2.1.el5_3.4

I think that the offending definition may have been introduced in a later version of curl.

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the report. The correct dependency is actually version 7.17.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use