VirtualBox

Ticket #4603 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

virtualbox OS (winxp) will not start at all under linux with kernel 2.6.30.2-1

Reported by: djg1971 Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.2 Keywords:
Cc: djg1971@… Guest type: Windows
Host type: Linux

Description

Ever since upgrading to linux kernel 2.6.30-whatever I cannot use virtualbox at all. Is anyone looking into this? The virtualbox kernel modules compile and load fine, and the virtualbox gui starts up fine. But when I try to boot the guest OS, it just fails and says windows cannot start normally, asks if I want to go into safe mode, etc. I had thought this was a known problem with 2.6.30-xxx linux kernels (running at least some versions of linux) and that eventually it would be fixed with a new vb release, but so far nothing in more than a month.

Is this a known issue? Is anyone working on it? If it doesn't get sorted out soon I will have to wipe VB off and try vmware...

Attachments

VBox.log Download (55.7 KB) - added by djg1971 5 years ago.
latest VBox.log file -- error is "Guest Log: BIOS: int13_harddisk: function 02, parameters out of range"

Change History

Changed 5 years ago by djg1971

latest VBox.log file -- error is "Guest Log: BIOS: int13_harddisk: function 02, parameters out of range"

comment:1 in reply to: ↑ description Changed 5 years ago by djg1971

cancel this.

comment:2 Changed 5 years ago by michael

Cancel as in close the ticket? Is it now working for you?

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Not able to reproduce. Please reopen if this still happens.

comment:4 Changed 5 years ago by djg1971

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I am reposting here though the nature of the problem does not appear to be what I had originally thought:

What has happened appears to be that, sometime after May 2009, one or more of the "windows updates" (and maybe something to do with the linux kernel, I'm not sure anymore) has caused XP not to be able to reboot normally after shutting down. When I launch VirtualBox, the first time XP tries to boot it fails with a black screen and high CPU usage. It will just sit there forever so you have to shut it down via the VB interface "send shutdown." Then I attempt to restart XP again, without closing VB, and the 2nd time it comes up to the screen which says that windows cannot boot normally... If I select the "boot into safe mode with networking" option, it does come up, and then I can opt to restore the system to a date before July 2009. The restore works, XP boots normally, and away you go. But, *even if I do not perform windows updates once booted AND select to shut down without updating* the same situation will exist the next time I start VirtualBox and attempt to boot XP. I only use XP when absolutely necessary (not that often for me), so I can probably go on in this manner for some time, but, something is clearly wrong and might be likely to get worse. Now that I have a much better sense of what the symptoms are, and given the events which preceeded this behavior, I would be very surprised if a lot of people out there who run linux and use XP as a guest under VirtualBox are not experiencing the same sort of thing. To "Frank," who looked into this and then closed the ticket: Did you try doing windows updates and then restarting (at first just XP without shutting down VB, and then shutting down the whole works and trying again some time later)? If you were able to complete those cycles and no evidence of any problems showed up, what distribution of linux are you using, and with what kernel? I am sure that the fact that the XP system restore works and I can eventually boot XP normally with the current linux system is telling me something, but more information is necessary to isolate the crux of the problem.

comment:5 Changed 5 years ago by frank

djg1971, sure I've done this and I work with Windows XP VMs on Linux hosts very often. Never saw such a problem you described here. Actually VBox 3.0.2 had some known bugs and an updated to VBox 3.0.8 is recommended. Furthermore I would suggest you to check your guest disks as well as your host disk to rule out any defect data. Windows XP guests on Linux hosts should run rock solid with VBox 3.0.8.

comment:6 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing. Please reopen if still relevant with VBox 3.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use