VirtualBox

Ticket #4593 (closed defect: obsolete)

Opened 5 years ago

Last modified 3 months ago

Windows XP Client freezes on shutdown

Reported by: tha492s Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: Windows
Host type: other

Description

Clicked shutdown in the client machine, the Windows Shutdown screen is shown, but the machine never succeeds in shutting down, it freezes until the process is killed from the task manager. According to the log file the additions seem to have a problem.

Attachments

MPOS MasterPOS-2009-07-21-16-33-29.log Download (191.8 KB) - added by tha492s 5 years ago.
Machine log
VBox_2.2.4_Hang Example_1.log Download (55.2 KB) - added by HipHoppity 5 years ago.
Sample VBox 2.2.4 log - VirtualBox Shutdown Hang
VBox Window During Hang.jpg Download (99.7 KB) - added by HipHoppity 5 years ago.
VBox Hang_Apple Report Window.jpg Download (123.2 KB) - added by HipHoppity 5 years ago.
VBox_3.0.8 Apple Report Window.png Download (58.5 KB) - added by HipHoppity 4 years ago.
VBox_3.0.8_Hang Example_6.log Download (73.5 KB) - added by HipHoppity 4 years ago.
VBox_3.0.10_Hang Example_7.log Download (55.7 KB) - added by HipHoppity 4 years ago.
VirtualBoxVM_2009-11-06-133626_Macintosh_VBox_3.0.10.crash Download (26.9 KB) - added by HipHoppity 4 years ago.
VBox_3.1.2_Hang Example_8.log Download (83.9 KB) - added by HipHoppity 4 years ago.
VBox 3.1.2 Log for WinXP Guest on Mac OSX Host After VBox Crash
VBox_3.1.2_VM_2010-01-13-163746_Macintosh.crash Download (26.6 KB) - added by HipHoppity 4 years ago.
Mac OSX Crash Report from VBox 3.1.2 Crash Example

Change History

Changed 5 years ago by tha492s

Machine log

comment:1 Changed 5 years ago by frank

  • Guest type changed from other to Windows
  • Summary changed from Windows XP Client freezes on shutdown to Windows XP Client freezes on shutdown (guest properties)

Never saw a problem like this. Is this still relevant with VBox 3.0.4? Are the guest additions installed correctly, that is, is the mouse integration working? Is there enough free disk space on the host and within the guest?

comment:2 Changed 5 years ago by michael

That error code corresponds to the Windows host error

ERROR_GEN_FAILURE 31 (0x1F) A device attached to the system is not functioning.

Definitely looks like a problem with your host operating system.

comment:3 Changed 5 years ago by tha492s

First thank you Frank and Michael for your responses. Yes, the additions work correctly in the guest machine (mouse pointer, resolution, etc..). I will try to see if this can be reproduced with 3.0.4.

comment:4 follow-up: ↓ 5 Changed 5 years ago by mrsteve

I found the same problem using Windows XP x86 guest on Windows Vista x64 host with VBox 3.0.4 and guest additions. It froze on shutdown, although in my case the log indicated all was good. I had to kill the process. The next time I tried with 3D acceleration turned off and it shutdown OK - although I had been installing XP SP3 at the same time so can't say if turning off 3D was the solution.

comment:5 in reply to: ↑ 4 Changed 5 years ago by tha492s

I tried it with 3.04, and the problem can still happen. I can believe that it has something to do with Windows and devices, but just the same it is too bad that the client machine window "freezes" (buttons do not respond) and the VM can only then be stopped by killing the VirtualBox process in task manager..

comment:6 Changed 5 years ago by michael

  • Summary changed from Windows XP Client freezes on shutdown (guest properties) to Windows XP Client freezes on shutdown

comment:7 Changed 5 years ago by HipHoppity

I've been experiencing this problem since VBox 2.2.4 with a WinXP SP3 Guest on a Mac OSX Host. See my forum post, "VirtualBox 2.2.4 Hangs After Guest Shutdown" in the Mac OSX section for further details ( http://forums.virtualbox.org/viewtopic.php?f=8&t=19085).

Let me know if you have questions or need additional information on my observations as you work on this bug.

Changed 5 years ago by HipHoppity

Sample VBox 2.2.4 log - VirtualBox Shutdown Hang

Changed 5 years ago by HipHoppity

Changed 5 years ago by HipHoppity

comment:8 Changed 5 years ago by vbox4me2

Same experience with vbox 2.2.4, host: xp64 previously upgraded from 2.08 (2.06 had the same vt-x hanging problem, 2.08 this was solved) shutdown any vt-x Guest will result in a Guest hang, vbox processes can not be terminated, Host does not shutdown properly anymore.

comment:9 Changed 4 years ago by HipHoppity

Update => This problem with VBox Hangs when "VT-x/AMD-V" acceleration is enabled in Guest has continued through to VirtualBox version 3.0.8. Additional example log / screen shot uploaded to assist with resolution.

Changed 4 years ago by HipHoppity

Changed 4 years ago by HipHoppity

comment:10 Changed 4 years ago by vbox4me2

Also now confirmed that this happens with only pae enabled (ubuntu tls server 804), Guests do shutdown but the vbox handled process never terminates and can't be terminated manually.

comment:11 Changed 4 years ago by vbox4me2

Update: this bug does NOT happen if the Host is 32bit!!! toshiba 64bit laptop with vista business 32bit, vt-x/pae works fine, no hangs.

comment:12 Changed 4 years ago by frank

vbox4me2: Hmm, but there are logs attached to this ticket where PAE is disabled and for 32-bit hosts as well ...

comment:13 Changed 4 years ago by vbox4me2

Well I have a xp64 Host that suffers from this with either vt-x, vt-x+pae or just pae, either 3 options lets any VM hang on shutdown(with vbox 2.0.x no problems), however on that (you know which one here) vista business 32bit toshiba 64bit laptop it runs fine (same VM's like ubuntu server, xp64, windows 2008 server) VBox 2.2.4 / 3.04 and 3.08. After it hangs no log entries are created or appended, vbox processes can not be terminated, Host must be rebooted. Obviously I can't testrun 64bit vm's without vt-x, but if I enable vt-x for a 32bit Guest the same thing happens. The laptop however works like a charm. The issue is 100% shutdown related as VM's run fine for weeks until you have to shutdown... attempting to control such vm via vboxmanage lets that new process hang as well but can be stopped with C.

comment:14 Changed 4 years ago by HipHoppity

Update => My first week with VirtualBox 3.0.10 went quite well and I was able to use the "VT-x/AMD-V" acceleration enabled for Guest WinXP SP3. Unfortunately, I got my first VBox Hang with version 3.0.10 today. Example log and crash report uploaded.

Changed 4 years ago by HipHoppity

Changed 4 years ago by HipHoppity

comment:15 Changed 4 years ago by vbox4me2

See  http://forums.virtualbox.org/viewtopic.php?p=108857#p108857 I have actually done this on a test server, haven't tried shutting down a guest yet since I want to run this for a while(simulate conditions) to see if this helps. It would explain why a fresh install on a 64bit laptop and a cold reboot worked without vt-x problems. Somehow I feel this a BIOS setting/vbox issue, between mayor vbox releases vt-x settings are tested differently to which a BIOS might react differently (a BIOS can and will store minor changes when quering values the wrong way) this can be a fault in the BIOS. A Host reboot does NOT restore these changed bios values, you need to cold boot for that to happen. I don't have these facilities but a test could done as follows: Install 2.08 on a fresh Host with vt-x enabled(dump bios), run some Guests in vt-x mode(dump bios), upgrade to 2.2.4 or 3.x, warm reboot(dump bios), try running same vt-x guests and shutdown from the Guest(dump bios). The 4 dumps should not differ, I suspect they will differ. If they differ vbox is making bios calls that effect some bios settings, if not the bios has a bug.

comment:16 Changed 4 years ago by vbox4me2

As mentioned before on the forum I've re-initialized the bios vt-x value and that seems to have solved it, guests are shutting down and the control process terminates normally, I've adjusted the vbox FAQ how to do this, so far no more vt-x issues (2.2.4). It does however beg to differ 'what' vbox does to bios volatile values when quering for vt-x capabilities...

comment:17 Changed 4 years ago by HipHoppity

Update => Since updating to VirtualBox 3.1.0 and now to build 3.1.2 (about a month now) I haven't seen this hang and my WinXP Guest shuts down as "Powered Off" now. Perhaps other fixes in the VBox 3.1.x branch have resolved this bug? Time will tell . . .

comment:18 Changed 4 years ago by HipHoppity

VirtualBox 3.1.2 Crash => As noted above, I've found the VBox 3.1.x builds have improved stability related to this bug. Unfortunately, I had my first crash yesterday with VBox 3.1.2. This crash showed the same symptoms as reported before and requires Force Quitting VBox followed by a shutdown/restart of the Mac Host in order to get VirtualBox running again. I will attach the VBox log file and crash report for this incident. I hope this helps with your efforts to track down this bug.

Changed 4 years ago by HipHoppity

VBox 3.1.2 Log for WinXP Guest on Mac OSX Host After VBox Crash

Changed 4 years ago by HipHoppity

Mac OSX Crash Report from VBox 3.1.2 Crash Example

comment:19 Changed 4 years ago by nickj

Virtualbox 3.2.6, with an Ubuntu 10.04.1 64-bit Linux host, running a WinXP SP3 (32-bit) guest, host's CPU is a "4x Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz", and it also hung on the "Windows is shutting down" screen. It did it the first 3 times (once for a user-initiated shutdown, twice on automatic reboots after installing updates). For the 4th time, I tried disabling Vt-x under settings -> system -> acceleration -> untick "Enable VT-X/AMD-D", and it worked fine; also worked fine shutting down the 5th time. So (based on this admittedly very small sample size) it appears to be 100% reproducible with the latest version, and toggling the VT-X setting appears to fix it.

comment:20 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use