VirtualBox

Ticket #4539 (new defect)

Opened 5 years ago

Last modified 5 years ago

Guest Additions causing app in Guest OS to fail when accessing shared drive

Reported by: georgesc Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.0 Keywords: Shared Folder Pervasive.SQL
Cc: Guest type: Windows
Host type: Windows

Description

Hello

I am reporting a bug when Guest Additions is installed. I have tried the end user forums for a solution for several weeks without finding a successful solution.

I am trying run an application that connects to a Pervasive.SQL database. Both the Pervasive.SQL 8.6 software and the application are installed locally.

I did the following:

  1. Install the Pervasive.SQL software and application locally with the Guest Additions also installed. The software works perfectly when accessed via local drive letter.
  1. I then use the windows explorer to map the local drive to a new drive letter and change the shortcut path of the application to point to the new drive letter. The follow error occurs:

"Cannot create system lock file: ./TEMP/SYSLCK.DAT. File status: 9/004, Btrieve status: 11"

  1. If I remove the Guest Additions and run the application, the software works perfectly even via with the mapped drive letter.

The above steps were done when trying to isolate what causes the problem. Ideally, we want to run the application on a server via a mapped drive letter which connects to the Pervasive.SQL database on the server. The application also works perfectly in this configuration as long as the Guest Additions is not installed.

We have tried this with the Virtual Box v2.2.0 and v2.2.2 and with Guest Additions versions 2.2.2, 2.2.0, 2.0.0 and 1.6.0. The same problem occurred.

This was originally reported under trouble ticket 4093 more than 2 months ago. We received no response. Since then I have tried it with VirtualBox 3.0.0 and the same problem remains. I am creating a new ticket and placing it under the Guest Additions component.

Regards,

Change History

comment:1 Changed 5 years ago by georgesc

Hey

I reported this bug over 2 months ago and I got no response. I now see a similar issue reported in Ticket #4920 (2 days ago) and they already got a response.

Is there any additional info I can provide to help with a resolution to the problem?

Regards,

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use