VirtualBox

Ticket #4537 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

No Network Traffic after Installating 3.0.2 (NAT)

Reported by: seg Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

Hi I used Virtualbox 2.2.4 on my Macbook (10.5.7) and everything works fine. The Internet on the VB-Image (Windows XP SP3) i used through the Network via NAT.

Now I have changed to Virtualbox 3.0.2, but now the Internet doesn´t work anymore. After the Start auf my Image I can see, that via DHCP the Image gets IP-Adresse, DNS, Gateway, ... A Pings sometimes works: Ping  http://www.web.de [217.72.195.42] mit 32 Bytes Daten:

Antwort von 10.0.2.2: Bytes=32 Zeit=497ms TTL=127 Antwort von 217.72.195.42: Bytes=32 Zeit=143ms TTL=127 Zeitüberschreitung der Anforderung. Zeitüberschreitung der Anforderung.

After chancing back to 2.2.4 everything works .... and after a new installation of 3.0.2 it works till the first reboot.

In the forum i have seen, that other User have the same problem

Attachments

log.rtf Download (56.3 KB) - added by seg 5 years ago.
Windows XP Magix-2009-08-23-19-51-35.log Download (66.1 KB) - added by seg 5 years ago.
nic Download (301.2 KB) - added by seg 5 years ago.

Change History

comment:1 Changed 5 years ago by Hachiman

Could you please attach the log?

Changed 5 years ago by seg

comment:2 Changed 5 years ago by Hachiman

  • Component changed from other to network/NAT

comment:3 Changed 5 years ago by Hachiman

test build (r50558) has been sent

comment:4 follow-up: ↓ 5 Changed 5 years ago by vondralbra

All of a sudden a firewall appliance which I've built on a VBox Machine stopped working in a quite awkward way. The IPSEC and OPENVPN requests timed out and a ping took more than 20 seconds to get a reply - when getting a reply at all. This had not been the case when I've set up the appliance on 3.0.0 in the first place. The big delay went in right after the latest security upgrade of the host and/or the guest.

After switching the external interface of the virtual machine into "bridged" mode everything worked like before. A switch of the interface to some other hardware made no difference.

The regression shown in #4537 seems like it could match the behavior of my appliance in NAT-mode and I'd gladly tested the appliance on the test build R50558 if I had my hands on it. Host and Guest are both Debian Lenny having latest security patches.

comment:5 in reply to: ↑ 4 Changed 5 years ago by Hachiman

Replying to vondralbra: Your problem more like #4540

comment:6 Changed 5 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate #4540

comment:7 follow-up: ↓ 8 Changed 5 years ago by seg

  • Status changed from closed to reopened
  • Resolution duplicate deleted

The Problem isn´t fxed with Build 3.0.4 ... so it seems to be a differend problem!!! I will attach the new log ... Problem still ressist as discribed

Changed 5 years ago by seg

comment:8 in reply to: ↑ 7 Changed 5 years ago by Hachiman

  • Status changed from reopened to closed
  • Resolution set to duplicate

Replying to seg:

The Problem isn´t fxed with Build 3.0.4 ... so it seems to be a differend problem!!! I will attach the new log ... Problem still ressist as discribed

Could you please clearify which problem one of some response come from 10.0.2.2 #4540 or network freeze #4343?

comment:9 follow-up: ↓ 10 Changed 5 years ago by seg

The network doesn´t freeze. During the ping pakets will be lost!

comment:10 in reply to: ↑ 9 Changed 5 years ago by Hachiman

Replying to seg:

The network doesn´t freeze. During the ping pakets will be lost!

Could you please attach  pcap file to the ticket.

Changed 5 years ago by seg

  • attachment nic Download added

comment:11 follow-up: ↓ 12 Changed 5 years ago by seg

pcap file attached

comment:12 in reply to: ↑ 11 Changed 5 years ago by Hachiman

Replying to seg:

pcap file attached

Thank you for file, behavior of traffic in pcap file (big number of retransmits and duplications) makes me think that it related to #4343.

comment:13 Changed 5 years ago by seg

i don´t know exactly. The Guest doesn´t hang. Only the network-traffic. After trying 4 or 5 times a internet-page sometimes will be displayed

On my Host I can see the starting of the traffic, but after a few seconds there will be no traffic to the internet.

comment:14 follow-up: ↓ 15 Changed 5 years ago by seg

Hi, is there someting new? As I wrote to Vasily I have tried Version VirtualBox-2009-08-19-19-58-13-mac2-rel-3.0.51-r51281 but the problem hasn´t changed. Exactly the same

comment:15 in reply to: ↑ 14 Changed 5 years ago by Hachiman

Replying to seg:

Hi, is there someting new? As I wrote to Vasily I have tried Version VirtualBox-2009-08-19-19-58-13-mac2-rel-3.0.51-r51281 but the problem hasn´t changed. Exactly the same

Hi Simon, haven´t received any feedback probably mail delivery problem that why I haven´t offer more recent built. Will sent you fresh 3.0 branch build.

comment:16 Changed 5 years ago by Hachiman

r51724 mac buld was sent.

comment:17 follow-up: ↓ 18 Changed 5 years ago by seg

Hi Vasily, the Version VirtualBox-2009-09-01-12-11-38-mac2-3.0-3.0.5-r51724 works fine - no problem with nat!!! Full Internet-Access! Comes this patch with the next version?

Thx

Simon

comment:18 in reply to: ↑ 17 Changed 5 years ago by Hachiman

Replying to seg:

Hi Vasily, the Version VirtualBox-2009-09-01-12-11-38-mac2-3.0-3.0.5-r51724 works fine - no problem with nat!!! Full Internet-Access! Comes this patch with the next version?

Thx

Simon

Thanks for feedback. Yes I´d said it already included.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use