VirtualBox

Ticket #4507 (closed defect: duplicate)

Opened 10 years ago

Last modified 10 years ago

Closing network connection VB 3.0.0-2

Reported by: kraki Owned by:
Component: network/NAT Version: VirtualBox 3.0.2
Keywords: closing connection Cc:
Guest type: Linux Host type: Windows

Description

I have last release of Kubuntu 9.4 on Windows XP SP3. In VB i use Intel desktop NIC. Usually after higher network traffic on hosted OS the network connection on guested OS (Kubuntu) has been unstable. I have about 10 ssh connection to remote system and randomly the connection are closed with:

Read from remote host XXX: Connection reset by peer Connection to XXX closed.

If i go back to version VB 2.2.4 i don't have this problem.

Attachments

VBox.log.2 Download (53.1 KB) - added by kraki 10 years ago.
Log from 3.0.2
VBox.log.1 Download (54.9 KB) - added by kraki 10 years ago.
Log from 3.0.2 with VT-x enabled
VBox.log Download (41.5 KB) - added by FWNet 10 years ago.
Multiple connection drops over a two hour period.

Change History

comment:1 Changed 10 years ago by misha

What connection type do you use with your VM? i.e. bridged, NAT, etc.?

comment:2 Changed 10 years ago by kraki

I use NAT, no port forwarding.

comment:3 Changed 10 years ago by Hachiman

Could you please attach the log? Have you problems started from 3.0.0 or 3.0.2?

Changed 10 years ago by kraki

Log from 3.0.2

comment:4 Changed 10 years ago by kraki

I have this problem from 3.0.0.

Changed 10 years ago by kraki

Log from 3.0.2 with VT-x enabled

comment:5 Changed 10 years ago by Hachiman

What do you mean by "after higher network traffic", i need this information for easier reproducing the problem?

comment:6 follow-up: ↓ 7 Changed 10 years ago by kraki

I download/upload file over ftp. File has about 600 MB and speed about 4Mb/sec. After this step i have been sure that ssh connection are disconnected or will be disconnected in near following minutes. Also new created ssh connection is closed after few minutes.

comment:7 in reply to: ↑ 6 Changed 10 years ago by Hachiman

Replying to kraki:

I download/upload file over ftp. File has about 600 MB and speed about 4Mb/sec. After this step i have been sure that ssh connection are disconnected or will be disconnected in near following minutes. Also new created ssh connection is closed after few minutes.

Thank you for information.

comment:8 Changed 10 years ago by FWNet

I am experiencing spontaneous connection drops also since upgrading v224 to v302. Host XP Home, Guest XP Pro, NAT. Log file attached.

Changed 10 years ago by FWNet

Multiple connection drops over a two hour period.

comment:9 Changed 10 years ago by zoltanf

I can also confirm that sometimes, the connection drop on the NAT interface. Usually the only way to get back to realiable network operation after this point is to shut down the guest and start it up again.

comment:10 Changed 10 years ago by Hachiman

Test build was sent for verification.

comment:11 Changed 10 years ago by Hachiman

duplicate of #4343

comment:12 Changed 10 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use