VirtualBox

Ticket #4487 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Segfault on resuming from saved state

Reported by: ccf Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Host and guest are both Ubuntu 9/04, VBox 3.0.2, GA installed. Reproducible always.

VBoxManage controlvm <vmname> savestate

VBoxManage startvm <vmname> or VirtualBox -startvm <vmname> results in a segfault. Running a second time causes the VM to perform a cold boot.

I am unable to attach a debugger to get a meaningful backtrace or get any meaning from the core dump.

Attachments

VBox.log Download (31.9 KB) - added by ccf 5 years ago.
log file
machine.xml Download (4.8 KB) - added by ccf 5 years ago.
VM config
VBox.2.log Download (49.7 KB) - added by ccf 5 years ago.
before
VBox.3.log Download (31.9 KB) - added by ccf 5 years ago.
after
vbox-logs-4487.tar.bz2 Download (16.6 KB) - added by ccf 4 years ago.
Logs to go with 4487-core.bz2 on the ftp.

Change History

Changed 5 years ago by ccf

log file

Changed 5 years ago by ccf

VM config

comment:1 Changed 5 years ago by ccf

Core dump:  http://www.mediafire.com/download.php?tzio5zmjitv

I've no idea if you need any other information, but do ask for it if I've not got it. There seems to be a shared folders bug which is claimed as fixed in 3.0.2 - this VM is not using any shared folders.

comment:2 Changed 5 years ago by frank

Thanks for the core dump but so far we were not able to reproduce this problem. Please could you repeat the experiment and this time, attach two VBox.log file, the first file from the VM session which was saved and the second from the VM session where you tried to resume the VM? Thank you!

Changed 5 years ago by ccf

before

Changed 5 years ago by ccf

after

comment:3 Changed 5 years ago by frank

Are you able to reproduce these crashes with VBox 3.0.6? If so, could you provide another core dump for such a 3.0.6 VM?

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if you are able to reproduce the problem with VBox 3.0.8.

comment:5 Changed 5 years ago by ccf

  • Status changed from closed to reopened
  • Resolution fixed deleted

Duly reopening. Logs and backtrace in progress.

comment:6 Changed 5 years ago by ccf

After much to and fro (mostly forgetting to re-enable suid_dumpable) I have a fresh set of logs and a core dump. Unfortunately, I'm having trouble uploading them anywhere over HTTP due to poor connectivity (also putting paid to attaching it to an email, since I use Web-based). Is there an alternative to this? Compressed to >6MB.

comment:7 Changed 5 years ago by frank

Please send me a private E-mail to frank _dot_ mehnert _at_ sun _dot_ com.

comment:8 Changed 5 years ago by ccf

Quote: "(also putting paid to attaching it to an email, since I use Web-based)"

comment:9 Changed 5 years ago by ccf

Actually, scratch that. I just got lucky (on the 13th attempt, no less). E-mail on the way.

Changed 4 years ago by ccf

Logs to go with 4487-core.bz2 on the ftp.

comment:10 Changed 4 years ago by frank

Please could you check if VBox 3.1.6 fixes your problem? It contains a related fix.

comment:11 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use