VirtualBox

Ticket #4450 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Black screen with any virtual machine after update to 3.0.0_ose

Reported by: Zugschlus Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Hi,

after upgrading to Virtualbox 3.0.0_ose (from Debian unstable), my virtual machines do only show black screens when running. When I force Virtualbox to open a dialog on the host screen, I get the correct display inside the VM window, but the window becomes black again when I close the dialog.

Starting the VM with VboxSDL -startvm helps, output is OK then.

If you need additional information, please ask and I'll happily try to help.

Greetings Marc

Attachments

2009-05-15-10-33-13.031-VirtualBox-27126.log Download (387 bytes) - added by Zugschlus 5 years ago.
Log file of a virtual machine being started, a dialog being forced, and the virtual machine being powered down

Change History

Changed 5 years ago by Zugschlus

Log file of a virtual machine being started, a dialog being forced, and the virtual machine being powered down

comment:1 Changed 5 years ago by frank

Does

export XLIB_SKIP_ARGB_VISUALS=1
VirtualBox

work as well?

comment:2 follow-up: ↓ 3 Changed 5 years ago by Zugschlus

export XLIB_SKIP_ARGB_VISUALS=1 VirtualBox

helps, yes. Thanks.

Greetings Marc

comment:3 in reply to: ↑ 2 Changed 5 years ago by Zugschlus

Replying to Zugschlus:

export XLIB_SKIP_ARGB_VISUALS=1 VirtualBox

helps, yes. Thanks.

Can anybody explain why this fix helps, what's the cause of the issue and whether this is virtualbox' or some of my libraries' fault?

Greetings Marc

comment:4 Changed 5 years ago by michael

We haven't investigated right down into the nitty depths, but it seems to be a combination of problems in the Qt library and/or buggy display drivers (note the "or", as I am by no means certain that it is a Qt issue).

What happens is that the display driver provides a special ARGB visual (which is roughly a graphics mode which allows transparency and funny things) which Qt chooses to use. Either Qt can't handle it properly or the driver sets it up wrong (or both). Setting that variable tells Xlib to hide the visual from the application. VirtualBox 3.0.2 automatically sets this variable while initialising the Qt library (and then unsets it before initialising the virtual 3D component which needs to use the ARGB visual.

You asked :)

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Obsolete.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use