VirtualBox

Ticket #4389 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Crash while running uTorrent 1.8.2

Reported by: john.doe Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by Hachiman) (diff)

The VM crashes running uTorrent.

It looks like 2 threads are in free() at the same time... maybe a threading bug?

I'm running Windows 2003.

 	ntdll.dll!_RtlpCoalesceFreeBlocks@16()  + 0x79 bytes	
 	ntdll.dll!_RtlFreeHeap@12()  + 0xa14 bytes	
>	msvcr71.dll!free(void * pBlock=0x0bda56f8)  Line 103	C
 	VBoxRT.dll!1001eba1() 	
 	[Frames below may be incorrect and/or missing, no symbols loaded for VBoxRT.dll]	
 	VBoxDD.dll!03f71c32() 	
 	VBoxDD.dll!03f6f0f3() 	
 	VBoxDD.dll!03f73401() 	
 	VBoxDD.dll!03f7351d() 	
 	VBoxDD.dll!03f78671() 	
 	VBoxDD.dll!03f73a00() 	
 	VBoxDD.dll!03f73ad8() 	
 	VBoxDD.dll!03f75048() 	
 	VBoxDD.dll!03f6f017() 	
 	VBoxDD.dll!03f63d0c() 	
 	VBoxDD.dll!03f63d97() 	
 	VBoxVMM.dll!01c32008() 	
 	VBoxRT.dll!1000c880() 	
 	VBoxRT.dll!1002a012() 	
 	msvcr71.dll!_threadstartex(void * ptd=0x024d7250)  Line 241 + 0x6 bytes	C
 	kernel32.dll!_BaseThreadStart@8()  + 0x34 bytes	


 	ntdll.dll!_KiFastSystemCallRet@0() 	
 	ntdll.dll!_ZwWaitForSingleObject@12()  + 0xc bytes	
 	ntdll.dll!_RtlpWaitOnCriticalSection@8()  - 0xe4 bytes	
 	ntdll.dll!_RtlEnterCriticalSection@4()  + 0x22f51 bytes	
 	ntdll.dll!_RtlFreeHeap@12()  + 0x9ee bytes	
>	msvcr71.dll!free(void * pBlock=0x0be31670)  Line 103	C
 	VBoxRT.dll!1001eba1() 	
 	[Frames below may be incorrect and/or missing, no symbols loaded for VBoxRT.dll]	
 	VBoxDD.dll!03f63f38() 	
 	VBoxVMM.dll!01c24890() 	
 	VBoxVMM.dll!01c24e32() 	
 	VBoxVMM.dll!01c03141() 	
 	VBoxVMM.dll!01c04dbc() 	
 	VBoxVMM.dll!01c04bf9() 	
 	ntdll.dll!_ZwSetEvent@8()  + 0xc bytes	
 	kernel32.dll!_SetEvent@4()  + 0x10 bytes	
 	VBoxRT.dll!10029c7d() 	
 	VBoxVMM.dll!01c1ac31() 	
 	VBoxVMM.dll!01bf130d() 	
 	VBoxRT.dll!10029b70() 	
 	VBoxRT.dll!1000c880() 	
 	VBoxRT.dll!1002a012() 	
 	msvcr71.dll!_threadstartex(void * ptd=0x01361a28)  Line 241 + 0x6 bytes	C
 	kernel32.dll!_BaseThreadStart@8()  + 0x34 bytes	

Attachments

VBox.log Download (40.7 KB) - added by john.doe 5 years ago.

Change History

comment:1 Changed 5 years ago by john.doe

just tested 3.0 and i get the same crash.

comment:2 Changed 5 years ago by Hachiman

Thanks for report. Could you please attach the log?

Changed 5 years ago by john.doe

comment:3 Changed 5 years ago by john.doe

sorry, i've added it.

comment:4 Changed 5 years ago by Hachiman

  • Description modified (diff)

comment:5 Changed 5 years ago by Hachiman

Have you been able get crash dump? if yes please let me [vasily _dot_ levchenko _at_ Sun _dot_ COM] know, I'll provide instruction how to deliver it to us.

comment:6 Changed 5 years ago by john.doe

How do I generate a crash dump?

I can replicate the problem.

comment:7 Changed 5 years ago by Hachiman

please check C:\Windows\Minidump or %SystemRoot%\Minidump.

comment:8 Changed 5 years ago by john.doe

nope, no dumps. i have confirmed that my o/s options are set to create dumps, but there are none.

i guess this is to be expected because it is VirtualBox that is faulting, not the O/S.

when the crash happens i get a "VirtualBox.exe - Application Error" OK/Cancel dialog box in the host o/s that allows me to attach a debugger to the process. that is how i got the stack trace for the faulting thread.

comment:9 Changed 5 years ago by Hachiman

Does it repeat in 3.0.2?

comment:10 Changed 5 years ago by john.doe

Seems to be fixed in 3.0.2. Thanks.

comment:11 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use