VirtualBox

Ticket #4344 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

3.0.0 VBoxClient incompatible with Solaris 10 version of libX11.so.4 -> fixed in SVN

Reported by: scott_barrett Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.0.0 Keywords: X11 clipboard
Cc: Guest type: Solaris
Host type: other

Description

GUI login on Solaris 10 guest fails to successfully start XSession as VBoxClient requires SUNW_1.2 symbol from libX11.so.4. A copy of ~/.dt/startlog is attached.

Partial workaround is to define LD_NOVERSION in ~/.dtprofile to cause runtime linker to not perform version verification.

This workaround however leaves clipboard functionality broken, as the "VBoxClient --clipboard" process dies when an attempt is made to copy text from the guest.

Running "VBoxClient --clipboard -d" shows:

bash-3.00$ /opt/VirtualBoxAdditions/VBoxClient --clipboard -d
ld.so.1: VBoxClient: fatal: relocation error: file /opt/VirtualBoxAdditions/VBoxClient: symbol Xutf8TextPropertyToTextList: referenced symbol not found
Killed

Attachments

startlog.txt Download (2.4 KB) - added by scott_barrett 5 years ago.
Shows failed XSession start

Change History

Changed 5 years ago by scott_barrett

Shows failed XSession start

comment:1 Changed 5 years ago by ramshankar

Which version of Solaris 10 is this?

comment:2 Changed 5 years ago by scott_barrett

Is this useful information?

bash-3.00$ uname -a
SunOS solaris10 5.10 Generic_141415-04 i86pc i386 i86pc

comment:3 Changed 5 years ago by scott_barrett

Since people generally speak in terms of uThis and uThat, I checked and determined that kernel patch 141415-xx corresponds to u7.

comment:4 Changed 5 years ago by randshuntzinger

I can confirm that this problem exists with Solaris 10 update 7. In my case I worked around the problem by using the 2.2.4 guest additions instead of the 3.0.0 version. I am still running under the 3.0.0 VirtualBox software.

Scott - the contents of the /etc/release file shows which version of Solaris 10 you are running. It shows Solaris 10 5/09 for update 7.

comment:5 Changed 5 years ago by scott_barrett

Thanks for confirming the problem, and your workaround and version tip. My /etc/release file has the following first line:

Solaris 10 5/09 s10x_u7wos_08 X86

comment:6 Changed 5 years ago by michael

  • Summary changed from 3.0.0 VBoxClient incompatible with Solaris 10 version of libX11.so.4 to 3.0.0 VBoxClient incompatible with Solaris 10 version of libX11.so.4 -> fixed in SVN

Fixed in SVN

comment:7 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use