VirtualBox

Ticket #4334 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

32 bit guest hangs in 64 bit server

Reported by: sjoerd Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Various 32 bit (so far I have only tried Linux) guests hang after a short while inside my 64 bit host. The cursor disappears (is recoverable when moving out of the guest window or by clicking the Host key) and the guest is totally unresponsive. This happens both on guests with and without the guest additions installed. I have only seen this happen when trying to download system updates, i.e. when there is network activity. I have not seen this happen with 64 bit Linux hosts.

The host runs Fedora 10 x86_64, and I recently updated from VirtualBox 2.2 to 3.0.0 (64 bit version). Using 2.2 I have had no problems running the guests. I don't remember which 2.2 I had (at least 2.2.2).

Attachments

VBox.log Download (39.8 KB) - added by sjoerd 5 years ago.
log file of hanging guest

Change History

Changed 5 years ago by sjoerd

log file of hanging guest

comment:1 Changed 5 years ago by sjoerd

Some new information:

The 32 bit guests that hang all have one thing in common which they did not have in common with the 64 bit guests that didn't hang. The hanging systems all use the PCnet-FAST III (Am79C973) network adapter, whereas the 64 bit guests all use the Intel PRO/1000 MT Desktop (82540EM) network adapter. When I change the 32 bit guests to the Intel PRO network adapter, they don't hang.

In other words, there is a bug in the PCnet network adapter (or in the various Linux kernels running on the guests), but given that I didn't experience the hangs using VirtualBox 2.2 without changing the guest, I tend to put the blame on the network adapter implementation. The guests I have tried this on most recently run Fedora 9 and Fedora 11.

comment:2 Changed 5 years ago by jjamor

I'm experiencing the same problem, and after choosing the Intel PRO/1000 MT driver, the problem is apparently fixed.

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

See #4343, I will close this bug as duplicate. We believe we found the problem.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use