VirtualBox

Ticket #4303 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

amd64/VirtualBox crashes on 2009.06

Reported by: dmeetry Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.4 Keywords: core
Cc: Guest type: other
Host type: Solaris

Description

amd64/VirtualBox crashes while starting a guest (newly created or an old one). Core file is attached. No log file has been created. It worked fine on 2008.11.

vbox:     2.2.4 & 3.0.0 beta
host OS:  OpenSolaris 2009.06 (SunOS 5.11 snv_111b i86pc i386 i86pc)
guest OS: any
host h/w: # psrinfo -vp
            The physical processor has 2 virtual processors (0 1)
            x86 (AuthenticAMD 60FB1 family 15 model 107 step 1 clock 2311 MHz)
            AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
====================================================================

Failed to open a session for the virtual machine a.
Virtual machine 'a' has terminated unexpectedly during startup.

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Machine
Interface: IMachine {4d1df26d-d9c1-4c7e-b689-15e85ecf8ffc}

====================================================================
-----------------------------------------------------
CRASH DETECTED at 2009 Jun 26 17:41:17
-----------------------------------------------------
Type:    SIGSEGV
Program: VirtualBox
Args:    /opt/VirtualBox/amd64/VirtualBox --comment a --startvm ffdb1f72-c534-4bdc-a320-\0
PID:     4047
TID:     1
LWPs:    1
PPID:    4046
UID:     101
GID:     10
TaskID:  80
ProjID:  10
PoolID:  0
ZoneID:  0
zone:    global
CWD:     /export/home/dmeetry
errno:   0

User Stack Backtrace,
              libglib-2.0.so.0.1800.3`g_utf8_validate+0x20
              libgconf-2.so.4.1.5`gconf_value_from_corba_value+0x2d4
              libgconf-2.so.4.1.5`gconf_engine_get_fuller+0x24c
              libgconf-2.so.4.1.5`gconf_engine_get_entry+0x89
              libgconf-2.so.4.1.5`get+0x10b
              libgconf-2.so.4.1.5`gconf_client_get_full+0x93
              libgconf-2.so.4.1.5`gconf_client_get+0x46
              libgconf-2.so.4.1.5`gconf_client_get_string+0x71
              libQtGuiVBox.so.4`_ZNK23QCleanlooksStylePrivate15lookupIconThemeEv+0x335
              libQtGuiVBox.so.4`_ZNK16QCleanlooksStyle14standardPixmapEN6QStyle14StandardPixmapEPK12QStyleOptionPK7QWidget+0x98
              libQtGuiVBox.so.4`_ZNK16QCleanlooksStyle26standardIconImplementationEN6QStyle14StandardPixmapEPK12QStyleOptionPK7QWidget+0x99
              libQtGuiVBox.so.4`_ZN16QCleanlooksStyle11qt_metacallEN11QMetaObject4CallEiPPv+0x77
              libQtCoreVBox.so.4`_ZN11QMetaObject12invokeMethodEP7QObjectPKcN2Qt14ConnectionTypeE22QGenericReturnArgument16QGenericArgumentS7_S7_S7_S7_S7_S7_S7_S7_S7_+0x5dd
              libQtGuiVBox.so.4`_ZNK6QStyle12standardIconENS_14StandardPixmapEPK12QStyleOptionPK7QWidget+0x218
              libQtGuiVBox.so.4`_ZN18QMessageBoxPrivate12standardIconEN11QMessageBox4IconEPS0_+0x174
              libQtGuiVBox.so.4`_ZN11QMessageBox7setIconENS_4IconE+0x31
              libQtGuiVBox.so.4`_ZN11QMessageBoxC1ENS_4IconERK7QStringS3_6QFlagsINS_14StandardButtonEEP7QWidgetS4_IN2Qt10WindowTypeEE+0x1f0
              libQtGuiVBox.so.4`_ZN18QMessageBoxPrivate17showOldMessageBoxEP7QWidgetN11QMessageBox4IconERK7QStringS6_iii+0x4d
              libQtGuiVBox.so.4`_ZN11QMessageBox8criticalEP7QWidgetRK7QStringS4_iii+0x22
              VirtualBox`main+0x1be

Kernel Stack Backtrace,
              genunix`sigaddqa+0x5f
              genunix`trapsig+0x119
              unix`trap+0x12a1
              unix`0xfffffffffb8001d9

Ansestors,
    4047 /opt/VirtualBox/amd64/VirtualBox --comment a --startvm ffdb1f72-c534-4bdc-a320-\0
      4046 /opt/VirtualBox/amd64/VBoxSVC --automate\0
        1 /sbin/init\0
          0 sched\0

Times,
    User:    11 ticks
    Sys:     2 ticks
    Elapsed: 177 ms

Sizes,
    Heap:   1867776 bytes
    Stack:  45056 bytes

Change History

comment:1 Changed 5 years ago by dmeetry

Maximum attachment size is 400000 bytes only. Core file is available upon request.

comment:2 Changed 5 years ago by dmeetry

%r13 is NULL, so SEGV on memory access.

(dbx) where
current thread: t@1
=>[1] g_utf8_validate(0x0, 0xffffffffffffffff, 0x0, 0x2d4, 0xfffffd7ff9049e10, 0x0), at 0xfffffd7ffbf7e710 
  [2] gconf_value_from_corba_value(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff9049e24 
  [3] gconf_engine_get_fuller(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff905a9cc 
  [4] gconf_engine_get_entry(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff905ad29 
  [5] get(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff9061e6b 
  [6] gconf_client_get_full(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff90620e3 
  [7] gconf_client_get(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff90622d6 
  [8] gconf_client_get_string(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff9062931 
  [9] _ZNK23QCleanlooksStylePrivate15lookupIconThemeEv(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff49ff635 
  [10] _ZNK16QCleanlooksStyle14standardPixmapEN6QStyle14StandardPixmapEPK12QStyleOptionPK7QWidget(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff4a00a68 
  [11] _ZNK16QCleanlooksStyle26standardIconImplementationEN6QStyle14StandardPixmapEPK12QStyleOptionPK7QWidget(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff49ff749 
  [12] _ZN16QCleanlooksStyle11qt_metacallEN11QMetaObject4CallEiPPv(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff4c88177 
  [13] _ZN11QMetaObject12invokeMethodEP7QObjectPKcN2Qt14ConnectionTypeE22QGenericReturnArgument16QGenericArgumentS7_S7_S7_S7_S7_S7_S7_S7_S7_(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff506f40d 
  [14] _ZNK6QStyle12standardIconENS_14StandardPixmapEPK12QStyleOptionPK7QWidget(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff4982fa8 
  [15] _ZN18QMessageBoxPrivate12standardIconEN11QMessageBox4IconEPS0_(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff4b57024 
  [16] _ZN11QMessageBox7setIconENS_4IconE(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff4b570f1 
  [17] _ZN11QMessageBoxC1ENS_4IconERK7QStringS3_6QFlagsINS_14StandardButtonEEP7QWidgetS4_IN2Qt10WindowTypeEE(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff4b597f0 
  [18] _ZN18QMessageBoxPrivate17showOldMessageBoxEP7QWidgetN11QMessageBox4IconERK7QStringS6_iii(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff4b598ad 
  [19] _ZN11QMessageBox8criticalEP7QWidgetRK7QStringS4_iii(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfffffd7ff4b59922 
  [20] main(0x0, 0x0, 0x0, 0x0, 0x0, 0x0), at 0x4ed11e

(dbx) frame 1
0xfffffd7ffbf7e710: g_utf8_validate+0x0020:	cmpb     $0x0000000000000000,0x0000000000000000(%r13)

(dbx) regs
current thread: t@1
current frame:  [1]
...
r13	 0x0000000000000000
...

comment:3 Changed 4 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4686

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use