VirtualBox

Ticket #4301 (closed defect: obsolete)

Opened 5 years ago

Last modified 5 months ago

VB can't boot system from the partition larger than 1024 cylinder

Reported by: xuqingkuang Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.4 Keywords: lba, partition
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

I got the problem when installing Windows XP into Virtual Box 2.2.4 and 3.0 Beta2 on Fedora 11, if the primary partition is larger than 8G, the system will can not boot. It will report 'Fatal. Could not read from the boot medium'.

I'm had tried to trouble shooting it. And found it's the BIOS problem. When I use PartitionMagic to split my partition in virtual machine, it report "Your partition is larger than 1024 cylinder, operating system may can not be boot", if the partition larger than 8G.

It looks the BIOS of Virtual Box is not support LBA large extension, so if the boot partition large than 1024 cylinder, the system will can not boot. It's a really old problem of old system and already fixed in newer BIOS a long time.

But after I make my primary partition to 8G, the problem is disappear.

I hope it can be fixed in newer release. Nobody want to use the system limit to 8G hard disk.

BTW: I tried boot from a Ghost XP cd in Virtual Box, when loading CDROM driver it report INT13 error. It confirm my thinking, the BIOS built-in Virtual Box did not support INT 13 extension.

Change History

comment:1 Changed 5 years ago by sandervl73

Aren't you using raw partitions? Everybody has been using > 8 GB disk containers for years without any problems.

comment:2 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use