VirtualBox

Ticket #4290 (reopened enhancement)

Opened 11 years ago

Last modified 5 months ago

Can't create hard links on a shared folder (= can't use zsh if home directory is shared folder)

Reported by: lat Owned by:
Component: other Version: VirtualBox 2.2.4
Keywords: hardlink linux vboxsf Cc:
Guest type: Linux Host type: all

Description (last modified by fbatschu) (diff)

It seems the shared folders do not allow hard links to be created (link() system call). The result is always EPERM, Operation not permitted. A simple "touch foo; ln foo bar" on a shared folder will demonstrate the problem. This is with VirtualBox 2.2.4 on Mac OS X 10.4.11 host, Linux 64-bit client (tried both Ubuntu 8.04 LTS Server x86-64 and Scientific Linux 4.8 x86-64 (a RHEL4 variant)).

The way I actually noticed was that the zsh delivered with scientific linux (zsh 4.2.0) tries to create a history lock file with link() and fails - and goes into an infinite loop. There's no such problem with the ubuntu version though (zsh 4.3.4). This makes it rather more difficult to use zsh as a login shell :-) I'll see if I can coax it to not use that way of locking.

However, hard linking support would be nice.

Change History

comment:1 Changed 11 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #818.

comment:2 Changed 3 years ago by hartmut

  • Status changed from closed to reopened
  • Resolution duplicate deleted

#818 only fixed the soft link aspect, hard links still don't work.

It might probably make sense to remove the duplicate status on this one and clearly mark #818 as only fixing the soft link part, continuing with the hard link part here?

comment:3 Changed 5 months ago by fbatschu

  • Keywords hardlink linux vboxsf added
  • Host type changed from Mac OS X to all
  • Type changed from defect to enhancement
  • Description modified (diff)

comment:4 Changed 5 months ago by fbatschu

zsh is actually not a compelling business case for adding such support in order to meat application demands that absolutely have to run within the shared folder file system and also require hardlink support within the same. Anything else?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use