VirtualBox

Ticket #4261 (new defect)

Opened 5 years ago

Last modified 17 months ago

Slow transfer speeds from USB disk

Reported by: cortana Owned by:
Priority: minor Component: USB
Version: VirtualBox 2.2.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

When converting a physical machine into a VirtualBox guest, I attached a USB external hard disk to the host computer, and connected it to the guest. Then I started to transfer data from the disk to the guest.

I noticed that the data was only being transferred at about 1.1 MB/sec. Perhaps co-incidentally, this is the speed of a USB 1.1 hub. I checked the kernel logs and saw that the device was being attached to an EHCI controller, and was being configured to run in high speed mode, so I'm not sure what to try next...

Attachments

wintermute-2009-06-20-12-16-38.log Download (45.3 KB) - added by cortana 5 years ago.
lsusb.out Download (22.2 KB) - added by davidharvey 4 years ago.
lsusb -v output
VBox.log Download (37.5 KB) - added by davidharvey 4 years ago.
davidharvey-kahuna-vbox.log

Change History

Changed 5 years ago by cortana

comment:1 Changed 5 years ago by personguy

happening here as well. VB 3.0.0 XP sp3 host XP sp2 guest USB 2.0 EHCI enabled

very slow transfer speeds.

comment:2 Changed 5 years ago by Domino

Same problem. Host = Ubuntu9.04 AMD64, guest = Windows 2003 R2 Ent. SP1 Vbox 2.2.4. Does anybody solve this problem?

comment:3 Changed 5 years ago by rtirrell

I think I'm having the same problem. VB3.0.4 on Ubuntu 32-bit host, Windows XP 32-bit guest. USB1.1 speeds...

comment:4 Changed 5 years ago by jptech

I have the same problem. VB 3.0.4, Win7 64bit host, Ubuntu 9.04 i386 guest. Looks the same as #2973. I've used VirtualBox since 2.2 and have never seen decent USB performance.

comment:5 Changed 4 years ago by davidharvey

Is there a resolution for this?

I'm using vbox 3.1.2 r56127 on Ubuntu 9.10 hosting a Windows XP SP3 system. I'm running iTunes in the Windows XP instance.

I'm on a USB2.0 system. It takes approximately seven hours to sync my 16GB IPhone.

With a native Windows XP system, also running USB 2.0 it takes less than 20 minutes.

david@kahuna:~/.VirtualBox/Machines/WindowsXP/Logs$ uname -a Linux kahuna 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC 2009 i686 GNU/Linux

I've attached lsusb -v output and the vbox.log.

Changed 4 years ago by davidharvey

lsusb -v output

Changed 4 years ago by davidharvey

davidharvey-kahuna-vbox.log

comment:6 Changed 4 years ago by NeuralMonk

Same problem here. I hope they fix this issue. I am only seeing ~600kB/s transfer across large reads. Native, I am getting 16MB/s with the same drive on the host.

comment:7 Changed 3 years ago by johnf

Is there any chance of this bug being looked at? I'm able to assist in anyway possible. I'm seeing a very similar issue with a Digital Camera. It shows about 3 frames per second where normally it would do a normal 24 or so. I believe this is a similar issue to the USB drive performance.

I believe this ticket is probably also related to #2973

comment:8 Changed 3 years ago by bla0ck

This is still the issue for 4.0.4 macos host, debian guest. I get 1.7-2 Megabytes per second while copying data between two attached usb drives and around 5-6 MBps while writing data to the attached usb drive only.

Transferring files on physical machine gives 30 Megabytes per second speeds.

PS let me know whats the point in having public bugzilla with no feedback from VB team? What the point in having corporate users pay for such a pathetic USB performance? Bother not to answer, 10x.

comment:9 Changed 3 years ago by frank

The USB emulation is still not optimal but we are working on improving the code. Yelling from non-paying users will only result in frustration of the developers. And in general, functional bugs (crashes, host reboots, device malfunctions) have a higher priority than performance optimizations.

comment:10 Changed 17 months ago by nars

I do get same problem with VirtualBox 3.2.4 on kernel 3.4.11 (unRAID), with USB 2.0 EHCI option enabled on the VM settings it's actually slower than with the option disabled!

Tried with an external HDD and with a pen drive (both can read at near 30MB/s on the host system), with USB 2.0 EHCI enabled I can only read them at around 0.5MB/s with USB 2.0 EHCI disabled I can get near 3MB/s :(

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use