VirtualBox

Ticket #4239 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Unable to run Windows 7 XP mode emulation concurrently with VirtualBox (AMD-V/VT-x) -> fixed in SVN/3.0.10

Reported by: lsproc Owned by:
Priority: major Component: VMM/HWACCM
Version: VirtualBox 2.2.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Under Windows 7 64bit, with a Phenom II 940 CPU on an MSI DKA790GX motherboard, the host will BSOD randomly when running VirtualBox, with the BSOD KMODE_EXCEPTION_NOT_HANDLED.

This is mentioned in the event log: The computer has rebooted from a bugcheck. The bugcheck was: 0x0000001e (0xffffffffc000001d, 0xfffffa8003f6f1d0, 0x0000000000000002, 0x0000000002b99500). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 061609-15022-01.

From googling the first parameter of the 0x1e bugcheck, it seems to be related to Virtualbox.

This seems to be related to:  http://vbox.innotek.de/pipermail/vbox-trac/2007-September/106534.html.

Because the guest is 64bit, AMD-V must be enabled. However I will try with Nested Paging off tomorrow. This did not occur on an Athlon64 X2 4800+ (Windsor) on an ASUS M2N motherboard with Nested Paging disabled due to lack of support.

Attachments

VBox.log Download (38.7 KB) - added by lsproc 5 years ago.
Log file from Virtualbox
061609-26722-01.dmp Download (268.9 KB) - added by lsproc 5 years ago.
I think this is the memory dump
061709-12807-01.dmp Download (279.7 KB) - added by lsproc 5 years ago.
Another BSOD with nested paging off, occured on VM start - possible incompatiblity with Windows Virtual PC. Note that VPC does not BSOD when running with AMD-V on, but there is no nested paging.

Change History

Changed 5 years ago by lsproc

Log file from Virtualbox

comment:1 Changed 5 years ago by lsproc

A minidump will be available next time I try tomorrow. I do have a full memory dump but that is a bit too big to attach.

Changed 5 years ago by lsproc

I think this is the memory dump

comment:2 Changed 5 years ago by lsproc

I think thats the one but I will get another minidump if one occurs. I have compressed the kernel memory dump (360MB) down to 71MB with 7zip which I can upload to my own webspace and link if you wish.

Changed 5 years ago by lsproc

Another BSOD with nested paging off, occured on VM start - possible incompatiblity with Windows Virtual PC. Note that VPC does not BSOD when running with AMD-V on, but there is no nested paging.

comment:3 Changed 5 years ago by lsproc

With nested paging off - BSOD when starting MSVPC VM with AMD-V enabled.

comment:4 Changed 5 years ago by sandervl73

Invalid instruction fault. This seems to imply somebody is messing with AMD-V behind our back. You're not running VirtualPC in the background, are you?

comment:5 Changed 5 years ago by lsproc

With Nested Paging on and VPC off, no BSOD occurs.

I think that, to summarise, the issue is that running VBox and MSVPC (XP Mode one) simultaneously does not work well together. It would be interesting to see if simultaneous VBox vms cause the same issue which I will investigate next. I add that this issue did not occur on the older Athlon64 X2 CPU, meaning that it must be due to the updated AMD-V support in this processor. Nested Paging apepars to make no difference.

comment:6 Changed 5 years ago by sandervl73

  • Priority changed from critical to major
  • Summary changed from BSOD when running VirtualBox with Nested Paging under a Phenom 940 to Unable to run Windows 7 XP mode emulation concurrently with VirtualBox (AMD-V/VT-x)

Yes, you can't run two virtualization products at the same time. That's just asking for trouble. And running multiple VBox VMs of course works.

We'll need to detect this properly somehow with Windows 7 then.

comment:7 Changed 5 years ago by lsproc

Excellent news! Thanks for the update :)

comment:8 Changed 5 years ago by lsproc

Out of interest, would the detection pause the emulator if it detects another virtualization product, and not allow you to start if one is detected?

comment:9 Changed 5 years ago by frank

  • Component changed from other to VMM/HWACCM

comment:10 Changed 5 years ago by sandervl73

  • Summary changed from Unable to run Windows 7 XP mode emulation concurrently with VirtualBox (AMD-V/VT-x) to Unable to run Windows 7 XP mode emulation concurrently with VirtualBox (AMD-V/VT-x) -> fixed in SVN/3.0.10

comment:11 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use