VirtualBox

Ticket #420 (closed defect: obsolete)

Opened 7 years ago

Last modified 5 weeks ago

WinXP: intelppm.sys and processr.sys on certain processors

Reported by: bruno Owned by:
Priority: critical Component: VMM
Version: VirtualBox 1.4.0 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

My laptop is a Centrino, had to follow this workaround for p3.sys and intelppm.sys to avoid BSOD (it happened already with 1.3.8)

 http://blogs.msdn.com/virtual_pc_guy/archive/2005/10/24/484461.aspx

Change History

comment:1 Changed 7 years ago by bruno

I needed to run "sc config p3 start= disabled " and "sc config intelppm start= disabled " in XP Safe Mode

comment:2 Changed 7 years ago by sandervl73

  • Priority changed from major to critical

Apparently happens with XP embedded too. ( http://forums.virtualbox.org/viewtopic.php?t=1560)

comment:3 Changed 7 years ago by sandervl73

New report:

Hi, I'm running VirtualBox 1.5.0 on Windows XP Pro and try to boot XP embedded for initializing (specifically that's XPe SP2, Feature Pack 2007, Update Rollup 1.0 - although I doubt that that makes a difference).

Just before the FBA (first boot assistant) starts, at least just before it shows its first window, I get a blue screen. The STOP error is DRIVER_UNLOADED_WITHOUT_CANCELLING_PENDING_OPERATIONS, the responsible driver file depends on the included processor component(s): "Processor" -> processr.sys "Intel Processor" -> intelppm.sys "Intel PIII" -> p3.sys

Best regards

comment:4 Changed 7 years ago by ujr

Unfortunately, there is no easy way to carry out those registry changes in a newly built XP embedded guest: the OS has never been run and cannot be started at all.

However, as I just tested, as a first measure it helps to remove or rename processr.sys (or any other offending processor driver, probably).

Now, if I only knew, why there's another bluescreen (0x0000007B) when the system starts the first time after initialization. But that's another story, I suppose.

comment:5 Changed 7 years ago by ujr

Another note: This applies for amdk6.sys and amdk7.sys as well.

comment:6 Changed 7 years ago by frank

  • Summary changed from Workaround for crash in Centrinos: DRIVER_UNLOADED_WITHOUT_CANCELLING_PENDING_OPERATIONS to WinXP: intelppm.sys and processr.sys on certain processors

We are observing this problem as well on some systems. Currently there is a workaround in our ASL code which should prevent Windows from loading this driver. However, this workaround (we just don't define an entry for a processor in the ACPI tables) seems to not work at every time.

comment:7 Changed 6 years ago by frank

  • Component changed from other to VMM

comment:8 Changed 5 years ago by ujr

Hmmm - just for the records: this bug is still in 2.1.4 (which is current at the moment). Has it been forgotten? Is there a chance for a fix?

comment:9 Changed 5 years ago by frank

No, this bug has not been forgotten but there is no fix in sight yet.

comment:10 Changed 5 years ago by jiniguy

Now seeing the same issue with v 3.0.0 (Solaris 10 x86 host).

comment:11 Changed 5 years ago by snf

I'm currently seeing this in 3.0.2. What I think may have caused it is trying to use 82545EM based network card - than I think I got the BSOD after switching NIC type (I'm saying I think because I do not quite clearly recall if I have installed the 82545EM driver or not). Tried reinstalling the network card driver to newest from Intel and switching back to 82543GC but no luck there either: STOP: 0x000000CE (0xF87048F8, 0x00000000, 0xF87048F8, 0x00000000)

comment:13 Changed 5 years ago by air

If you are seeing this problem repeatedly you can manually disable these drivers (with no negative side effect) by going to the following location in the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Processor

Or

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Intelppm

And changing the 'Start' value to '4'.

comment:14 Changed 5 years ago by xok

This problem happened to me.

The fastest fix is to boot in Safe Mode + Networking (F8 at startup)

  • Go to %Systemroot%\Inf\ and delete all OEM#.inf
  • Search for intelppm.sys in the c:\windows\ (search for hidden directories and system files)
  • Delete the 3 results of intelppm.sys
  • Reboot the Guest normally

That's it :)

comment:15 Changed 5 years ago by xok

(Sorry for re-post, but it is for better readability)

This problem happened to me.

The fastest fix is to boot in Safe Mode + Networking (F8 at startup)

  • Go to %Systemroot%\Inf\ and delete all OEM#.inf
  • Search for intelppm.sys in the c:\windows\ (search for hidden directories and system files) - Delete the 3 results of intelppm.sys
  • Reboot the Guest normally

That's it :)

comment:16 Changed 5 years ago by claude

After applying the instructions from "xok" I had the problem where the screen resolution and colour depth for my Windows VM was locked at 800x600 and 4-bit. Not very nice.

This seems to have been caused by the removal of the "OEM*" files. I have not yet been able to resolve this properly.

comment:17 Changed 5 years ago by frank

Just a wild guess: Try to re-install the VirtualBox guest additions.

comment:18 Changed 5 years ago by claude

Thats a good wild guess; unfortunately I tried that and had these weird outcomes:

Step # 1 - Uninstalled guest additions: now I could set 32-bit colour, and arbitrary resolutions. Of course, I lost all the neat integration with dynamic resizing and mouse handling. I thought I was on to a winner at that point.

Step # 2 - Re-installed guest additions: eeek. It went back to 800x600x4. I also tried messing around with different monitor types, to no avail.

The most annoying thing is my own stupidity. I could easily have taken a snapshot of the disk before I started playing around. But I did not. My colleagues helpfully remind me of this stupidity every few minutes.

Fortunately I don't have much invested in this Windows install and I am thinking of starting again.

comment:19 Changed 5 years ago by xok

TO: claude

OEM#.inf are the temporary files of the recognized devices.

If you have problems with your Display device and the OEM#.inf files are removed, then the Display / VGA will be reconizegd as "Unknown" and it is a good oportunity to insert the CD / download drivers for the Display / VGA.

I have done that procedure for other kind of drivers and hardware more than a hundred times and it is not a reason for the system not boot or having problems the Display / VGA device. Just reinstall the drivers and everything will be OK.

comment:20 Changed 5 years ago by claude

Thanks xok - unfortunately I'm not really sure where the original display drivers came from. I've checked some other (nearly identical) VM's and they just have "Default Monitor" and a virtualbox display adapter. I assumed that these drivers must have come from the guest additions, but no amount of messing around with/without the additions installed and the driver-manager seems to help.

One thing holding me back is my poor knowledge of Windows admin things! I'm more comfortable on Linux machines when messing around with this stuff.

Anyway, from here my fastest path forward is to just re-install windows. Yes, it is probably a sledgehammer but it requires only a tiny amount of knowledge (which is all I have) to acheive it.

comment:21 Changed 5 years ago by claude

I had reason to uninstall and re-install the guest additions prior to getting around to a windows rebuild, and this completely resolved the resolution problem. Perhaps I didn't do it properly the first time.

I reluctantly publish my incompetence here in case someone else can learn from it :)

comment:22 Changed 4 years ago by jurikolo

Just had same problem after installing Guest Additions with Direct 3d.
Host: Fedora 11 x86_64. Guest: Windows XP SP3. VirtualBox-3.0.10_54097_fedora11-1.x86_64

Here is screenshot:  http://dl.getdropbox.com/u/2196730/BSOD_VWXP.png

comment:23 Changed 4 years ago by neils123

Hello all. I was running fine with a my guest winXP on my host ubuntu 9.04. Then I decided to upgrade to ubuntu 9.10... Now I have this problem. Decided first to upgrade from the ubuntu package (vbox 3.08) to the Sun package (3.10) to see if that would fix the problem. It did not. Some searching led me here, and I followed air's advice to change the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Intelppm.

That fixed me right up, no BSOD, everything seems to boot and run normally. So I just wanted to make the comment that it worked in case that helps anyone else. Thanks air!

comment:24 Changed 4 years ago by plsm

Hi.

Running VirtualBox 3.0.12 r54655.

Built an XP vm on an Intel Centrino 2 T5800 laptop. Exported it to an Athlon Dual Core 5000B HP desktop. Then, after completing some work on it, exported it back to the laptop and got BSODs. Followed the link on the top of this page. Had to disable:

amdppm, intelppm and processor

OS is Windows 7.

Thought you might like to know.

comment:25 follow-up: ↓ 30 Changed 4 years ago by novafreak69

Hello...

I am running VirtualBox 3.2.4 r62467. I took a ghost image of an XP machine and ghosted it to the VBox HD... and ran a repair from the XP cd to fix most of the driver issues. Now I am getting the BSOD with the intelppm.sys. I cannot start in safe mode to edit the current registry because the system is still going through setup. I have tried to use UB4W and edit the hive in the registry... but been unsuccessful in getting the change to save in the CurrentControlSet001 in the system reg. Any suggestions for a next step would be greatly appreciated...

comment:26 Changed 4 years ago by mhanor

 http://www.runpcrun.com/0x0000007E

Quote:

boot with the Windows CDROM and start the Recovery Console on the interested partition.
then type 'disable intelppm' to disable that driver from running. Reboot

comment:27 Changed 3 years ago by Vaub

Problem is still present in VirtualBox 4.0.2.

Problem happened to my system after upgrading VirtualBox from 2.2.4 to 4.0.2:
Centrino laptop with Windows XP SP2.
VirtualBox 2.2.4, guest Windows XP SP2 worked OK, exported as Appliance.
VirtualBox 2.2.4 uninstalled, cleaned up (removed any files, folders and registry entries left over).
Fresh install of "VirtualBox-4.0.2-69518-Win.exe".
Imported Appliance mentioned above.
Crash of VM on first shutdown, blue screen:
DRIVER_UNLOADED_WITHOUT_CANCELLING_PENDING_OPERATIONS
STOP: 0x000000CE (0xF84657F8,0x00000000,0xF84657F8,0x00000000)
intelppm.sys

Problem solved by advice in topmost link http:.../484461.aspx, i.e.:
booted VM in Safe Mode with Command Prompt (pressing <F8> at startup),
issued "sc config intelppm start= disabled" on command prompt of VM, rebooted.
Now works OK.

comment:28 Changed 3 years ago by vladie

after i've upgraded to intel 2600k cpu with intel p67 chipset, all my VMs with windows XP guests stopped work. i've discovered that bsod'ed drivers - intelppm.sys and amdk7.sys (amdk7.sys in winxp which i've installed with virtualbox 3.x on AMD cpu). disabling of these drivers help, but, for example, installation of microsoft office enables them again. please fix this virtualbox problem.

comment:29 Changed 3 years ago by xok

Actually I dont think it a problem of VirtualBox..

This has happened to me because of a defective version of the Intel drivers.

I dont remember which driver version gives this problem. You have to download the drivers from the Intel website depending the Network Adapter you choose. If you just need 100Mbps just choose PCnet-FAST III, as it does not give such problem.

But if you feel lucky :) you can try any driver with the Intel NIC, if it works remember that you were lucky... :)

As I told before, to solve this issue:

The fastest fix is to boot in Safe Mode + Networking (F8 at startup)

  • Delete the files intelppm.* existing in the c:\windows\ and sub-dirs.
  • Go to %Systemroot%\Inf\ and delete all OEM*.inf
  • Re-install Guest Additions.
  • Reboot

DONE!

comment:30 in reply to: ↑ 25 Changed 3 years ago by jamshehan

Replying to novafreak69:

Hello...

I am running VirtualBox 3.2.4 r62467. I took a ghost image of an XP machine and ghosted it to the VBox HD... and ran a repair from the XP cd to fix most of the driver issues. Now I am getting the BSOD with the intelppm.sys. I cannot start in safe mode to edit the current registry because the system is still going through setup. I have tried to use UB4W and edit the hive in the registry... but been unsuccessful in getting the change to save in the CurrentControlSet001 in the system reg. Any suggestions for a next step would be greatly appreciated...

I was stuck in the same place as novafreak69, the only difference being that I was running a Windows Server '03 machine, not XP, but the fix should work in both I think. Here's how I got past it:

Boot up with the Windows installation disk, go into the recovery console, and type disable {driver name}

You can run listsvc first to see the list of all services and drivers. In my case, the BSOD mentioned the AMDK8.sys driver as the problem, so I ran listsvc, noticed that amdk8 was listed with a startup type of System, and ran disable amdk8. I quit out of the Recovery Console, rebooted, and the Windows install/repair finished successfully.

comment:31 Changed 5 weeks ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use