VirtualBox

Ticket #4192 (new defect)

Opened 5 years ago

Last modified 5 years ago

Virtualbox 2.2.4: Online Armor Personal Firewall 3.5.0.14 installation freezes WinXP SP3 when VT-x is enabled

Reported by: davidljwang Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.4 Keywords:
Cc: Guest type: Windows
Host type: other

Description

After I installed Windows XP SP3 guest VM with Vbox 2.2.4 default settings(i.e., VT-x was enabled), I went on to install Online Armor Personal Firewall 3.5.0.14 in the VM. However, at the end of the installation, when the installer tried to bring up the firewall service, the VM processor utilization rate went up to ~100%. Nothing can be done other than powering-off the VM coldly. After some research, I saw this thread in the forum  http://forums.virtualbox.org/viewtopic.php?f=7&t=17562 I tried the recommended work-around of disabling VT-x, and installed Firewall again. This time it did succeed. Therefore, there must be something wrong with VT-x support. I didn't see anyone creating a bug report, and I do think VT-x support is important. This is why I created this ticket. My hardware spec: CPU: Intel Core 2 Duo 6320 Memory: 8GB Motherboard: Asus P5K-SE Video Card: Sapphire ATI Radeon 2600XT Hard Drive: Seagate Barracuda 7200.11 1.5TB Host OS: Ubuntu 9.0.4

Virtualbox VM setting:

General Name: test_winxp OS Type: Windows XP Base Memory: 512 MB Video Memory: 12 MB Boot Order: Floppy, CD/DVD-ROM, Hard Disk ACPI: Enabled IO APIC: Disabled VT-x/AMD-V: Enabled Nested Paging: Disabled PAE/NX: Disabled 3D Acceleration: Disabled Hard Disks IDE Primary Master: test_winxp.vdi (Normal, 10.00 GB) CD/DVD-ROM Image: en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso Floppy Not mounted Audio Host Driver: PulseAudio Controller: ICH AC97 Network Adapter 1: PCnet-FAST III (NAT) Serial Ports Disabled USB Device Filters: 0 (0 active) Shared Folders None

Remote Display Disabled

Attachments

test_winxp-2009-06-06-22-12-08.log Download (47.7 KB) - added by davidljwang 5 years ago.
test_winxp-2009-06-06-22-20-50.log Download (50.7 KB) - added by davidljwang 5 years ago.

Change History

Changed 5 years ago by davidljwang

Changed 5 years ago by davidljwang

comment:1 Changed 5 years ago by davidljwang

After firewall installation failed and I cold-start the VM again, the VM can't boot up anymore. please see the second log file. Actually, I tried another firewall- Comodo Free Firewall. The result was almost the same: Although installation seemed successful, VM can't boot up after restart. I also tried it on Windows XP SP3 as host OS, the result was the same. Although disabling VT-x is a work-around, performance would suffer greatly.Hope it can be fixed ASAP.

comment:2 Changed 5 years ago by Hachiman

Does you configuration worked with previous veraions of VBox? Or problem has been introduced in 2.2.4?

comment:3 Changed 5 years ago by davidljwang

I tried 2.2.2 and 2.2.4.There were no difference.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use