VirtualBox

Ticket #4181 (closed defect: worksforme)

Opened 5 years ago

Last modified 4 years ago

Inconsistent copy paste behavior

Reported by: nick.dap Owned by:
Priority: major Component: clipboard
Version: VirtualBox 2.2.4 Keywords:
Cc: Guest type: Windows
Host type: other

Description

Host is Vista. Guest is CentOS 4.7 Latest guest additions (2.2.4r47978) installed.

Tried with GNOME Tried with KDE Tried with Eclipse Tried with Netbeans IDE Tried with Klipper on/off Issue exists in all cases and permutations

To reproduce:

  1. Copy "text 1" in guest
  2. Copy "text 2" in host
  3. CTRL + V into Eclipse or Netbeans (Java?), incorrectly "text 1" is pasted, even though "text 2" should have been pasted
  4. Middle mouse click in Netbeans/Eclipse, correctly pastes "text 2"
  5. CTRL + V in Netbeans, incorrectly pastes "text 1"
  6. Middle mouse click in Netbeans/Eclipse, again correctly pastes "text 2"

... ad infinitum, like you have separate clipboards for CTRL + V vs Middle click

Different use case:

  1. Copy "text 1" in guest
  2. Copy "text 2" in host
  3. CTRL + V into Eclipse/Netbeans, incorrectly pastes "text 1"
  4. CTRL + V into a "mediator", gedit, firefox, w.e, correctly pastes "text 2"
  5. CTRL + V again in Eclipse or Netbeans, correctly pastes "text 2"

Also, see this thread:  http://forums.virtualbox.org/viewtopic.php?f=3&t=7482&p=79468#p79468

Change History

comment:1 Changed 5 years ago by nick.dap

Excuse poor formatting in original.

Host is Vista.
Guest is CentOS 4.7
Latest guest additions (2.2.4r47978) installed.

Tried with GNOME
Tried with KDE
Tried with Eclipse
Tried with Netbeans IDE
Tried with Klipper on/off
Issue exists in all cases and permutations

To reproduce:

  1. Copy "text 1" in guest
  2. Copy "text 2" in host
  3. CTRL + V into Eclipse or Netbeans (Java?), incorrectly "text 1" is pasted, even though "text 2" should have been pasted
  4. Middle mouse click in Netbeans/Eclipse, correctly pastes "text 2"
  5. CTRL + V in Netbeans, incorrectly pastes "text 1"
  6. Middle mouse click in Netbeans/Eclipse, again correctly pastes "text 2"

... ad infinitum, like you have separate clipboards for CTRL + V vs Middle click

Different use case:

  1. Copy "text 1" in guest
  2. Copy "text 2" in host
  3. CTRL + V into Eclipse/Netbeans, incorrectly pastes "text 1"
  4. CTRL + V into a "mediator", gedit, firefox, w.e, correctly pastes "text 2"
  5. CTRL + V again in Eclipse or Netbeans, correctly pastes "text 2"

Also, see this thread:  http://forums.virtualbox.org/viewtopic.php?f=3&t=7482&p=79468#p79468

comment:2 Changed 5 years ago by michael

Not reproducible here with guest == host == Ubuntu 9.04. Can you see if you can reproduce the same thing with two consecutive copies in the guest instead of first copy guest, second host? I have seen that before with Eclipse (on real hardware), although in my case it was apparently due to the clipboard manager.

comment:3 Changed 5 years ago by michael

Is this still an issue with VirtualBox 3.0.4? And are you running a clipboard manager in your guest system?

comment:4 Changed 4 years ago by Technologov

No answer.

Please Close as INVALID.

-Technologov

comment:5 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use