Opened 15 years ago

Closed 4 years ago

#4163 closed defect (obsolete) missing after installing solaris guest addition

Reported by: barbarin Owned by:
Component: guest additions Version: VirtualBox 2.2.2
Keywords: Cc:
Guest type: Solaris Host type: Windows

Description (last modified by Frank Mehnert)

After installing guest addition for a solaris Guest, in order to run an OpenGL accelerated application, my app is complaining about missing

This is a dependency that comes from the library that installs withthe guest addition.

Thanks to check it out Phil

Change History (16)

comment:1 by Juergen Keil, 15 years ago

What's the version of the solaris operating system that you've installed as a guest?

I can tell you that with a current OpenSolaris 2009.06 installation, there is:

> ls -lL /usr/lib/amd64/ /usr/lib/ /usr/X11/lib/ /usr/X11/lib/amd64/
-rw-r--r--   1 root     bin        16984 Mai 11 11:39 /usr/lib/amd64/
-rw-r--r--   1 root     bin        14892 Mai 11 11:39 /usr/lib/
-rw-r--r--   1 root     bin        16984 Mai 11 11:39 /usr/X11/lib/amd64/
-rw-r--r--   1 root     bin        14892 Mai 11 11:39 /usr/X11/lib/

comment:2 by barbarin, 15 years ago

I just install version 3.02 and my 2 OPENGL software are still complaining about this missing library. I have also been trying to force the install of from openSolaris, but this is not working neither.

comment:3 by barbarin, 14 years ago

I just installed and test the same against verion 3.08, and this issue is still not solved. Can anyone tell me if it will be considered in a future release

Thanks and regards

comment:4 by Sander van Leeuwen, 14 years ago

Which version of Solaris?

comment:5 by barbarin, 14 years ago

I am using Solaris 10 5/09. Both OpenGL Applications run fine on this version. With Virtual box, it is ok without solaris addition, but no accelarated graphics nor desktop integration.

After installing guest addition pkg, OpenGL behavior is changed and lib dependency are different. It complains about when running. Also ldd shows that it is not there.

I have also been trying to grab this lib on an opensolaris install, but it does not work on solaris 10.

So I am still unable to run this applications on VB

Thanks for your help Phil

comment:6 by Ramshankar Venkataraman, 14 years ago

Could you please show "ldd <appname>" of the OpenGL program you're trying to run?

comment:7 by barbarin, 14 years ago

Here is ldd when no addition is installed =>	 /usr/apl/cadds/slib/ =>	 /usr/apl/cadds/slib/ =>	 /usr/apl/cadds/slib/ =>	 /usr/apl/cadds/slib/ =>	 /usr/apl/cadds/slib/ =>	 /usr/apl/cadds/slib/ =>	 /usr/openwin/lib/ =>	 /usr/openwin/lib/ =>	 /usr/openwin/lib/ =>	 /usr/apl/cadds/slib/ =>	 /lib/ =>	 /usr/ucblib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /usr/openwin/lib/ =>	 /lib/ =>	 /lib/ =>	 /usr/lib/ =>	 /usr/lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/

In that case, the app is running ok, but no HW acceleration

Now this is ldd after installing guest addition (3.08) =>	 /usr/apl/cadds/slib/ =>	 /usr/apl/cadds/slib/ =>	 /usr/apl/cadds/slib/ =>	 /usr/apl/cadds/slib/ =>	 /usr/apl/cadds/slib/ =>	 /usr/apl/cadds/slib/ =>	 /usr/openwin/lib/ =>	 /usr/openwin/lib/ =>	 /usr/openwin/lib/ =>	 /usr/apl/cadds/slib/ =>	 /lib/ =>	 /usr/ucblib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /usr/openwin/lib/ =>	 /lib/ =>	 /lib/ =>	 /usr/lib/ =>	 /usr/lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /usr/lib/ =>	 (file not found) =>	 /usr/sfw/lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/ =>	 /lib/

You can notice that libXcomposite is missing Hope this helps

comment:8 by Ramshankar Venkataraman, 14 years ago

Could you try installing SUNWxwplt (from package on your guest? I think this might be a shortcoming of Solaris 10 packaging.

comment:9 by barbarin, 14 years ago

this package is already installed remember I am running solaris 10 5/09 on my guest

comment:10 by DRC, 14 years ago

I am having this same problem with a Solaris 10 u5 guest and VirtualBox 3.2.2. I don't know why the manual and the web site claim that 3D acceleration works on Solaris 10 u5 or later guests. To my knowledge, no versions of Solaris 10 include That is a component of Xorg 7.x, whereas Solaris 10 uses Xorg 6.8.

comment:11 by DRC, 13 years ago

Bump. Problem still exists with VBox guest additions 4.0.4.

comment:12 by Frank Mehnert, 8 years ago

Description: modified (diff)
Resolution: obsolete
Status: newclosed

comment:13 by andbarac, 8 years ago

Resolution: obsolete
Status: closedreopened

Is there a solution or a workaround for this problem? Problem still exists with the latest VBox guest additions Version 5.0.12 r104815.

comment:14 by Frank Mehnert, 8 years ago

If the is missing then you probably need to install the corresponding Solaris package. Which version of Solaris are you using in your guest?

comment:15 by andbarac, 8 years ago

$ cat /etc/release

Oracle Solaris 10 1/13 s10x_u11wos_24a X86

$ uname -a

SunOS u001 5.10 Generic_147148-26 i86pc i386 i86pc

Last edited 8 years ago by andbarac (previous) (diff)

comment:16 by aeichner, 4 years ago

Resolution: obsolete
Status: reopenedclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use