VirtualBox

Ticket #4149 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

Problem starting vm with bridged networking

Reported by: freesurface Owned by:
Priority: major Component: network
Version: VirtualBox 2.2.4 Keywords: bridged networking
Cc: Guest type: Windows
Host type: Linux

Description

Hi there,

I have a clean installation of a Ubuntu 9.04 64-bit server without GUI. I installed Virtualbox 2.2.4 via apt-get by adding the Ubuntu/Debian repository to sources.list.

Then I followed the step by step instructions to set up a VM (Windows XP SP3) on a headless server. I would like to use bridged networking to make the VM completely available in my local network. I realised this via

VBoxManage modfifyvm "gvpc60" --nic1 bridged

At this point I a not sure, if I have to define the bridgeadapter with

VBoxManage modifyvm "gvpc60" --bridgeadapter1 foo

I did not do this, since I have no idea how to replace "foo".

Instead I directly tried to start the installation process of my VM by

VBoxHeadless --startvm gvpc60 
VirtualBox Headless Interface 2.2.4
(C) 2008-2009 Sun Microsystems, Inc.
All rights reserved.

Listening on port 3389
Error: failed to start machine. Error message: Failed to open/create the internal network 'HostInterfaceNetworking-' (VERR_INTNET_FLT_IF_NOT_FOUND).
Unknown error creating VM (VERR_INTNET_FLT_IF_NOT_FOUND)

I got the error message displayed above. Do you have a solution to this problem. BTW, when using nat as network configuration, the VM comes up without any problems.

Please find attached the result of ifconfig of my server, the xml and the logfile of Virtualbox.

Regards, Steffen

Attachments

VBox.log Download (28.7 KB) - added by freesurface 5 years ago.
gvpc60.xml Download (3.0 KB) - added by freesurface 5 years ago.
ifconfig.txt Download (1.5 KB) - added by freesurface 5 years ago.

Change History

Changed 5 years ago by freesurface

Changed 5 years ago by freesurface

Changed 5 years ago by freesurface

comment:1 Changed 5 years ago by freesurface

Problem solved - no bug.

Just use the option --nic1 bridged and --bridgeadapter eth0 for VBoxManage modifyvm within one command line. The it works!

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

Right. You have to attach the bridged network adapter to an existing NIC at the host.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use