VirtualBox

Ticket #4140 (new defect)

Opened 5 years ago

Last modified 13 months ago

Cannot access the kernel driver after upgrading (Windows host)

Reported by: abcuser Owned by:
Priority: major Component: installer
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Hi,
on Windows XP SP3 host and Ubuntu 9.04 I had VirtualBox 2.2.2 working well without any problem.

Then I did the following:

  1. shutdown virtual guest
  2. installed VirtualBox 2.2.4 over the existing installation.
  3. rebooted Windows host
  4. opened VirtualBox GUI
  5. deleted all VirtualBox log files to make sure there is no errors in logs.
  6. selected Ubuntu guest and clicked Start button from tools bar menu.

The error displayed: "Cannot access the kernel driver! Make sure the kernel module has been loaded successfully." Then only Abort button available and click on it displayed error: "Failed to open a session for the virtual machine..."

See attached pictures to the forum:  http://forums.virtualbox.org/viewtopic.php?f=6&t=18369

I have checked the log files but there was no log file created! Very strange.

Has anyone got the same problem?
Regards

 http://forums.virtualbox.org/viewtopic.php?f=6&t=18369

Attachments

install.zip Download (357.3 KB) - added by abcuser 5 years ago.
install-and-repair.zip Download (6.9 KB) - added by harvi 4 years ago.

Change History

comment:1 Changed 5 years ago by abcuser

Hi, as I see the same bug was already reported  http://www.virtualbox.org/ticket/4084 but that was for version 2.2.2 that in my case was working without any problem at all.
There are 3 questions in that bug report:

  1. Which Windows version is that?

Windows XP SP3

  1. Was the installation of the VBox package successful or were there any errors reported?

No error, just like any other installation of VirtualBox

  1. Which package did you install?

VirtualBox-2.2.4-47978-Win.exe

Regards

comment:2 Changed 5 years ago by abcuser

Hi,

  1. I have uninstalled Vbox 2.2.4
  2. Manually removed all files from "c:\program files\sun\xvm vitualbox" folder and deleted "C:\Documents and Settings\[user]\.VirtualBox\Machines" folder.
  3. Install Vbox 2.2.2.
  4. Created new virtual machine and selected existing vdi file
  5. virtual machine started-up and working without any problems at all.


It looks there is some kind of bung in Vbox 2.2.4.
Hope this helps,
Regards

comment:3 Changed 5 years ago by abcuser

Hi,
there is workaround solution published by Perryg on forum:  http://forums.virtualbox.org/viewtopic.php?f=6&t=18369&p=79148#p79148 that worked for me well and now problem is solved.

Instructions:

  1. Install Vbox 2.2.4 over 2.2.2
  2. Reboot
  3. Start Vbox and error is displayed
  4. Double click on install program again and select Repair.
  5. Reboot before starting VM guest
  6. Start VM guest


It looks there is some kind of bug in installation procedure that incorrectly copies files or something similar.
Regards

comment:4 Changed 5 years ago by frank

  • Component changed from host support to installer

comment:5 Changed 5 years ago by abcuser

Hi, today I have installed vbox 3.0.0 over 2.2.4 and got the same error. Work-around described in my previous post solves the problem again.

It looks this bug remains. Just to let you know bug still exists. Regards

comment:6 Changed 5 years ago by abcuser

Hi, today I have installed vbox 3.0.2 over 3.0.0 and got the same error. Work-around is the same. Just to let you know bug still exists
Regards

comment:7 Changed 5 years ago by sumeetsvaidya

Hello, the same issue was faced by me, while using VirtualBox 2.2.4 on OS X 10.5.7
Initially I was using VirtualBox 2.2.2 and before installing VirtualBox 2.2.4, I uninstalled VirtualBox 2.2.2
Re-installing VirtualBox 2.2.4 solves the problem
Thanks,
Sumeet

comment:8 Changed 5 years ago by abcuser

Hi, just to inform you, I have installed vbox v3.0.4 and problem still exists. Work-around is instructions written few posts above. Regards

comment:9 Changed 5 years ago by sandervl73

Can you attach an MSI installer log of such a failed attempt? (see  http://www.virtualbox.org/wiki/MSI_Logging)

Changed 5 years ago by abcuser

comment:10 Changed 5 years ago by abcuser

Hi, I have done the following:

  1. uninstall 3.0.4
  2. install 3.0.2
  3. install 3.0.4

and got the same error: "Cannot access the kernel driver".

Please see attached log files. Regards

comment:11 Changed 5 years ago by pentagonik

@abcuser: Did you reboot the host machine after each uninstall/install? According to the log the installer should have showed you a reboot message when uninstalling the VBox kernel driver:

DIFXAPP: WARNING:We've waited a while for the service to get deleted, but it did not get deleted yet. Will prompt for reboot

. . .

DIFXAPP: ERROR:  Unable to start service 'VBoxDrv' because of error 0x422

comment:12 Changed 5 years ago by abcuser

Hi,
I am not sure, but if I remember correctly:

  1. uninstall 3.0.4
  2. didn't restart (no message info that I should)
  3. install 3.0.2
  4. restarted
  5. install 3.0.4 over 3.0.2
  6. restarted
  7. repair 3.0.4
  8. restarted

Regards

comment:13 Changed 5 years ago by drDuck

I had the same problem, However I looked at Norton for another reason, and noticed that it had blocked registry changes.

I turned off the AutoProtect in Norton for 15-minutes. Then I uninstalled and re-installed 3.0.4 ALL IS FINE.

The norton excuse was several UNAUTHORIZED ACCESS BLOCKED(CREATE REGISTRY KEY) and UNAUTHORIZED ACCESS(ACCESS PROCESS DATA)and UNAUTHORIZED ACCESS BLOCKED(Open Process Token)

So with Norton off for 15 minutes all is working perfectly now.

comment:14 Changed 5 years ago by abcuser

Hi, I have uninstalled VirtualBox 3.0.4, rebooted Windows host. Disabled ESET NOD32 Antivirus version 3.0.650.0. Installed VirtualBox again and it works fine. It looks installation program executes some commands that antivirus program does not permit, but "Repair" option doesn't get refused by antivirus. So it is still a installation problem. I suggest to look into why "Repair" is not refused by antivirus program and why "Install" does.

BTW, when uninstalling VirtualBox and clicking on Reboot VirtualBox installation button after uninstall has finised, Windows reboot has frozen and after hard reset I all network settings vanished - so network corruption has appeared. I have restored my Windows host from disk backup image. Is there a bug in "Reboot" option? Regards

comment:15 Changed 5 years ago by rickybrent

Hello; I also ran into this problem with 3.0.4. I do not run Norton, but do use Avast. The "Repair" install worked for me as well; I did not have to reboot afterward.

comment:16 Changed 5 years ago by secristrc

The same problem ("Cannot access the kernel driver!") occurs with VirtualBox-3.0.6-52128-Win.exe on Windows XP SP2, with the same workaround (run the installer again and choose the repair option). The error occurred immediately after a reboot. After repairing I did not have to reboot.

comment:17 Changed 5 years ago by frank

  • Version changed from VirtualBox 2.2.4 to VirtualBox 3.0.6

comment:18 Changed 5 years ago by frank

  • Summary changed from Cannot access the kernel driver after upgrade from Virtualbox 2.2.2 to 2.2.4 to Cannot access the kernel driver after upgrading (Windows host)

comment:19 Changed 4 years ago by pentagonik

@secristrc and rickybrent: Does this problem still persist using the latest version 3.1 of VBox?

comment:20 Changed 4 years ago by gleira

It has happened to me when upgrading 3.1.0 to 3.1.2. I have solved it repairing the installation.

Changed 4 years ago by harvi

comment:21 Changed 4 years ago by harvi

I installed VirtualBox 3.1.2 for the first time on my fresh Vista 64bit SP2. During the installation I had UAC and antivirus turned off. At the end of installation but before the system rebooted I've seen a popup "MSI some-number error" that blinked for less than half a second... I created a new VM and started it but got the error "Cannot access the kernel driver". Then I tried to do the Repair in control panel but it didn't help.

The MSI installation and repair logs are attached.

comment:22 Changed 3 years ago by abcuser

Just an update for v4.0.

Today I have installed VBox v4.0 and I forgot to disable Nod32 anti-virus, but installation worked OK, which is nice. There is also a change in my Nod32 version, I now use: 4.0.468.0, so it could also be that Nod32 does not block VBox installation anymore. So problem for my system is solved and this bug report can be closed.

comment:23 Changed 3 years ago by kenden

After upgrading from VirtualBox 4 to VirtualBox 4.0.10 on Windows 7 64, I got the problem with Ubuntu 11.04. Uninstalling and reinstalling VirtualBox solved it.

comment:24 Changed 3 years ago by BarryCent

I am experiencing the same issue: Win 7 x64 host, upgrade from 4.0.8 to 4.0.10.

I am going to attempt a reinstall of VirtualBox to resolve this, but thought it was best to inform you that the issue was not completely resolved.

comment:25 Changed 3 years ago by MartinBonner

Windows XP SP3 host: Upgrade 4.1.2 to 4.1.4 -> same problem.

Reboot, repair, reboot fixes it.

comment:26 Changed 2 years ago by mastabog

Same issue here in WinXP SP3 upgrading from 4.1.4 to 4.1.6. Installing again (and choosing repair) fixes it.

This is such an old bug ... why not fix it properly?

comment:27 Changed 20 months ago by Lulu58e2

Same issue here on Win 7 64-bit SP-1 upgrading from 4.1.18-78361 to 4.1.20-80170 and from 4.1.20-80170 to 4.1.22-80657; repair & reboot fixed it.

Last edited 19 months ago by Lulu58e2 (previous) (diff)

comment:28 Changed 19 months ago by snorky2001

Same issue with XP SP3 upgrading from 4.1.4 to 4.2.0. Repair fails as installation .msi file is not found. Uninstall + reinstall solve the problem.

comment:29 Changed 13 months ago by RSexton

For what it's worth and anyone else with this problem: I was prompted to upgrade my version from 4.2.8 to 4.2.10 and afterwards was told the extpack needed to be updated, which I allowed and after the restart was hit with this same error. Doing a repair install by starting the downloaded update and choosing repair (without restarting the host after) corrected this for me. Based on this thread, this seems to be somewhat common, but I openly admit I am a new user for the application. I created an account just to leave this comment, but I would think it will come in handy down the road. :-) Rob

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use