VirtualBox

Ticket #4130 (closed defect: worksforme)

Opened 5 years ago

Last modified 2 years ago

VT-x not enabled -> update your BIOS

Reported by: guilhermesg Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Hello,

I have processor intel P8400 C2D, x64 on ubuntu 9.10 64x

Whem start the virtual SO, its displaied the message: "VirtualBox Error:

VT-x/AMD-V hardware acceleration has been enabled, but is not operational. You 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot.

Please ensure thet you have enabled vt-x/AMD-V propert in the BIOS of tour host computer. "

In my BIOS de intel virtualization is enable.

Thanks!

Attachments

BaseLinuxEnterprise64-2009-05-29-20-58-53.log Download (46.7 KB) - added by guilhermesg 5 years ago.
BaseLinuxEnterprise64-2009-05-29-21-08-46.log Download (46.8 KB) - added by guilhermesg 5 years ago.
BaseLinuxEnterprise64-2009-05-29-21-31-47.log Download (46.0 KB) - added by guilhermesg 5 years ago.
gentoovm-2009-12-30-08-17-25.log Download (57.6 KB) - added by jakepunk 4 years ago.
VBox.log Download (58.4 KB) - added by Knitebane 4 years ago.
M61SME-S2.txt Download (305.0 KB) - added by Knitebane 4 years ago.
My hardware
Vbox.log Download (67.1 KB) - added by ecsdrive 3 years ago.
Vbox.log Dell Optiplex Core2Duo

Change History

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

If you want help, then you should include VBox.log. Your BIOS probably doesn't turn on VT-x properly.

Changed 5 years ago by guilhermesg

Changed 5 years ago by guilhermesg

Changed 5 years ago by guilhermesg

comment:2 Changed 5 years ago by guilhermesg

  • Status changed from closed to reopened
  • Resolution worksforme deleted

sorry. Here the log files.

I checked the BIOS again and this really qualified, that would be a problem of ubuntu?

comment:3 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to invalid
  • Summary changed from Enable to VT-x not enabled -> update your BIOS

It's a BIOS problem; VT-x is disabled and locked. You can try to disable it in the BIOS (perhaps they inverted the setting) or find an update. It's not a VirtualBox bug.

comment:4 Changed 5 years ago by MarioVilas

I'm having the same problem with Ubuntu 8.10. VT-x was disabled so I enabled it in the BIOS, but after rebooting nothing changed - still showing the same error message. Maybe I have to do something else? I also tried running "vboxdrv setup" but still no success.

comment:5 Changed 4 years ago by mircea_vutcovici

  • Status changed from closed to reopened
  • Resolution invalid deleted

I have installed the VirtualBox 3.1.0 r55467 on Ubuntu 9.10 64 bit desktop and it worked well until the first reboot. After that I am receiving the error message specified in the ticket when I am trying to start a 64bit VM. I mention that kvm is starting without problems and the the setting for virtualization in BIOS was enabled. Changing the BIOS setting to disable and the enable did not fix the problem. CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy Motherboard: Asus M2N-E

comment:6 Changed 4 years ago by klaus

  • Status changed from reopened to closed
  • Resolution set to invalid

AMD systems have no VT-x, so this is the wrong bug for such systems anyway.

And enabling VT-x on some system requires a power cycle. A simple reset/reboot isn't enough.

comment:7 Changed 4 years ago by jakepunk

  • Status changed from closed to reopened
  • Resolution invalid deleted

I have the same symptom as mircea_vutcovici above. I am using VirtualBox 3.1.2 r56127 on Mac OS X 10.5.8 on a Macbook Pro model A1226. I created a 64-bit gentoo VM from a .vdi, and it started up successfully yesterday. Today after I powered up my laptop and try to start the vm, I get the message, "VT-x/AMD-V hardware acceleration has been enabled, but is not operational...". Any ideas as to why VirtualBox would work the first time but not subsequent times across reboots? VBox.log attached. When I downgrade to VirtualBox 3.0.8 r53138 the problem no longer exists.

Changed 4 years ago by jakepunk

comment:8 Changed 4 years ago by Knitebane

I'm getting this too. I'm running VirtualBox 3.1.4-57640 installed from the Ubuntu repository. My host system is a AMD64 system running Ubuntu 9.10. I created a VM to test out the next version of Ubuntu, downloaded the current 9.10 AMD64 alternate CD with the intention of installing it and then upgrading to 10.04. The same "VT-x/AMD-V hardware acceleration has been enabled, but is not operational" message comes up. If I continue past it the boot menu comes up but if I select to boot the CD I get the message that my system is not a 64-bit system. I've not tried downgrading but this used to work. This is how I tested my upgrade from 9.04 to 9.10 so at some point about 6 months ago my 64-bit host could run 64-bit guests. I'm attaching the VBox.log.

Changed 4 years ago by Knitebane

Changed 4 years ago by Knitebane

My hardware

comment:9 Changed 4 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

jakepunk: are you using other virtualizers? it failed because somebody is using VT-x. Reopen if required please.

Knitebane: duplicate of #5639

comment:10 Changed 3 years ago by ebonweaver

  • Status changed from closed to reopened
  • Resolution fixed deleted

This is apparently a bug in VirtualBox that has not been fixed. As of version 3.2.12 this error is still reported on all Dell systems with Core2duo chips. For example, I have an Optiplex 755 with an E8200 which supports VT-x per  http://ark.intel.com/Product.aspx?id=33909 and has all virtualization options on in the BIOS. It is running Win 7 Ent 64bit just fine. Virtualbox however insists that VT-x is not operational when I attempt to launch a 2008 R2 guest for first install. If I try to install anyway, the boot loader on the DVD fails to start. This problem does not occur in the Mac version of 3.2.12, only the Windows version. VB on Win is simply unable to properly read and work with the host hardware and virtualization support apparently. If this means that VB can not read the BIOS settings correctly, that is still a problem with VB, not an issue with the BIOS, especially when you are talking about a brand as large as Dell. You need to be able to work with them, not insist they change their BIOS configuration.

comment:11 Changed 3 years ago by frank

Obviously you don't understand the problem. For many users updating the BIOS did solve the problem. VirtualBox is not unable to read the BIOS settings but VT-x is often disabled + locked by the BIOS. In that case, VirtualBox can't do anything but fall back to software virtualization. VirtualBox is often the first application which is ever using VT-x, this hardware extension is not required for regular applications. If VBox can't use VT-x on your host, the minimum information we appreciate is a VBox.log file because it contains logging which can give a hint where the problem is.

comment:12 Changed 3 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to worksforme

Dell is such a large brand that they can't possibly make any mistakes? That's a good one! Too bad they did make such mistakes just like pretty much all the other big ones.

Like Frank said; the VBox.log will confirm exactly that if it's not too much trouble for you to upload it.

comment:13 Changed 3 years ago by ebonweaver

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Obviously you are not paying attention and your unprofessional responses indicate you have no intention of fixing the problems in your software.

  1. I never said Dell could not make a mistake, but in this case they have not
  2. VT-x is enabled and working, VirtualBox is not functioning properly
  3. VMware's product works properly and can read the VT-x setting and run a 64bit guest
  4. I would include a log if one was available, but that function also seems to not work properly. When I choose show log, the last update (in all 4 tabs) is from 2 weeks ago.

If there is a procedure to obtain a fresh clean log that shows only the start up attempt of a 64bit guest with the failure of your software to read the VT-x settings please detail it and I'll be happy to provide the log. Otherwise, if you prefer to simply close problem tickets instead of investigate and fix them we'll stop bothering to try to help improve the product.

comment:14 Changed 3 years ago by sandervl73

No VBox.log means no help no matter how much you complain. We'd be happy to look at your trouble if you can manage to keep calm.

comment:15 Changed 3 years ago by frank

How do you know that VMware can use the VT-x mode of your host? Because VMware can run a 64-bit guest? That is no proof.

Finding the VBox.log file is very easy: Just open the main GUI window and choose Machine / Show Log..., read section 12.1.2 of the user manual.

comment:16 Changed 3 years ago by ecsdrive

Same issue on Dell Optiplex Core2Duo, attached log file

comment:17 Changed 3 years ago by sandervl73

ecsdive: the same goes for you: your Dell BIOS is broken as the log file clearly shows (VT-x disabled and locked -> we can't enable it). I don't know which Optiplex you've got, but there are at least a few hits on google about vt-x issues on these systems. (e.g.  http://en.community.dell.com/support-forums/desktop/f/3514/t/19264100.aspx)

comment:18 follow-up: ↓ 19 Changed 3 years ago by MarioVilas

ecsdive: just curious, does VMWare work in that machine? and does it use vt-x?

comment:19 in reply to: ↑ 18 Changed 3 years ago by ecsdrive

I haven't tried VMWare on this machine, I'll try to update the BIOS and post my result (my Dell is an Optiplex 755 if that's of any use)

comment:20 Changed 3 years ago by ecsdrive

With latest BIOS (A17) for Optiplex 755 I get the same message, so no luck running using VT-X

00:00:00.504 DevPcBios: SATA LUN#0 LCHS=851/255/63
00:00:00.504 PGMR3InitFinalize: 4 MB PSE mask 0000000fffffffff
00:00:00.520 HWACCM: No VT-x or AMD-V CPU extension found. Reason VERR_VMX_MSR_LOCKED_OR_DISABLED
00:00:00.520 HWACCM: VMX MSR_IA32_FEATURE_CONTROL=ff0b
00:00:00.535 VM: Halt method global1 (5)
00:00:00.535 Changing the VM state from 'CREATING' to 'CREATED'.
00:00:00.535 Changing the VM state from 'CREATED' to 'POWERING_ON'.
00:00:00.535 Changing the VM state from 'POWERING_ON' to 'RUNNING'.
00:00:00.551 Guest Log: BIOS: VirtualBox 3.2.12

Changed 3 years ago by ecsdrive

Vbox.log Dell Optiplex Core2Duo

comment:21 Changed 3 years ago by ecsdrive

You need to have in BIOS Trusted Execution set to OFF and TPM set to ON see this blog post  http://www.shnake.com/blog/?p=419

You may close this issue, but maybe it's useful to have a note somewhere (release notes? FAQ page?) to note this. I've read about people sending back the machines to Dell for this.

Cheers

00:00:00.797 HWACCM: 32-bit and 64-bit guests supported.
00:00:00.797 HWACCM: VMX enabled!
00:00:00.797 HWACCM: TPR Patching disabled.
00:00:00.797 HWACCM:    VT-x/AMD-V init method: GLOBAL
00:00:00.812 VM: Halt method global1 (5)
00:00:00.812 Changing the VM state from 'CREATING' to 'CREATED'.
00:00:00.812 Changing the VM state from 'CREATED' to 'POWERING_ON'.
00:00:00.813 Changing the VM state from 'POWERING_ON' to 'RUNNING'.
00:00:00.832 Guest Log: BIOS: VirtualBox 3.2.12

comment:22 Changed 3 years ago by MarioVilas

I agree with ecsdrive, "update your BIOS" is clearly not good advice here... it'd be much better to have this explained in the help, and the error message could tell the user where to find that explanation.

comment:23 Changed 3 years ago by sandervl73

It clearly *is* good advise. Quite a few vendors fix bugs in their BIOS. In 90% of the cases the error message is correct. We don't think that an error message should contain an explanation for all possible causes. There's only so much you can expect from us for (stupid) problems 3rd parties create. We can add a hint to the manual though.

comment:24 Changed 3 years ago by ebonweaver

many thanks to ecsdrive for coming up with the fix! It's unfortunate that the devs/support seem to be so hostile and unhelpful towards the users, at least the user community is helpful.

While knowing your BIOS is up to date and having virtualization enabled are obviously prudent advice, turning one of the virtualization features OFF, and a security feature ON in order to make the software work correctly is counter intuitive. Taking the stance that users should be able to figure this out, or that it's somehow the manufacturer's fault is absurd. You have to provide documentation about your software that indicates it's requirements, and these are clearly requirements, so the basic install/ setup info needs to include these items. While they may not be there for all BIOS types, knowing they are there for a large number calls for mention now that you are aware of the issue. When an issue is reported, you work with the person to figure it out, you don't dismiss it. Once the full issue is identified, you look to improve your product or document where applicable, not say it's someone elses fault.

Overall, even if this critical information is added to the documentation, the attitude of the staff needs to be radically improved. I have never encountered this kind of rudeness from a vendor, and were I their manager I would fire sandervl73 and frank immediately for their complete lack of assistance and hostility to the users. It did not have to take 2 years and unknown alienated users to find the simple answer for this problem.

comment:25 Changed 3 years ago by frank

ebonweaver, I don't agree.

  1. Lets summarize that this was not a bug of VirtualBox but a bug of your BIOS or wrong BIOS settings. Your first accusation was that this is a bug of VirtualBox. You wrote: If this means that VB can not read the BIOS settings correctly, that is still a problem with VB, not an issue with the BIOS, especially when you are talking about a brand as large as Dell. You need to be able to work with them, not insist they change their BIOS configuration. This was definitely wrong, we always pointed you to the correct direction but you refused to believe us. We always said that something with your BIOS is wrong. Well, as we don't know your BIOS you really cannot expect that we find the one setting of your BIOS which must be toggled.
  2. You even wanted to make us believe that VMware can use VT-x while VirtualBox cannot. Another wrong statement.
  3. Many of your comments were dismissive. The whole attitude of your comments was that VirtualBox does it wrong, that it does not work (not even able to create proper log files) and that we have to investigate why it does not work.
  4. You cannot expect that we contact your BIOS vendor. Really not. Very comfortable for the user: Just let the vendors talk to each other, one of them is definitely guilty. Well, what answer do you expect to such requests? Thank you Mr. ebonweaver for the report, a technican is just calling Dell and is trying to figure out the problem. -- Hello? You cannot expect such support as non-paying customer.

Thank you for using VirtualBox!

comment:26 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme

comment:27 Changed 3 years ago by dawmail333

NOTICE:

I just had my VB return this error, and then I went through my processes and found a Windows Virtual PC process that was integrating with my system for XP Mode.

Moral of the story: Win 7 XP Mode can lock the VT-x/AMD-V etc.

So if your VM is not working, and you have XP Mode, try to kill it completely.

Hope that helped!

comment:28 follow-up: ↓ 29 Changed 3 years ago by h2oferko

Why don't you just enable the Intel Virtualization Technology option in your bios and forget the 'XP mode' and all the noob tricks?

comment:29 in reply to: ↑ 28 Changed 3 years ago by dawmail333

Replying to h2oferko:

Why don't you just enable the Intel Virtualization Technology option in your bios and forget the 'XP mode' and all the noob tricks?

Before calling people noobs, read. XP Mode was LOCKING AMD-V on my machine, which WAS ENABLED IN THE BIOS.

Don't give tl;dr replies. Read.

comment:30 Changed 3 years ago by virtualjp

I have the same problem, also on a Dell system (Optiplex 755 MT with an Core2Duo E6750, latest BIOS). I found a very good trouble-shooting page for VMWare, which contains a small bootable ISO image displaying the VT-x state. In the end I found out that it doesn't matter what option I set in the BIOS VT-x is always disabled.

 http://communities.vmware.com/docs/DOC-8978

comment:31 Changed 2 years ago by kai1

Not sure if it's already been covered, but:

FYI: I had this same issue (on host Ubuntu 11.10, Lenovo X220 laptop). It seemed to work at first and then fail on rebooting the VM..

Short ans: I had changed the number of processors to '2'; reverting it back to '1' caused VB to function correctly again..

So, there was really no BIOS issue in my case.. BUT making # processors > 1 in the Settings seems to trigger this problem (not that i've extensively checked :)

thus, is there still a problem/bug somewhere??

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use