VirtualBox

Ticket #4109 (closed defect: invalid)

Opened 5 years ago

Last modified 4 years ago

Default OS processes consuming lots of CPU during and after running VirtualBox - hard reset required.

Reported by: laitm Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

I recently noticed some strange behavior with my macbook pro where processes seem to consume lots of CPU for no apparent reason. The only common denominator seems to be VirtualBox.

Example

  • Boot into OSX launch VirtualBox and run a Win2003 Virtual machine - everything seems fine.
  • Download some OS updates for the VM (win2003) and lauch safari or firefox on the mac - everything seems fine
  • close/reopen safari a few times and launch system preferences - notice CPU % value of 125% in top. Close VM down and notice other processes consuming lots of CPU. Even top starts to report it's own process at about 30-40%. Idle CPU % values basically stay around 0-5% and the OS becomes unusable.

After rebooting the OS everything seems fine. At the moment I can't recreate the issue unless I run Virtualbox at some point.

Tested with VirtualBox version 2.2.2, 2.2.0, 2.1.4 (haven't tried previous versions) Tried with Mac OSX 2.5.6 and the latest update 2.5.7

Mac Details - OSX Version 10.5.7 Mem 8GB 667 Mhz DDR2 SDRAM Processor 2.4 Ghz Intel Core 2 Duo

Looks like some sort of race condition occurs on the default mac processes after using VBox.

Any help would be appreciated.

Attachments

Picture-2.jpg Download (291.1 KB) - added by laitm 5 years ago.

Change History

Changed 5 years ago by laitm

comment:1 Changed 5 years ago by laitm

Uploaded a picture showing top running at 15% and Finder at 80% (The only SW running is top and finder + a few items in the menu bar. Normally if I run this combo CPU idle is at > 90 %. Even if you close finder and load something else the CPU for that process seems to be v high (so it's not related to one particular process)

Everything was fine until I ran the "VBoxMnager clonehd" command. Seems you don't even have to launch a VM server to create the scenario.

This used to work fine on my mac.

The only difference is that I've added to 2x4GB DDR2 modules into the mix. However I'm not experiencing problems with any other apps.

comment:2 Changed 5 years ago by laitm

Removed 4GB and issue seems to be resolved.

comment:3 Changed 4 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use