VirtualBox

Ticket #4070 (closed defect: invalid)

Opened 5 years ago

Last modified 4 years ago

A cloned openSuse disk (clonehd) doesn't boot on Windows XP host

Reported by: lena Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: other
Host type: other

Description

A cloned disk doesn't boot (VBoxManage clonehd original.vdi clone.vdi). The original disk is a freshly build expandable disk with 30 GB size. The disk was created with default options using openSuse 11.1 installation DVD. Disk formatting is partition based.

Log files for sessions with the original and cloned disks are attached. Also attached is a screen shot for the failed boot.

Note:

Clones of Fedora 10 disks work fine (LVM formatting)

Attachments

Notes.zip Download (95.5 KB) - added by lena 5 years ago.
logs of sessions with clone and original vdis and failed boot screen shot

Change History

Changed 5 years ago by lena

logs of sessions with clone and original vdis and failed boot screen shot

comment:1 Changed 4 years ago by Technologov

  1. Please make sure both VMs are configured similarly.
  1. Retry with 3.2.0
  1. Try to use OVF VM Import/Export

-Technologov

comment:2 Changed 4 years ago by klaus

  • Status changed from new to closed
  • Resolution set to invalid

This is caused by openSUSE bolting itself to the hard disk serial number (which by default is derived from the disk image UUID). The documentation already mentions how one can override this hard disk serial number logic.

From my perspective it's plain silly to configure a system this way (not your fault, it's the SUSE people making this decision for you). The very same problem would happen on real hardware, e.g. if you copy the image of a failing disk to a new one.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use