VirtualBox

Ticket #4054 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Virtualbox 2.2.2 guest additions crashes OpenSolaris build 114 guest

Reported by: randshuntzinger Owned by:
Priority: critical Component: guest additions
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Solaris
Host type: Solaris

Description

I have a OpenSolaris (SXCE) build 114 host running VirtualBox 2.2.2 with the VDI kernel package built to resolve the problem in bug #3981. This works fine with all of the guests I have on this machine except for an OpenSolaris (SXCE) build 114 guest. This guest crashes if the guest additions are installed on it. If I remove the SUNWvboxguest package (and disable the service which didn't get removed for some reason) the guest will run. So the guest additions is causing the crash. The following is found in the messages file of the guest:

May 19 08:52:31 nevada Mpanic[cpu0]/thread=e0fd1780: May 19 08:52:31 nevada genunix: [ID 335743 kern.notice] BAD TRAP: type=e (#pf Page fault) rp=d68b4c00 addr=64 occurred in module "vboxguest" due to a NULL pointer dereference May 19 08:52:31 nevada unix: [ID 100000 kern.notice] May 19 08:52:31 nevada unix: [ID 839527 kern.notice] Xorg: May 19 08:52:31 nevada unix: [ID 753105 kern.notice] #pf Page fault May 19 08:52:31 nevada unix: [ID 532287 kern.notice] Bad kernel fault at addr=0x64 May 19 08:52:31 nevada unix: [ID 243837 kern.notice] pid=722, pc=0xf8a71989, sp=0x30, eflags=0x10292 May 19 08:52:31 nevada unix: [ID 211416 kern.notice] cr0: 8005003b<pg,wp,ne,et,ts,mp,pe> cr4: 698<xmme,fxsr,pge,pse,de> May 19 08:52:31 nevada unix: [ID 624947 kern.notice] cr2: dca42c4d May 19 08:52:31 nevada unix: [ID 625075 kern.notice] cr3: 36f9f000 May 19 08:52:31 nevada unix: [ID 100000 kern.notice] May 19 08:52:31 nevada unix: [ID 537610 kern.notice] gs: fe9501b0 fs: e3d90000 es: 160 ds: 160 May 19 08:52:31 nevada unix: [ID 537610 kern.notice] edi: 0 esi: d3076760 ebp: d68b4c54 esp: d68b4c38 May 19 08:52:31 nevada unix: [ID 537610 kern.notice] ebx: e3d97990 edx: e3d97990 ecx: 0 eax: 0 May 19 08:52:31 nevada unix: [ID 537610 kern.notice] trp: e err: 0 eip: f8a71989 cs: 158 May 19 08:52:31 nevada unix: [ID 717149 kern.notice] efl: 10292 usp: 30 ss: d3267210 May 19 08:52:31 nevada unix: [ID 100000 kern.notice] May 19 08:52:31 nevada genunix: [ID 353471 kern.notice] d68b4b3c unix:die+93 (e, d68b4c00, 64, 0) May 19 08:52:31 nevada genunix: [ID 353471 kern.notice] d68b4bec unix:trap+1430 (d68b4c00, 64, 0) May 19 08:52:31 nevada genunix: [ID 353471 kern.notice] d68b4c00 unix:cmntrap+7c (fe9501b0, e3d90000,) May 19 08:52:31 nevada genunix: [ID 353471 kern.notice] d68b4c54 vboxguest:RTProcSelf+11 (dd4df5c0, 0, d68b4c) May 19 08:52:31 nevada genunix: [ID 353471 kern.notice] d68b4c64 vboxguest:VBoxGuestCreateUserSession+1c (d69e55c0, d68b4c84,) May 19 08:52:31 nevada genunix: [ID 353471 kern.notice] d68b4c94 vboxguest:VBoxGuestSolarisOpen+82 (d68b4cf8, 2003, 2, ) May 19 08:52:32 nevada genunix: [ID 353471 kern.notice] d68b4cb4 genunix:dev_open+27 (d68b4cf8, 2003, 2, ) May 19 08:52:32 nevada genunix: [ID 353471 kern.notice] d68b4d14 specfs:spec_open+517 (d68b4dc8, 2003, e10) May 19 08:52:32 nevada genunix: [ID 353471 kern.notice] d68b4d54 genunix:fop_open+a2 (d68b4dc8, 2003, e10) May 19 08:52:32 nevada genunix: [ID 353471 kern.notice] d68b4e74 genunix:vn_openat+633 (843a120, 0, 2003, 1) May 19 08:52:32 nevada genunix: [ID 353471 kern.notice] d68b4f64 genunix:copen+403 (ffd19553, 843a120, ) May 19 08:52:32 nevada genunix: [ID 353471 kern.notice] d68b4f84 genunix:open64+20 (843a120, 2002, 180,) May 19 08:52:32 nevada unix: [ID 100000 kern.notice] May 19 08:52:32 nevada genunix: [ID 672855 kern.notice] syncing file systems... May 19 08:52:32 nevada genunix: [ID 904073 kern.notice] done May 19 08:52:44 nevada genunix: [ID 409368 kern.notice] M100% done: 123651 pages dumped, compression ratio 3.22, May 19 08:52:44 nevada genunix: [ID 851671 kern.notice] dump succeeded May 19 08:53:29 nevada genunix: [ID 540533 kern.notice] MSunOS Release 5.11 Version snv_114 32-bit May 19 08:53:29 nevada genunix: [ID 943908 kern.notice] Copyright 1983-2009 Sun Microsystems, Inc. All rights reserved. May 19 08:53:29 nevada Use is subject to license terms. May 19 08:53:29 nevada unix: [ID 126719 kern.info] features: 21046dff<cpuid,sse3,sse2,sse,pat,cx8,mca,mmx,cmov,de,pge,mtrr,msr,tsc,lgpg> May 19 08:53:29 nevada unix: [ID 168242 kern.info] mem = 1572412K (0x5ff8f000) May 19 08:53:29 nevada genunix: [ID 723599 kern.warning] WARNING: Driver alias "usb403,e88c" conflicts with an existing driver name or alias. May 19 08:53:29 nevada genunix: [ID 107833 kern.warning] WARNING: Missing " on line 1130 of /etc/driver_aliases May 19 08:53:29 nevada acpica: [ID 565230 kern.notice] ACPI: RSDP @ 0xe0000/0x0024 (v 2 VBOX ) May 19 08:53:29 nevada acpica: [ID 258974 kern.notice] ACPI: XSDT @ 0x5fff0030/0x002C (v 1 VBOX VBOXXSDT 0x00000001 ASL 0x00000061) May 19 08:53:29 nevada acpica: [ID 831520 kern.notice] ACPI: FACP @ 0x5fff0060/0x00F4 (v 4 VBOX VBOXFACP 0x00000001 ASL 0x00000061) May 19 08:53:29 nevada acpica: [ID 234198 kern.notice] ACPI: DSDT @ 0x5fff01a0/0x18A9 (v 1 VBOX VBOXBIOS 0x00000002 INTL 0x20061011) May 19 08:53:29 nevada acpica: [ID 814940 kern.notice] ACPI: FACS @ 0x5fff0160/0x0040

I have attached the VBox.log file showing the problem. What I did to create the log was set a boot environment without active guest additions as the default boot environment and then boot the system selecting an entry with the guest additions from the grub menu. The guest booted, crashed and then rebooted using the system without the guest environment. So the log shows a crashing boot followed by a successful boot - albeit without guest additions.

Attachments

VBox.log.problem Download (51.4 KB) - added by randshuntzinger 5 years ago.
VBox log containing a boot where the guest crashed

Change History

Changed 5 years ago by randshuntzinger

VBox log containing a boot where the guest crashed

comment:1 Changed 5 years ago by jkeil2

The root cause for this problem is probably the same as bug #3981, but this time the guest kernel module (vboxguest) is affected.

The putback for bug 6565817 "sigwait can't wait for SIGTSTP" has changed the Solaris kernel data structure kthread_t.  http://bugs.opensolaris.org/view_bug.do?bug_id=6565817

I guest vboxguest is directly accessing kthread_t data structures; the fix should be similar to the one for bug #3981...

comment:2 Changed 5 years ago by ramshankar

This is fixed in 2.2.4 and backported to older versions. Upgrade the additions should fix it. Reopen if necessary.

comment:3 Changed 5 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use